Opened 11 years ago

Closed 10 years ago

#4783 closed defect

Custom status messages are not always displayed

Reported by: db Owned by: datallah
Milestone: Component: Bonjour
Version: 2.3.1 Keywords:
Cc:

Description

I have two XP machines, A and B, with Pidgin 2.3.1 on. They see each other via Bonjour.

A has a custom away message "Spriten räddade mig från golfen". When opening a IM-window with A on B, this message is visible.

B has several custom away messages, e.g., "Lunch" and "Knark - ett lätt sätt att umgås". When B's status is set to the first message above A can see the custom message but when B's status is set to the latter message it is not visible to A.

Change History (18)

comment:1 Changed 11 years ago by datallah

  • Component changed from unclassified to Bonjour
  • Owner changed from lschiere to datallah

comment:2 follow-up: Changed 11 years ago by db

I can add another data point to my initial report; this specific custom status message doesn't seem to work over Jabber (Google Talk) either.

comment:3 in reply to: ↑ 2 Changed 11 years ago by francisd

Replying to db:

I can add another data point to my initial report; this specific custom status message doesn't seem to work over Jabber (Google Talk) either.

I confirm that. Status message are not working on any Jabber server (not Google Talk specific). It worked on Pidgin 2.2.1 (Ubuntu 7.10) but this doesn't work anymore on 2.4.1 (Ubuntu 8.04).

Should I open a new ticket specific to the Jabber protocol are this bug is related to this one ?

comment:4 follow-up: Changed 11 years ago by deryni

Copying and pasting both of those messages from this ticket worked just fine for me a moment ago on one of my Google Talk accounts.

francisd: How are you testing that this isn't working? If you open the Debug Window before you try to use those messages do you see pidgin send the outgoing <presence> stanza with the correct text?

comment:5 in reply to: ↑ 4 Changed 11 years ago by francisd

francisd: How are you testing that this isn't working?

The contact just don't see my status message. I don't see it either on my server's webadmin interface (Openfire).

If you open the Debug Window before you try to use those messages do you see pidgin send the outgoing <presence> stanza with the correct text?

The <presence> is sent, but don't content the message.

(14:04:24) jabber: Sending (ssl): <presence><show>away</show><c xmlns='http://jabber.org/protocol/caps' node='http://pidgin.im/caps' ver='2.4.1' ext='mood moodn nick nickn tune tunen avatarmeta avatardata avatar'/></presence>

comment:6 follow-up: Changed 11 years ago by deryni

Did you copy and paste the messages from here or did you type them in? If you typed them in can you try copy and pasting them? Do messages without accented characters work? Does this problem affect both away and available messages? I'm assuming once you try to set the message you see the message correctly in the entry box at the bottom of the buddy list, is that correct?

comment:7 in reply to: ↑ 6 Changed 11 years ago by francisd

Replying to deryni:

Did you copy and paste the messages from here or did you type them in? If you typed them in can you try copy and pasting them? Do messages without accented characters work? Does this problem affect both away and available messages? I'm assuming once you try to set the message you see the message correctly in the entry box at the bottom of the buddy list, is that correct?

I found that the bug seem to occurs only when I use accented characters. And yes the message always appear on the bottom of my buddy list.

comment:8 follow-up: Changed 11 years ago by deryni

You answered two of my five questions, can you please answer the other questions as well? Namely: Did you copy and paste or type the messages? If you typed them try pasting them and report what happens. Does this happen to both away and available messages?

Thank you.

comment:9 in reply to: ↑ 8 Changed 11 years ago by francisd

Replying to deryni:

Did you copy and paste or type the messages?

No I type the messages.

If you typed them try pasting them and report what happens.

No changes.

Does this happen to both away and available messages?

Only to away.

I think accented characters are not enough to reproduce the bug. If my message is only "à", it's ok, but if my message is "Pas là", the message is not sent.

ehhhh... (just before submitting this message) wtf I cannot reproduce the bug with "Pas là" as my message. I restarted Pidgin and still working (even tried on another computer)... very strange... it doesn't worked some minutes ago when I did tests again to answers your others questions... No, I'm not crazy, this bug was here :D

comment:10 Changed 11 years ago by deryni

So are you now unable to reproduce the bug at all? Or is only that specific message not a problem?

comment:11 Changed 11 years ago by db

I can still confirm this problem as described in the initial report (a semilong message with 8-bit characters over bonjour) and it is independent of "cut'n'paste" or typing it in (what that has to do with anything - feels more like ignorant americans unused to accents).

comment:12 Changed 11 years ago by deryni

Congratulations db, any desire I may have had to help you is now gone, insulting the people who are trying to help is generally not a good idea (especially when you don't know what you are talking about). Good luck with your problem.

francisd, if your problem persists please feel free to file a new ticket on it so that I can continue helping you.

comment:13 Changed 11 years ago by db

Ooh, hit me where it hurts. I hope you don't mind me stopping donating money to the pidgin project after this? Cut'n'paste strings, yeah yeah.

comment:14 Changed 11 years ago by deryni

It was not my intention to hit or hurt you, merely to point out that your unhelpful insulting attitude is unlikely to win you any favor from the people you are insulting (and when you are simultaneously asking those people for help don't expect them to care to keep helping).

Also I find it unlikely that you have been donating money to pidgin up to this point as we have no way of accepting such donations that I am aware of yet.

comment:15 Changed 11 years ago by bernmeister

In the interests of diplomatic relations, can this ticket be closed?

comment:16 Changed 11 years ago by db

The problem is still there with the most recent version of pidgin...

comment:17 Changed 11 years ago by datallah

  • Status changed from new to pending

2.5.2 includes a fix to truncate TXT entries that are too long, I bet it'll also fix this.

Please test with 2.5.2

comment:18 Changed 10 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!