Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#485 closed defect

MSN connection problem

Reported by: ravennolonger Owned by: nosnilmot
Milestone: Component: MSN
Version: 2.0.2 Keywords:
Cc:

Description (last modified by lschiere)

Using Pidgin 2.0 Beta 7 I am receiving this error when trying to connect to my MSN account at work. I however can connect to that same MSN account using Trillian. I would rather use Pidgin. Can someone please look at this debug and tell me if there is a way to fix it? Is this a MSN client version problem, and the one Pidgin is based on is not working where trillian is based on a newer version of the MSN client?

account: Connecting to account xxxxxxx@hotmail.com
connection: Connecting. gc = 017E1018
msn: new httpconn (017F5BD0)
dnsquery: Performing DNS lookup for messenger.hotmail.com
dnsquery: IP resolved for messenger.hotmail.com
proxy: Attempting connection to 207.46.28.93
proxy: Connecting to messenger.hotmail.com:1863 with no proxy
proxy: Connection in progress
proxy: Connected to messenger.hotmail.com:1863.
msn: C: NS 000: VER 1 MSNP9 MSNP8 CVR0
msn: S: NS 000: VER 1 MSNP9 MSNP8 CVR0
msn: C: NS 000: CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 6.0.0602 MSMSGS loueyknew@hotmail.com
msn: S: NS 000: CVR 2 8.1.0178 8.1.0178 6.2.0208 http://msgr.dlservice.microsoft.com/download/1/A/4/1A4FEB1A-18E0-423A-B898-F697402E4F7F/Install_Messenger.exe http://messenger.msn.com
msn: C: NS 000: USR 3 TWN I xxxxxxx@hotmail.com
msn: servconn read error, len: 0 error: Windows socket error #10036
msn: Connection error from Notification server (messenger.hotmail.com): Reading error
msn: C: NS 000: OUT
account: Disconnecting account 00CAC3B8
connection: Disconnecting connection 017E1018
msn: destroy httpconn (017F5BD0)
connection: Destroying connection 017E1018

Attachments (3)

pidgin-msn_connection_error.log (1.4 KB) - added by marcoshack 12 years ago.
Log file of a little diferent error related to MSN connection problem
pidgin-2.2.0-msn-connection-error.log (4.3 KB) - added by DugieHowsa 11 years ago.
pidgin.log (29.2 KB) - added by joske 11 years ago.
log of msn (and gtalk) conversation

Download all attachments as: .zip

Change History (55)

comment:1 Changed 12 years ago by lschiere

  • Component changed from pidgin (gtk) to libpurple
  • Description modified (diff)
  • Owner set to nosnilmot

comment:2 Changed 12 years ago by nosnilmot

  • pending changed from 0 to 1

Do you use a software firewall? If you do, does Pidgin work if you turn it off?

comment:1 Changed 12 years ago by trac-robot

  • pending changed from 1 to 0
  • Status changed from new to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:2 Changed 12 years ago by datallah

  • pending changed from 0 to 1
  • Status changed from closed to reopened

Sorry, this was accidentally closed.

comment:3 Changed 12 years ago by ravennolonger

  • pending changed from 1 to 0

Turning off sw firewall doesn't help, same error. I'm wondering if the hardware firewall at work is doing something with the MSN version (blocking anything below say version 8.0) that pidgin is based on compared to what trillian uses for MSN, since trillian's MSN works ok. Any idea what MSN client version trillian is using for it's MSN connection?

comment:4 Changed 12 years ago by nosnilmot

  • pending changed from 0 to 1

Try using the HTTP method (Accounts -> msn account -> Edit Account -> Advanced -> "Use HTTP Method")

comment:5 Changed 12 years ago by ravennolonger

  • pending changed from 1 to 0

No go, still won't connect even with the HTTP method.

comment:6 Changed 12 years ago by lschiere

  • Milestone set to Merge MSNP14 Branch

comment:7 Changed 12 years ago by MarkDoliner

Hmm. When you tried turrning off the sw firewall? Did you disable it, or did you kill it completely? I'm wondering if Pidgin would connect if the firewall is killed completely? Also, what kind of firewall is it?

comment:8 Changed 12 years ago by ravennolonger

What does "set to Merge MSNP14 Branch" mean? Does that mean this will be fixed in the next code release? And is the version of the MSN client Pidgin is based on changing to a more newer version?

As for the sw firewall, I made sure it didn't even start. I don't think that is the problem, because even with my sw fw running Trillian and MSN work fine and have worked all along. I believe our fw guys are blocking certain MSN client from getting through the hw fw, hence Trillian works and Pidgin doesn't so i'm just assuming Pidgin is using an older version of the MSN client than what Trillian is.

comment:9 Changed 12 years ago by nosnilmot

"Merge MSNP14 Branch" is our target milestone for when we merge the new protocol support code into mainline. You can see our milestones on our Roadmap

You are correct that Pidgin currently uses an older version of the MSN protocol (MSNP9), and I suppose it is possible that your corporate firewall is blocking this.

However, the error code reported (10036) is apparently for "Operation now in progress.", which I would not expect to see in response to an external firewall blocking a connection.

Software firewalls are mysterious beasts, and often block/permit the same ports differently depending on the application trying to establish the connection, or otherwise interfere with connections in strange ways. Is there any chance you can reproduce this on a PC in the same location that doesn't even have a software firewall installed? (yes, some software firewalls interfere even when not set to start).

comment:10 Changed 12 years ago by ravennolonger

Yes, same problem occurs on a different machine that doesn't have any sw fw installed. And same results, Pigin MSN doesn't work whereas Trillian does. And boy I miss Pigin/Gaim? :-(

comment:13 Changed 12 years ago by datallah@…

(In a1e49bdf5d79109f7becf1a5b25ab023070524c9) Pretend that WSAEINPROGRESS is EAGAIN (for our purposes, I think they are equivalent). I think this might help #485. References #485.

comment:14 Changed 12 years ago by nosnilmot

  • Milestone changed from Merge MSNP14 Branch to 2.0.2
  • Resolution set to fixed
  • Status changed from reopened to closed

Hopefully datallah's change will make this work, if it's still a problem in 2.0.2 (due out on Thursday), comment here and I'll reopen this ticket.

comment:15 follow-up: Changed 12 years ago by MarkDoliner

I liked the change datallah made for this. This statement doesn't really have a purpose.

comment:16 follow-up: Changed 12 years ago by ravennolonger

I just tried 2.0.2 same thing:

(14:51:27) util: Writing file accounts.xml to directory C:\Documents and Settings\user\Application Data\.purple (14:51:27) util: Writing file blist.xml to directory C:\Documents and Settings\user\Application Data\.purple (14:51:58) autorecon: do_signon called (14:51:58) autorecon: calling purple_account_connect (14:51:58) account: Connecting to account user@… (14:51:58) connection: Connecting. gc = 01581E80 (14:51:58) msn: new httpconn (01583A10) (14:51:58) dnsquery: Performing DNS lookup for messenger.hotmail.com (14:51:58) autorecon: done calling purple_account_connect (14:51:58) dnsquery: IP resolved for messenger.hotmail.com (14:51:58) proxy: Attempting connection to 207.46.28.93 (14:51:58) proxy: Connecting to messenger.hotmail.com:1863 with no proxy (14:51:58) proxy: Connection in progress (14:51:59) proxy: Connected to messenger.hotmail.com:1863. (14:51:59) msn: C: NS 000: VER 1 MSNP9 MSNP8 CVR0 (14:51:59) msn: S: NS 000: VER 1 MSNP9 MSNP8 CVR0 (14:51:59) msn: C: NS 000: CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 6.0.0602 MSMSGS user@… (14:51:59) msn: S: NS 000: CVR 2 8.1.0178 8.1.0178 6.2.0208 http://msgr.dlservice.microsoft.com/download/1/A/4/1A4FEB1A-18E0-423A-B898-F697402E4F7F/Install_Messenger.exe http://messenger.msn.com (14:51:59) msn: C: NS 000: USR 3 TWN I user@… (14:52:00) msn: servconn read error, len: 0 error: Windows socket error #10036 (14:52:00) msn: Connection error from Notification server (messenger.hotmail.com): Reading error (14:52:00) msn: C: NS 000: OUT (14:52:00) account: Disconnecting account 0150A820 (14:52:00) connection: Disconnecting connection 01581E80 (14:52:00) msn: destroy httpconn (01583A10) (14:52:00) connection: Destroying connection 01581E80 (14:52:03) util: Writing file accounts.xml to directory C:\Documents and Settings\user\Application Data\.purple (14:52:03) util: Writing file blist.xml to directory C:\Documents and Settings\user\Application Data\.purple

comment:17 Changed 12 years ago by datallah

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hmm... that is a little surprising.

Are you positive that this is with 2.0.2?

comment:18 Changed 12 years ago by ravennolonger

yep, actually uninstalled the previous version 2.0.1, rebooted then installed 2.0.2 to be sure.

comment:19 Changed 12 years ago by lschiere

  • Milestone changed from 2.0.2 to 2.1.2
  • Version changed from 2.0 to 2.0.2

Changed 12 years ago by marcoshack

Log file of a little diferent error related to MSN connection problem

comment:20 Changed 12 years ago by marcoshack

Hi guys, I added a debug log file of an error that is a little different of the original description. On my case the problem happen intermittently. I hope that it helps to solve the problem.

Regards.

comment:21 Changed 12 years ago by swingtan

Hi All, I may have a work around for this problem. I was getting the same types of errors when using Pidgin ( both 2.0 and 2.1 ) from behind a proxy server. Windows Live Messenger 8.1 worked fine, but Pidgin reported both reading and writing errors depending on how often I tried. While looking into a problem I was having with Opera Internet Browser and NTLM authentication, I came across this information...

http://my.opera.com/Tamil/blog/proxy-server-authentication-problem-with-opera

Which is an NTLM authorising proxy. After installing this, and setting my MSN proxy settings as described in the link above, MSN is working fine behind the proxy server. While not being a complete fix, it does offer a work around for those in the same situation as me.

Simon.

comment:22 Changed 12 years ago by bristmi

I am having this same issue. I believe it is the same issue as Ticket #413, or at least related.

The fix was slated to be in milestone 2.1.1, but was pushed back to 2.1.2. Can the powers that be work to get this into 2.1.2?

comment:23 Changed 12 years ago by pjbcr

Hello, I was getting the MSN reading error, while trying to connect no MSN at work behind a firewall. Now i manage to conect only by replacing the messenger.hotmail.com by the ip 65.54.239.140, w/o using the HTTP method.

Can you guys try to see if works with you also?

comment:24 follow-up: Changed 12 years ago by sadrul

  • pending changed from 0 to 1

I believe this is fixed in 2.2.0.

comment:25 in reply to: ↑ 24 Changed 12 years ago by jacob733

Replying to sadrul:

I believe this is fixed in 2.2.0.

I believe this as well. I used to have this problem, but after installing 2.2.0, I can connect through my work proxy fine.

comment:26 Changed 12 years ago by seanegan

  • Component changed from libpurple to MSN

comment:27 Changed 11 years ago by DugieHowsa

I have 2.2.0 installed and can confirm the problem still exists. Attached is debug with the HTTP method button both checked and unchecked.

Changed 11 years ago by DugieHowsa

comment:1 Changed 11 years ago by trac-robot

  • pending changed from 1 to 0
  • Status changed from reopened to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:2 Changed 11 years ago by MarkDoliner

  • Status changed from closed to reopened

comment:3 Changed 11 years ago by joske

I'm having the same problems. Strange thing is, that it worked yesterday and the previous week, but today no go. amsn can connect using HTTP method, but piding can not.

comment:4 Changed 11 years ago by joske

sorry, forgot the version, this was on 2.2.1 on ubuntu gutsy.

Changed 11 years ago by joske

log of msn (and gtalk) conversation

comment:5 Changed 11 years ago by thc0

I'm have this same problem too :/ Please take more attention to this bug...

Thanks!

comment:6 Changed 11 years ago by joske

In my case it is fixed again. On Tuesday it did not work, Wednesday and today it works again, so I guess it was a glitch on the MSN network affecting only HTTP, and maybe only specific servers (load-balancing).

comment:7 Changed 11 years ago by DugieHowsa

Issue still exists in 2.2.2 with with the HTTP method button both checked and unchecked.

comment:8 Changed 11 years ago by carlosgames

If this is a MSN Network glitch, it only affects amsn and pidgin, Trillian and miranda work just OK.

comment:9 Changed 11 years ago by jernst

comment:10 Changed 11 years ago by bristmi

Yes. issue still exists in 2.2.2.

My MSN client can connect behind corp firewall, but pidgin cannot.

comment:11 follow-up: Changed 11 years ago by bristmi

Just downloaded 2.3.0. Issue still exists!

comment:12 in reply to: ↑ 11 ; follow-up: Changed 11 years ago by leekaho

Replying to bristmi:

Just downloaded 2.3.0. Issue still exists!

I have got the exactly message as yours. However, this issue appears since I upgrade my Pidgin to 2.3.0 from 2.2.2, i.e. never shown before.

comment:13 in reply to: ↑ 12 Changed 11 years ago by nosnilmot

Replying to leekaho:

Replying to bristmi:

Just downloaded 2.3.0. Issue still exists!

I have got the exactly message as yours. However, this issue appears since I upgrade my Pidgin to 2.3.0 from 2.2.2, i.e. never shown before.

You are probably hitting #4066 or #4103 then.

comment:14 Changed 11 years ago by carlosgames

still happens at 2.3.1 the issue is like this here:

Trillian and MSN Messenger can just connect without having to configure the client network connection.

Miranda connects just right after setting the correct proxy configuration

Pidgin and Amsn can't connect even after setting the correct configuration manually

(here we are behind a proxy and a firewall which uses the windows domain authentication to get connected)

comment:15 follow-up: Changed 11 years ago by leighahall

having trouble connecting to MSN network as well.

Using linux (Kubuntu 7.04 and 7.10) with GAIM, aMSN, Kopete. None will connect to the msn network.

Using Windows Vista with Pidgin, I can't connect to the MSN network either (I will include some debug info below). However, using Vista with MS Live Messenger, I am able to connect successfully. I can connect to AIM and GoogleTalk? using Pidgin though.

So, it appears that ANY program other than the MS one cannot connect. But it doesn't appear to be a network problem, since the MS client can get through.

debug information from Pidgin

(14:29:13) account: Connecting to account xxxxxxxx@hotmail.com/home
(14:29:13) connection: Connecting. gc = 02DF84D8
(14:29:13) msn: new httpconn (046F6378)
(14:29:13) purple_url_encode: assertion `str != NULL' failed
(14:29:13) dnsquery: Performing DNS lookup for messenger.hotmail.com
(14:29:13) dnsquery: IP resolved for messenger.hotmail.com
(14:29:13) proxy: Attempting connection to 65.54.239.140
(14:29:13) proxy: Connecting to messenger.hotmail.com:1863 with no proxy
(14:29:13) proxy: Connection in progress
(14:29:14) proxy: Connected to messenger.hotmail.com:1863.
(14:29:14) proxy: Error connecting to messenger.hotmail.com:1863 (Unknown error).
(14:29:14) proxy: Connection attempt failed: Unknown error
(14:29:14) msn: Connection error: Unknown error
(14:29:14) msn: Connection error from Notification server (messenger.hotmail.com): Unable to connect
(14:29:14) account: Disconnecting account 003BE6F8
(14:29:14) connection: Disconnecting connection 02DF84D8
(14:29:14) msn: destroy httpconn (046F6378)

end debug info

please let me know if I can provide any more debug info

comment:16 in reply to: ↑ 15 ; follow-up: Changed 11 years ago by datallah

Replying to leighahall:

having trouble connecting to MSN network as well.

Using linux (Kubuntu 7.04 and 7.10) with GAIM, aMSN, Kopete. None will connect to the msn network.

So, it appears that ANY program other than the MS one cannot connect. But it doesn't appear to be a network problem, since the MS client can get through.

It is actually a network problem. Pidgin is unable to connect to messenger.hotmail.com on port 1863 - that is the source of the problem. That the native client can still connect means that it is using one of the fallback connection methods for restrictive networks. Pidgin doesn't do this automatically, but you can try the "HTTP Method" checkbox in the "Advanced" section of the account setup to see if that'll let you connect.

comment:17 in reply to: ↑ 16 Changed 11 years ago by leighahall

Replying to datallah:

It is actually a network problem. Pidgin is unable to connect to messenger.hotmail.com on port 1863 - that is the source of the problem. That the native client can still connect means that it is using one of the fallback connection methods for restrictive networks. Pidgin doesn't do this automatically, but you can try the "HTTP Method" checkbox in the "Advanced" section of the account setup to see if that'll let you connect.

thanks for your help. the HTML method doesn't work either. here is the debug output in case you want to see it

Connecting to account xxxxxxxx@hotmail.com/home
(20:15:06) connection: Connecting. gc = 0457DB48
(20:15:06) msn: new httpconn (036158C8)
(20:15:06) purple_url_encode: assertion `str != NULL' failed
(20:15:06) dnsquery: Performing DNS lookup for gateway.messenger.hotmail.com
(20:15:06) msn: C: NS 000: VER 1 MSNP9 MSNP8 CVR0
(20:15:06) dnsquery: IP resolved for gateway.messenger.hotmail.com
(20:15:06) proxy: Attempting connection to 65.54.239.211
(20:15:06) proxy: Connecting to gateway.messenger.hotmail.com:80 with no proxy
(20:15:06) proxy: Connection in progress
(20:15:06) proxy: Connected to gateway.messenger.hotmail.com:80.
(20:15:07) msn: Connection error from Notification server (gateway.messenger.hotmail.com): Reading error
(20:15:07) msn: C: NS 000: OUT
(20:15:07) account: Disconnecting account 01378FD0
(20:15:07) connection: Disconnecting connection 0457DB48
(20:15:07) msn: destroy httpconn (036158C8)

I have a working theory that this may be related to Belkin routers. have you experienced anything similar? I have just switched from a zoom x6 that allowed messenger to work fine for all clients, but now with the belkin 54g I have these problems...do you have any ideas around this? I have tried playing with the MTU settings on my linux box, but without success :(

Thanks, Leigh

comment:18 Changed 11 years ago by DugieHowsa

The problem is with how Pidgin implements the MSN protocol. I have had this problem when using Pidgin in corporate environments that monitor/manipulate chat protocols at the network perimiter. I'm hoping that "Milestone Activate MSNPV14" will resolve this issue, but I'm not holding my breath.

In the mean time, if you are looking for a multiple-protocol chat client, use Trillian from Cerulean Studios. It works for me where Pdigin fails. I am continuing to use it until the MSN protocol issue is resolved in Pidgin.

comment:19 Changed 11 years ago by malmostoso

I noticed the milestone for this bug has been moved from 2.4.1 to unknown... please don't forget about it, I'm sick of using Miranda at work :)

comment:20 Changed 11 years ago by bristmi

I just installed 2.4.1, and my connection issues at work are now resolved! Can anyone else verify?

comment:21 Changed 11 years ago by DugieHowsa

Confirmed. MSN chat works like a champ now in 2.4.1 in my corporate environment. Great work developers! Many thanks!

comment:22 Changed 11 years ago by QuLogic

  • pending changed from 0 to 1

Let's hope this fixes things for the original reporter as well. I'll leave this open till then.

comment:23 Changed 11 years ago by malmostoso

2.4.1 here did not solve the problem. I am behind a quite restrictive proxy, but Miranda can connect using HTTP method. Here is the debug log (only the part relative to the connection):

(09:35:52) account: Connecting to account XXXXXXXXXXXXXX@hotmail.com
(09:35:52) connection: Connecting. gc = 019D2D30
(09:35:52) msn: new httpconn (019D2D88)
(09:35:52) dnsquery: Performing DNS lookup for gateway.messenger.hotmail.com
(09:35:52) msn: C: NS 000: VER 1 MSNP9 MSNP8 CVR0
(09:35:52) prefs: /pidgin/blist/width changed, scheduling save.
(09:35:52) prefs: /pidgin/blist/height changed, scheduling save.
(09:35:52) prefs: /pidgin/blist/width changed, scheduling save.
(09:35:52) prefs: /pidgin/blist/height changed, scheduling save.
(09:35:52) dnsquery: IP resolved for gateway.messenger.hotmail.com
(09:35:52) proxy: Attempting connection to 207.46.96.154
(09:35:52) proxy: Connecting to gateway.messenger.hotmail.com:80 with no proxy
(09:35:52) proxy: Connection in progress
(09:35:52) proxy: Connected to gateway.messenger.hotmail.com:80.
(09:35:53) msn: S: NS 000: VER 1 MSNP9 MSNP8 CVR0
(09:35:53) msn: C: NS 000: CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 6.0.0602 MSMSGS XXXXXXXXXXXXX@hotmail.com
(09:35:53) msn: Connection error from Notification server (gateway.messenger.hotmail.com): Reading error
(09:35:53) msn: C: NS 000: OUT
(09:35:53) account: Disconnecting account 00C42108
(09:35:53) connection: Disconnecting connection 019D2D30
(09:35:53) msn: destroy httpconn (019D2D88)
(09:35:53) connection: Destroying connection 019D2D30

Maybe this helps: I have tried pinging 207.46.96.154 and I can't access it:

C:\Program Files\Pidgin>ping 207.46.96.154

Pinging 207.46.96.154 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 207.46.96.154:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Just ask for any additional info you might need. This is taken on WinXP but I also have a linux machine available (which does not connect either) if you think it might me easier to debug. Thanks for your help guys!

comment:51 Changed 11 years ago by trac-robot

  • pending changed from 1 to 0
  • Status changed from reopened to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:52 Changed 11 years ago by gbudo

Was this issue ever fixed? Just curious.. I'm also having the same issue.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!