Opened 11 years ago

Closed 10 years ago

#4884 closed defect (duplicate)

Perl simple plugin makes pidgin crash

Reported by: ecik Owned by: deryni
Milestone: Component: unclassified
Version: 2.3.1 Keywords:
Cc:

Description

I have already told about it on IRC channel, however I think it may be a good idea to post this bug here too. I wanted to do a perl plugin and I encounted a problem with segfault. Segfault happens when I click right mouse button on chat or group, NOT when I click on contact. I'm attaching trackback and script I've written.

Attachments (2)

abc.pl (805 bytes) - added by ecik 11 years ago.
plugin
pidgin-bugreport.txt (14.3 KB) - added by ecik 11 years ago.
trackback

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by ecik

plugin

Changed 11 years ago by ecik

trackback

comment:1 Changed 11 years ago by datallah

One issue here is that the Perl plugin support isn't going to work for that signal because we don't translate the GList to/from a corresponding Perl type.

It doesn't crash for me though (and I don't see why it would crash when trying to get the convert the Blist Node pointer to a perl object).

comment:2 Changed 10 years ago by lschiere

  • Status changed from new to pending

If it only crashes with this perl plugin, and if we don't distribute that plugin, then this is really a problem for the plugin's author.

comment:3 Changed 10 years ago by zdeqb

My intuition says this is a duplicate of #7404 and #3775 (or vice versa)

All three reports crash around perl_signal_cb, and are 64bit... but my intuition's been wrong before :-P

#7404 contains a workaround...

comment:4 Changed 10 years ago by deryni

  • Owner changed from lschiere to deryni

comment:5 Changed 10 years ago by deryni

  • Resolution set to duplicate
  • Status changed from pending to closed

Closed as duplicate of #7404.
I agree with zdeqb, this looks like a duplicate of #7404 to me as well. ecik if you apply the patch in #7404 (or wait for 2.5.4) and still get this crash please re-open this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!