Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#4965 closed defect (fixed)

icq problem receiving messages

Reported by: Sim-on Owned by: MarkDoliner
Milestone: 2.4.1 Component: ICQ
Version: 2.4.0 Keywords:
Cc: xtonda

Description

(Es gab einen Fehler beim Empfang dieser Nachricht. Entweder haben Sie und 335383808 unterschiedliche Kodierungen gesetzt oder 335383808 hat einen fehlerhaften Client.)

(there was an error with the receipt of this message. Either you and 335383808 different coding set or 335383808 have an incorrect Client.)

this is now second person where i get this all the time.

in 2.3.1 i was able to talk with this persons without problems!!

Attachments (1)

pidginerr.png (117.6 KB) - added by xtonda 11 years ago.
Pidgin GTK+ issue

Download all attachments as: .zip

Change History (39)

comment:1 Changed 11 years ago by ansmeer

I can confirm that - it seems as if there's a problem with umlauts (which we tend to use very often in germany ;))

comment:2 Changed 11 years ago by Sim-on

#4968 is similar

comment:3 Changed 11 years ago by ansmeer

You (respectively the person you're talking to) can solve the problem by disabling unicode in his options. But I guess that can't be the final solution...

comment:4 Changed 11 years ago by Sim-on

yeah but this isnt nice solution to tell a huge number of people to change their options. until this i will go on using 2.3.1 with old GTK...

comment:5 Changed 11 years ago by datallah

  • Component changed from unclassified to ICQ
  • Owner changed from lschiere to MarkDoliner

comment:6 follow-up: Changed 11 years ago by MarkDoliner

What operating system are you guys using?

comment:7 Changed 11 years ago by msfranky

I too have this problem. I use WinXP SP2 and i think problem is in GTK because only after rewrite on new version come this problem. Btw. 25 min. ago i installed 2.4.0 pidgin

comment:8 Changed 11 years ago by msfranky

yes i uninstall GTK an asspell and install 2.4.0 again and it works!

comment:9 Changed 11 years ago by lcg

Confirmed this issue with a friend on ICQ, who is using Trillian on Vista. I am using Pidgin, also on Vista. My account was set to CP1251, changing it to UTF-8 did not solve the problem.

Downgrading to 2.3.1 didn't solve the problem, downgrading GTK+ did. With the older GTK+, I can also use Pidgin 2.4.0 without problems.

(The bug is probably the same as #4968, sorry for crossposting this comment.)

comment:10 in reply to: ↑ 6 Changed 11 years ago by Sim-on

Replying to MarkDoliner:

What operating system are you guys using?

Win XP SP 2

comment:11 follow-up: Changed 11 years ago by dsi

Same thing here. I consider this a major defect! It is very disturbing asking my conversation partner to type his messages without ö, ä, ü and ß! A quick solution of this problem would be much appreciated.

comment:12 in reply to: ↑ 11 Changed 11 years ago by ansmeer

Replying to dsi:

Same thing here. I consider this a major defect! It is very disturbing asking my conversation partner to type his messages without ö, ä, ü and ß! A quick solution of this problem would be much appreciated.

If jou want a temporaray, but quick solution, you can downgrade your GTK+ (I used the old one from my last Pidgin Portable build) so you can use the newest version of Pidgin. That's what I did and it works fine. :)

Btw, I'm using Win XP SP2, too. And, don't know if this is important, but I use the Portable edition by portableapps.com.

comment:13 Changed 11 years ago by Seamas

I confirm this bug with sending and receiving messages with cyrillic letters

comment:14 Changed 11 years ago by webmeister

This bug does not always seem to be related to special characters. I wasn't able to receive any messages from someone using QIP 2005 Build 8040. Using 2.3.1 with the old GTK+, there was no problem.

comment:15 follow-up: Changed 11 years ago by fafer

Please change priority to major!

ICQ in Pidgin 2.4 is unusable with this issue! Any message containing any special char is lost (in german this is about half of all messages) Maybe check if it's an GTK+ bug, or an API-problem

comment:16 in reply to: ↑ 15 Changed 11 years ago by msfranky

Yes this is real problem and for non-english user is icq on pidgin unusable

comment:17 follow-up: Changed 11 years ago by datallah

This appears to be related to the updated GTK+ runtime included with 2.4.0 on Windows. You can revert to GTK+ 2.12.1 Rev. B for now.

comment:18 Changed 11 years ago by MarkDoliner

For all non-Windows users... what version of gettext are you using?

comment:19 Changed 11 years ago by vvs

This is a serious issue for me too. Basically, I can't communicate with most of my non-English speaking friends now! I'm on Vista x64. This is definitely not a "minor" defect, this is a critical show-stopper worthy of out-of-cycle update release.

comment:20 follow-up: Changed 11 years ago by rmaryan

This bug is even worse that I expected. If you happened to use "Last Said" feature it might destroy your buddy list.

In my case, lines like the following were recorded to my blist.xml:

<setting name="lastsaid" type="string">&#x4;x4;=&#x4;x4;C (There was an error receiving this message.... [cut]</setting>

This caused inability of Pidgin to load buddy list. Fortunately Pidgin saves the original buddy list in file blist.xml~. I fixed this by removing such lines from blist.xml.

comment:21 in reply to: ↑ 20 ; follow-up: Changed 11 years ago by rmaryan

Replying to rmaryan:

Just an addition: having this bug means ANYONE can destroy buddy list of ANY pidgin user by simply sending some non-latin message.

Do you still believe this bug is minor???

comment:22 in reply to: ↑ 21 Changed 11 years ago by datallah

Replying to rmaryan:

Just an addition: having this bug means ANYONE can destroy buddy list of ANY pidgin user by simply sending some non-latin message.

Do you still believe this bug is minor???

Calm down. The bug "priority" is largely insignificant in terms of the effect it has on the development process, so don't get offended that this is assigned the default priority. You should also note the simple workaround that has been posted.

comment:23 Changed 11 years ago by MarkDoliner

  • priority changed from minor to critical

comment:24 Changed 11 years ago by wooom

Hey.. These are 2 different problems!
1st: New and very bad in 2.4.0: You don't get ANY text from QIP at all (when QIP is set to default Client ID: "QIP 2005 (UTF8)", has to be changed to "QIP 2005")
2nd: Old problem with CE characters from QIP.. you can set anything in QIP with any combination in Pidgin but you dont get the special characters correctly. Probably the same with characters from Trillian..

comment:25 in reply to: ↑ 17 Changed 11 years ago by wooom

Replying to datallah:

This appears to be related to the updated GTK+ runtime included with 2.4.0 on Windows. You can revert to GTK+ 2.12.1 Rev. B for now.

THIS WORKS! Solves the problem with receiving NO text from QIP with default settings. So this is probably a problem with the latest GTK..

comment:26 Changed 11 years ago by Sim-on

  • Milestone set to 2.4.1

comment:27 Changed 11 years ago by msfranky

Yes it´s good priority and milestone but when released 2.4.1?

comment:28 follow-up: Changed 11 years ago by datallah

  • Resolution set to fixed
  • Status changed from new to closed

This has been fixed by revision 1aa8a701c81527c4f91549a4546a54262fccce6d. The issue was that glib 2.14.5 and newer use an internal win_iconv implementation instead of the external GNU libiconv library and that doesn't know what to do with the "UCS-2" encodings.

comment:29 Changed 11 years ago by mmcnamee

Just for reference, this bug means anyone using a Russian mobile phone or PC, cannot send ANY messages, even if they are using the full western character set for their messages. My friend sent a "hi", and even that caused this error message.

Downgrading by doing the following does work:

Open c:\Program Files\Pidgin and rename "pidgin.exe" to pidgin-2.4.0-broken.exe", then re-install 2.3.1 from the installer, downgrading GTK when prompted. This fixed my problems.

2.4.0 is BETA quality at best, disappointing as some of the new features look nice! :-)

comment:30 in reply to: ↑ 28 ; follow-up: Changed 11 years ago by suncho

Replying to datallah:

This has been fixed by revision 1aa8a701c81527c4f91549a4546a54262fccce6d. The issue was that glib 2.14.5 and newer use an internal win_iconv implementation instead of the external GNU libiconv library and that doesn't know what to do with the "UCS-2" encodings.

Huh? I see the ticket is closed, but I am not sure how to fix the problem. What is revision 1aa8a701c81527c4f91549a4546a54262fccce6d?

comment:31 in reply to: ↑ 30 ; follow-up: Changed 11 years ago by datallah

Replying to suncho:

Huh? I see the ticket is closed, but I am not sure how to fix the problem. What is revision 1aa8a701c81527c4f91549a4546a54262fccce6d?

The fix is for the next release. As mentioned in my previous comment, the workaround until then is to downgrade GTK+.

comment:32 Changed 11 years ago by Kampy

if there's a fix then freakin release it ASAP this software is absolutely useless without the fix!

check it out: (without umlauts!) http://chrisnew.game-host.org/imagespace2/dat2/845b-0000.JPG

comment:33 Changed 11 years ago by bob0850

Workaround: Using Pidgin-Encryption plugin as workaround here.

Changed 11 years ago by xtonda

Pidgin GTK+ issue

comment:34 in reply to: ↑ 31 ; follow-up: Changed 11 years ago by xtonda

Replying to datallah:

The fix is for the next release. As mentioned in my previous comment, the workaround until then is to downgrade GTK+.

Should have been fixed in next release of Pidgin or GTK+?

Problem probably related to this is still Present in Pidgin 2.5.1 and GTK+ 2.12.8 rev a. Downgrading GTK+ to 2.12.1 rev b solves the issue. It happens when messaging via AIM in Czech language (CP1250) between Trillian 3.1.10 and Pidgin 2.5.1. Screenshot presenting problem included.

I am not sure whether is safe to use GTK+ windows binaries from other sources like gtk.org or those coming with GIMP.

comment:35 in reply to: ↑ 34 Changed 11 years ago by datallah

Replying to xtonda:

Replying to datallah:

The fix is for the next release. As mentioned in my previous comment, the workaround until then is to downgrade GTK+.

Should have been fixed in next release of Pidgin or GTK+?

This particular issue was fixed in Pidgin 2.4.1

Problem probably related to this is still Present in Pidgin 2.5.1 and GTK+ 2.12.8 rev a. Downgrading GTK+ to 2.12.1 rev b solves the issue. It happens when messaging via AIM in Czech language (CP1250) between Trillian 3.1.10 and Pidgin 2.5.1. Screenshot presenting problem included.

This looks like a different issue - it isn't failing to convert the text. Please file a separate ticket for this.

I am not sure whether is safe to use GTK+ windows binaries from other sources like gtk.org or those coming with GIMP.

These should work fine, there's nothing special about our binaries (in fact, they come from gtk.org - we don't compile them).

comment:36 Changed 11 years ago by xtonda

Filed Ticket #6976 for issue described in my previous post

comment:37 Changed 11 years ago by Loky

Env: SLED10 SP2, gtk2-2.8.11-0.22, pidgin from repo http://download.opensuse.org/repositories/home:/ericgearhart:/Pidgin/SLE_10/i586/pidgin-2.3.1-5.1.i586.rpm Protocol: ICQ Client from the other side: qip, icq, trillian

Problem: Broken non-English (Russian) characters (looks like: ????????? ??? ??????) in offline messages. And Error message "Error receiving mesaage, different codepages of errors in other client"

comment:38 Changed 10 years ago by ruv

Hello! I have just received this error message on Pidgin 2.5.8

An error-log contains following messages:

(14:30:53) oscar: incomingim_ch1: unknown TLV 0x0013 (len 1)
(14:30:53) oscar: Received IM from xxx with 1 parts
(14:30:53) oscar: xxx has an icon
(14:30:53) oscar: Parsing IM part, charset=0x0003, charsubset=0x0000, datalen=33
(14:30:53) oscar: String is not valid UTF-8.
(14:30:53) oscar: String is not valid UTF-8.

Should I set the same encoding as that of every of my recipients?

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!