Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#4966 closed defect (fixed)

Quick find in Buddy list stops at first character

Reported by: khaytsus Owned by: datallah
Milestone: 2.5.2 Component: winpidgin (gtk)
Version: 2.4.0 Keywords:
Cc: satiani

Description

When attempting to search for a contact in my long list of folks here at work, I have noticed that 2.4.0 now stops at the first character and 'freezes' for a bit until it times out.

I am running 2.4.0 on Windows XP.

I've taken a screenshot in case that's useful, cut out the names etc. and circled the find area.

http://wally.unlimitedphoto.com/stuff/FindPidgin240.JPG

Change History (49)

comment:1 follow-up: Changed 9 years ago by datallah

This appears to be related to the the GTK+ upgrade.

comment:2 in reply to: ↑ 1 Changed 9 years ago by JiveMasterT

Replying to datallah:

This appears to be related to the the GTK+ upgrade.

Yeah tested it myself this morning. Downgrading the GTK+ fixes the issue.

comment:3 Changed 9 years ago by datallah

I've filed this upstream in the GTK+ bugzilla: 520165

comment:4 follow-ups: Changed 9 years ago by witmaster

Temporary solution is to copy file: %GTK+_WORK_DIR%\bin\libgdk-win32-2.0-0.dll from GTK+ 2.12.6 (http://ftp.gnome.org/pub/gnome/binaries/win32/gtk+/2.12/gtk+-2.12.6.zip).

comment:5 in reply to: ↑ 4 Changed 9 years ago by russelldad

Replying to witmaster:

Temporary solution is to copy file: %GTK+_WORK_DIR%\bin\libgdk-win32-2.0-0.dll from GTK+ 2.12.6 (http://ftp.gnome.org/pub/gnome/binaries/win32/gtk+/2.12/gtk+-2.12.6.zip).

Thank you for the work around! It works perfectly.

comment:6 Changed 9 years ago by FatButtLarry

Perfect work-around. Thank you!

-Tres

comment:7 Changed 9 years ago by dotech

Adding myself to the CC list.

comment:8 in reply to: ↑ 4 Changed 9 years ago by kuntau

Thanks, work perfectly!

Replying to witmaster:

Temporary solution is to copy file: %GTK+_WORK_DIR%\bin\libgdk-win32-2.0-0.dll from GTK+ 2.12.6 (http://ftp.gnome.org/pub/gnome/binaries/win32/gtk+/2.12/gtk+-2.12.6.zip).

comment:9 in reply to: ↑ 4 Changed 9 years ago by aine

Workaround worked for me too, thanks.

Just as importantly, there is nothing in the Pidgin menus that even suggests that "Ctrl+F" does a find. There is no "Find" menu item, and there is no hint that "Ctrl+F" is the shortcut for such a menu item.

Is there a bug to add a Buddies|Find menu item, with "Ctrl+F" as its shortcut?

comment:10 Changed 9 years ago by deryni

ctrl-f doesn't find in the buddy list (not for me at least), and the type-ahead find is a GTK+ feature that we take advantage of (and is growing more and more common in applications). I am unaware of any bug for such an addition but you are as capable of searching the tickets as I am to try to find one.

comment:11 Changed 9 years ago by FatButtLarry

Confirmed that both "CTRL + F" and "/" in GTK and Windows behave similar to the "type ahead" feature.

Since this is a GTK feature, not a pidgin feature, getting a menu, shortcut or explanation would be tough to justify and GTK version dependent.

I'm for anything that makes the app more user friendly, but greatful of the improvements since GAIM. Cheers.

comment:12 Changed 9 years ago by FatButtLarry

Upgraded to latest 2.4.1 and this issue didn't carry over. Kudos. :)

-Tres

comment:13 Changed 9 years ago by bpalatt

I just upgraded to 2.4.1 and the issue DID carry over. The .dll fix above continues to work. Thanks.

comment:14 Changed 9 years ago by razwww

Just upgraded to 2.4.1, the dll fix doesn't work :(

Razvan.

comment:15 Changed 9 years ago by FatButtLarry

bpalatt is right, the bug carries over, but the dll fix still works for me with 2.4.1.

-Tres

comment:16 Changed 9 years ago by rcsheets

This still affects 2.4.2.

comment:17 Changed 9 years ago by fishbone99

Workaround works for version 2.4.2, but version still carries the bug.

comment:18 Changed 9 years ago by stefanlasiewski

Agreed. This bug still occurs in version 2.4.2. The workaround works for me.

comment:19 Changed 9 years ago by FatButtLarry

Is this simply a matter of the wrong GTK version bundled with the windows version? How do we as users communicate properly to get this into new versions?

-Tres

comment:20 Changed 9 years ago by curdie

This bug is still persistent in 2.4.3, but the workaround still works. THANKS witmaster.

comment:21 Changed 9 years ago by Cube

@Witmaster: Is that a downgrade of the DLL file?

comment:22 Changed 9 years ago by Cube

Aight, sorry, found out myself

comment:23 Changed 9 years ago by nagelp

Hope this will be fixed soon, but the GTK+ guys don't seem to be even near a solution :( +CC

comment:24 Changed 9 years ago by bitdefuser

Confirmed for Windows Vista. Workaround works, though. :) Thanks!

comment:25 Changed 9 years ago by FatButtLarry

Still exists in 2.4.3.


I've found type ahead especially useful for long buddy lists, or buddy pounces for known away buddies (since away buddies can be in the hundreds).

I also use this at work, since the list can be long some days.

The libgtk-win32-2.0-0.dll work-around is still golden, although I'm a bit hesitant to recommend Pidgin to Windows users with this default behavior.

Anything that locks the GUI can cause frustration, and I'd hate to make that a first impression. :)


http://img375.imageshack.us/img375/7093/49812065ho7.png


For now, I'm keeping around a spare libgtk-win32-2.0-0.dll for upgrades.

I'm still using the original download suggested by witmaster:

http://ftp.gnome.org/pub/gnome/binaries/win32/gtk+/2.12/gtk+-2.12.6.zip

Thanks for an excellent product (and providing us "users" with an excellent bug tracker).

-Tres

comment:26 Changed 9 years ago by FatButtLarry

Sorry, I made a mistake... those screeshots are for libgtk not libgdk.

The library is libgdk-win32-2.0-0.dll not libgtk-win32-2.0-0.dll

-Tres

comment:27 follow-up: Changed 9 years ago by manca

I can confirm that copying this file from other GTK does fix the issue with search, but on the other hand breaks the window control :( You can see this bug here: http://developer.pidgin.im/ticket/6594.

Anyone found a workaround of this?

comment:28 in reply to: ↑ 27 Changed 9 years ago by nagelp

Replying to manca:

I can confirm that copying this file from other GTK does fix the issue with search, but on the other hand breaks the window control :( You can see this bug here: http://developer.pidgin.im/ticket/6594.

Anyone found a workaround of this?

That's exactly why we should stop using / searching for workarounds, and try to get the GTK issue fixed... imo.

comment:29 Changed 9 years ago by manca

there is new gtk 2.12.11, but I don't know how to install in on windows, anyone knows? Also will the new version of pidgin be released soon, which will use the new GTK, which hopefully fix those ridiculous glitches? Also I tried copying the libgdk-win32-2.0-0.dll from 2.12.11 but it didn't work, pidgin couldn't load.

comment:30 Changed 9 years ago by gianop

The first letter locked in the typing search defect is back to Pidgin 2.5! Darn...

comment:31 Changed 9 years ago by FatButtLarry

I just downloaded the latest GIMP for windows and the same GTK bug caries over.

-Tres

comment:32 follow-up: Changed 9 years ago by manca

I can confirm the bug in 2.5 as well. I just don't get it why the hell the didn't include the newest GTK which would eventually fix this bug in the new release, but instead they still used the old 2.12.8.

comment:33 in reply to: ↑ 32 Changed 9 years ago by datallah

Replying to manca:

I can confirm the bug in 2.5 as well. I just don't get it why the hell the didn't include the newest GTK which would eventually fix this bug in the new release, but instead they still used the old 2.12.8.

You're confused. There hasn't been a GTK+ release that includes a fix for this bug. When there is, we will include it (barring other issues).

comment:34 Changed 9 years ago by manca

Oh, I thought the newer versions of GTK did fix this bug... seems like I was wrong, sorry about that.

I have another recommendation then, that is, why don't you use the stable release (2.12.6) which doesn't produce such bugs? I mean what do we get with 2.12.8 which doesn't exist in 2.12.6?

Thanks

comment:35 Changed 9 years ago by Sim-on

  • Milestone set to 2.5.1

The GTK-Bug has been fixed and will be in the next GTK-Release...
i think we can close this ticket, can't we?

comment:36 Changed 9 years ago by datallah

  • Milestone 2.5.1 deleted

I have no idea if this will actually be included in 2.5.1 because we don't determine the GTK+ release schedule.

I think we should keep this open until we release a version containing the fix.

comment:37 Changed 9 years ago by deryni

Ticket #6799 has been marked as a duplicate of this ticket.

comment:38 Changed 9 years ago by pra

Couldn't you just include older GTK with Pidgin, until there is a version where this bug is fixed? I still have my GTK from Pidgin 2.3.0, and I use the 2.3.0 installer to downgrade it if I forget about the bug and let the newer installer install the buggy GTK. Haven't noticed any problems with that old version.

comment:39 Changed 9 years ago by frost_

isn't the new version of gtk is 2.14 and not 2.12.6

comment:40 follow-up: Changed 9 years ago by satiani

I installed Pidgin 2.5.1 and I have a different workaround that fixes both bugs:

  • the hanging quick find
  • the irregular minimize behavior

simply by downloading the latest GTK+ 2.14.1 bundle from here:

http://ftp.gnome.org/pub/gnome/binaries/win32/gtk+/2.14/gtk+-bundle_2.14.1-20080905-1_win32.zip

I extracted it and then copied the following folders:

bin etc lib share

to:

C:\Program Files\Common Files\GTK\2.0

comment:41 Changed 9 years ago by manca

This indeed worked for me too. I guess it's time for 2.5.2 release which will include this version of GTK+.

By the way, I just realized that searching for contact works fine, but when i try to click on it I first have to hit esc and then click on it, or on anyone else.

comment:42 in reply to: ↑ 40 ; follow-up: Changed 9 years ago by thiru.think

With 2.5.1 when I copy bin etc lib share

to:

C:\Program Files\Common Files\GTK\2.0

ctrl + f worked for me also.. Thanks!!

comment:43 in reply to: ↑ 42 Changed 9 years ago by thiru.think

one more thing.. When I delete old folders bin etc lib share at C:\Program Files\Common Files\GTK\2.0 and copy new one then pidgin is not opening up. But when we replace the old with new folders then its working fine..

Thiru

comment:44 Changed 9 years ago by datallah

The next Pidgin update will include GTK+ 2.12.12. There is a test installer available here if you would like to try it.

comment:45 follow-up: Changed 9 years ago by phannent

The link to GTK+ 2.12.12 does not work, I get address not found.

Is there another download location I could try it from?

comment:46 in reply to: ↑ 45 Changed 9 years ago by datallah

Replying to phannent:

The link to GTK+ 2.12.12 does not work, I get address not found.

Try again (I fixed the link in my previous post).

comment:47 Changed 9 years ago by Sim-on

Great. Its working well now. I think we can close this now for 2.5.2 , can't we? ;)

comment:48 Changed 9 years ago by phannent

You can add a "Works for me" for the new GTK installer.

Thank you.

comment:49 Changed 9 years ago by datallah

  • Milestone set to 2.5.2
  • Resolution set to fixed
  • Status changed from new to closed

The GTK+ 2.12.12 runtime shipped with 2.5.2.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!