Opened 11 years ago

Closed 10 years ago

#4979 closed defect

input-area-1-pixel-bug with non-standard windows theme

Reported by: ryanspeck Owned by:
Milestone: Component: winpidgin (gtk)
Version: 2.4.0 Keywords:
Cc:

Description

With the latest text entry resizing change, the text entry box (though small) works perfecty fine until you close the IM window and receive a new message.

When you double-click on the blinking icon in the taskbar, the message pops up but has no text entry window at all, making it impossible to respond to a message without closing the IM window, double-clicking on the person from your buddy list, and starting over again. This happens with every message received in the tray.

Attachments (1)

single_pixel_bug.png (6.8 KB) - added by deryni 11 years ago.
Single Pixel Bug

Download all attachments as: .zip

Change History (25)

comment:1 Changed 11 years ago by deryni

If you turn off hiding of new IM windows or the formatting toolbar this bug should go away, we are aware of the issue but do not yet have a fix that works for everyone.

comment:2 Changed 11 years ago by ryanspeck

Thanks. I hate to leave open windows, so I downgraded for the time being.

Hopefully in 2.4.1 everything'll be back to being kosher.

comment:3 Changed 11 years ago by end-user

add my vote

comment:4 follow-up: Changed 11 years ago by TheAntipode

I have a somewhat similar issue with the text field being only a few pixels high, jumping up to two lines any time I type, and after hitting enter it drops back down to a few pixels. I've cycled the formatting toolbar and hiding of new IM windows (both currently off) and have disabled all plugins, yet the problem persists.

comment:5 in reply to: ↑ 4 Changed 11 years ago by draconic

Replying to TheAntipode:

I have a somewhat similar issue with the text field being only a few pixels high

this is happening for me as well.

comment:6 Changed 11 years ago by deryni

  • Resolution set to fixed
  • Status changed from new to closed

The single-pixel high bug has been fixed to the best of our ability to test it, and should be in the next release.

comment:7 Changed 11 years ago by Sim-on

  • Milestone set to 2.4.1

comment:8 Changed 11 years ago by TheAntipode

This is persistent in 2.4.1

comment:9 Changed 11 years ago by deryni

You still see the single-pixel input area bug in 2.4.1?

comment:10 Changed 11 years ago by mbchampoux

I have the single-pixel bug as well. Version 2.4.1. I tried both the hiding new IM window, and formatting tool bar tricks with no success.

comment:11 Changed 11 years ago by deryni

  • Resolution fixed deleted
  • Status changed from closed to reopened

To be clear the single-pixel bug is that the default input area size in IM windows is infinitesimally small, nothing else. As seen in the file I am attaching. You are still seeing that in 2.4.1? If so can you tell us what operating system you are running, what GTK+ theme you are using, what default font size you have set for your interface and for your outgoing message formatting, and what plugins you have loaded. I'm reopening this temporarily.

Changed 11 years ago by deryni

Single Pixel Bug

comment:12 Changed 11 years ago by Sim-on

seems to be an issue when using non-standard windows themes. Please check this, too!

comment:13 Changed 11 years ago by Nougat

I have this issue, 2.4.1, and am using the Windows XP theme with minor modifications: desktop background, titlebar size (smaller).

Shoot me for not saving that modified theme. I switched to the default Windows XP theme, and the input field was normal size. I made some of the changes I remembered from the old theme, and it's still fine.

comment:14 Changed 11 years ago by deryni

If you (or anyone else) can track down what changes cause the bug to happen that would be incredibly useful.

comment:15 Changed 11 years ago by xmelzax

I have this bug on a clean install of pidgin 2.4.1 in windows XP. http://img153.imageshack.us/img153/9162/tinyee9.png It happens in received windows opened from the tray icon, and in new message windows opened from the contact list. Typing something in the input box makes it larger, until I press enter to send the message, then it goes small again. I have a patched uxtheme.dll and a custom visual style for windows. (Have tried 3 different custom visual styles with same results) The bug DOES NOT happen when using the default windows XP theme, or if I untick the "Use font from theme" checkbox from the 'conversations' tab in preferences. I do not have any plugins other than standard defaults installed in pidgin. I have not changed the default font size on outgoing messages, only thing I changed was the colour.

comment:16 Changed 11 years ago by deryni

What font does your Windows theme (that causes the bug) set? I'm assuming if you switch to the default theme and then back to your custom theme it stays broken in pidgin? Can you tweak the font settings in your custom theme such that pidgin isn't broken?

comment:17 Changed 11 years ago by mbchampoux

For the record - I changed my Windows theme to the Windows XP theme and it solved the problem. I then switched back to my custom theme, and all is good.

Thanks,

comment:18 Changed 11 years ago by xmelzax

Changing the font within the windows theme fixes the input box. Font causing problems for me is 'AvantGarde? LT Medium' (in any size). All the themes I had tried used this same font which is why I had the same problem with all. Have now tried themes which use other fonts and the bug doesn't occur. Yes, switching from the default xp theme back to the custom theme immediately breaks it - an already-open window's text box will shrink as soon as I change themes. I have unticked the 'use font from theme' box in preferences to fix this for now.

comment:19 Changed 11 years ago by TheAntipode

Going along the lines of everyone else, switching to the default Windows theme makes the window behave normally. Switching to any other custom theme I have on my system makes the window behavior work fine - it's only in the theme I've been using regularly that seems to cause this problem.

comment:20 Changed 11 years ago by ikorb

Another font that can cause this problem is "MS Sans Serif" (the bitmap font - the TrueType? font named "Microsoft Sans Serif" works fine).

comment:21 Changed 11 years ago by Sim-on

  • Component changed from pidgin (gtk) to winpidgin (gtk)
  • Milestone 2.4.1 deleted
  • Summary changed from Text window issues to input-area-1-pixel-bug with non-standard windows theme

comment:22 Changed 10 years ago by bernmeister

Is this still occurring in Pidgin 2.5.8?

comment:23 Changed 10 years ago by darkrain42

  • Status changed from new to pending

comment:24 Changed 10 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!