Opened 11 years ago

Closed 9 years ago

Last modified 8 years ago

#5038 closed defect (fixed)

Make the authorize buddy dialog usable

Reported by: unholly Owned by:
Milestone: 2.8.0 Component: pidgin (gtk)
Version: 2.3.1 Keywords: authorization dialog pop-up usability
Cc: ivan.komarov, MarkDoliner

Description

I'm sending this as bug report, not as enhancement request, because it's about a problem with already existing functionality, that has has serious negative impact on pidgin usability. It was submitted some time ago, when SourceForge? was used, but seems to have been lost when moving to this site.

With the "Authorize Buddy?" dialog, used right now it usually impossible to see who is requesting authorization. In situations where same names are used in multiple IM accounts there is also no way to figure what protocol is he/she using and which of your accounts received the request. To make things worse, with the new embedded authorization dialogs there is no way to just close the window, postponing the decision until there is sufficient information to decide.

Even now i have several pending requests, that can't just be denied, because they are either undoubtedly spam or _may_ be from someone i want to authorize or don't want to offend. They can't be answered, because there is no way to figure how answer. They also can't be removed, because even by manually digging ~/.purple i can't find where are they saved. In situations like this, the "Authorize Buddy?" dialog could be as good as a nonexistent, if it wasn't so annoying.

To make it usable with minimal changes at least several features must be added:

  • Information about the IM service used by the buddy, requesting authorization. Can be implemented by using the corresponding protocol icon instead of the the currently used question mark icon. This also allows in almost any case to figure which account received the request.
  • Button to request buddy information. Without this one the "Authorize Buddy?" dialog serves mostly as random annoyance instead of being usable function.

As alternative (and even more usable solution) button to open chat with the buddy can be added. It is possible to request user info from the chat window and it is also possible to identify account/protocol this way.

  • Close button (small x for example), allowing to silently ignore the request. This functionality, that was lost when dialog windows were replacled with embedded dialogs, serves both as a polite way to refuse authorization without insulting someone and as best answer for bot generated spam, where demonstrating activity is not wise decision.

Adding "chat" and close dialog buttons won't make the pop-up "bloated", but is one of the ways to make it usable in 100% of the possible situations.

Attachments (1)

pidgin-auth-problem.png (5.0 KB) - added by manski 9 years ago.
Authorization popup screenshot

Download all attachments as: .zip

Change History (14)

comment:1 Changed 11 years ago by deryni

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5039

comment:2 Changed 11 years ago by Sim-on

  • Resolution duplicate deleted
  • Status changed from closed to reopened

both tickets were closed as duplicat of each other ;)

but of course this ticket is similar to #3804 and #3207...

Changed 9 years ago by manski

Authorization popup screenshot

comment:3 Changed 9 years ago by manski

I do have the same "problem" with the authorization popup/dialog (whatever you may call it). For me it looks like this:

Authorization popup screenshot

Sorry for it being German but basically it says:

21506xxxx wants to add 28742xxxx to his or her buddy list

And as the OP said this is almost useless since it only says that there is an authorization but makes it hard to determine for which protocol and who wants to be authorized.

It should say instead:

John Doe (21506xxxx) wants to add you (28742xxxx) to his or her buddy list

Additionally the protocol icon should be displayed (as the OP suggested).

And as for the button for a chat or info window about the buddy: Maybe this could be implemented as "hyperlink" on the buddys name. This way no additional space for a new button would be needed.

comment:4 Changed 9 years ago by MarkDoliner

  • Cc ivan.komarov added

We did add an X button a while back, and it can be used to "ignore" a request. However not all protocols supports ignoring requests. For these protocols we should probably not show the X. Or clicking the X should send a negative reply. I also think it would be more clear if we had an "Ignore" button instead of, or in addition to, the X.

Ivan and I both like these suggestions:

  1. In the "ABC wants to add XYZ" message, make "ABC" a hyperlink to ABC's profile (the one Pidgin shows after clicking "Get Info" on ABC in the buddy list).
  2. Instead of the stock question mark, display ABC's protocol icon.

comment:5 Changed 9 years ago by ivan.komarov@…

(In 850102c2d3b83ffb1c63bf0bb5ee384cd2fd7ec8):
Display the protocol icon for the authorization request dialog instead of a question mark. Refs #5038.

The dialog is still pretty unusable, though. There should be either a link to the user profile or a button to start a conversation (or maybe both), but these seemingly trivial things were surprisingly tough to implement. I think I'll return to this ticket at the end of the summer.

comment:6 Changed 9 years ago by khc

A long long time ago I submitted a patch to the SF tracker to add a get info button on the add request dialog (before they became those mini dialogs). It looks like I can't find that patch on SF anymore though, and I don't have a copy of it anymore. Do you remember this Mark? Maybe part of it is still relevant and maybe you could use your super awesome power to dig it out of SF ;-)

comment:7 Changed 9 years ago by ivan.komarov@…

(In d00e5622c7b15359775cf6892019db8af29ed8fe):
Add a "Send Instant Message" button and a hyperlink to the user's profile (works only for GTK+ >= 2.18) to the authorization request dialog. Refs #5038

comment:8 Changed 9 years ago by MarkDoliner

Hey Ivan, I'm curious, are there still other things you would like to add before considering this ticket fixed?

comment:9 Changed 9 years ago by ivan.komarov

Mark, I don't think there's anything else left. I can't merge that last commit right now to ipp, though, since it adds some new public API functions. I'll wait for 2.8.0 and then close this ticket.

comment:10 Changed 9 years ago by MarkDoliner

  • Milestone set to 2.8.0
  • Resolution set to fixed
  • Status changed from new to closed

Awesome. If you want you can merge it to im.pidgin.pidgin.next.minor. That purpose of that branch is to contain changes that add new public API. When we decide that the next release should be 2.8.0 and contain new API, we will merge that branch into im.pidgin.pidgin.

comment:11 Changed 9 years ago by ivan.komarov

Ticket #12793 has been marked as a duplicate of this ticket.

comment:12 Changed 8 years ago by nomeata

Just adding some metadata: #1258 is a duplicate of this (although that bug is closed wontfix).

comment:13 Changed 8 years ago by ivan.komarov@…

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!