Opened 12 years ago

Closed 10 years ago

#504 closed enhancement (fixed)

Drag and drop should invite to chat

Reported by: fmoo Owned by: deryni
Milestone: 2.6.0 Component: pidgin (gtk)
Version: 2.0 Keywords:
Cc:

Description

For protocols that support chat invites (such as msn), dragging a contact/buddy to the chatroom window should prompt the user to invite selected buddy(buddies) to the chat.

Currently, a new IM tab is opened.

Attachments (1)

dnd-invite2chat.diff (4.1 KB) - added by Zzzoom 10 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by lschiere

  • Owner set to seanegan

Sean, did you not look at something related to this?

comment:2 Changed 12 years ago by mambro

I agree with you

comment:3 Changed 12 years ago by jonh_tomas

I can't use this pidgin IM without this feature!!!

this is a very big hole on Pidgin...

pleaaaaaaasssseeeeee make this a feature available for the next release!!!

pidgin is really cool... but missing this feature I really have to stick whit Windows Live Messenger :(

comment:4 Changed 12 years ago by ernstp

Hello, this would be a really nice feature! It feels really obvious that people should be invited when you drag them to the chat-list.

comment:5 Changed 12 years ago by seanegan

  • Owner changed from seanegan to deryni

comment:6 Changed 12 years ago by ercanyuz

I totally agree with this. This is an important usability feature. Initiating a chat in Pidgin is currently very cumbersome. Can't you please increase its priority?

comment:7 Changed 11 years ago by djphazer

*Bump!*

I, too, would be ecstatic about this as an added feature! (I'd do it myself if I had more skill in the relevant programming areas...)

Also, see ticket #5279.

comment:8 Changed 11 years ago by twarwick

*re-bump*. I use Pidgin in preference to the official Sametime client at work... but the lack of a workable Chat invite feature might drive me back to Sametime ! Please don't let this happen :)

comment:9 Changed 11 years ago by QuLogic

Ticket #7382 has been marked as a duplicate of this ticket.

comment:10 Changed 10 years ago by Zzzoom

As a former WLM user I found this particularly annoying so I wrote a small patch for it. When you drag a contact to a chat window of the same protocol, the contact is invited to the chat with an empty invite message.

Changed 10 years ago by Zzzoom

comment:11 Changed 10 years ago by sadrul@…

  • Milestone set to 2.6.0
  • Resolution set to fixed
  • Status changed from new to closed

(In 0bd107bd701b43985e1a0f49f0e9d394af0b819b):
Open a chat-invite dialog when a buddy is dragged onto a chat. A somewhat warmenhoved patch from Zzzoom. Closes #504. Refs #8871.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!