Opened 11 years ago

Closed 11 years ago

#5402 closed enhancement (duplicate)

Tooltips should display emoticons

Reported by: Mauro Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.4.1 Keywords:
Cc:

Description

When user set the status message including a smiley, it's shown the text and not the image.

Change History (9)

comment:1 Changed 11 years ago by Sim-on

  • pending changed from 0 to 1

you mean your own away or the away of others? seems to be a duplicate of #3693?

comment:2 Changed 11 years ago by Mauro

  • pending changed from 1 to 0

I'll try to be more specific:

I want to create a new status. I open the "Saved statuses" panel and I add a new one. I set: Title, Status and Message. The problem I was speaking before, was about the Message inserted.

In the Message area I can set any text correctly but if I add a smiley, the smiley doesn't appear to other friends in their Pidgin. The only thing that appears is the text that stands used for the smiley.

comment:3 Changed 11 years ago by deryni

  • pending changed from 0 to 1

Where would you want/expect to see the graphical smiley? We don't currently do that, to the best of my knowledge, in the buddy list, in the tooltip, or in the conversation window infopane (and I'm not sure I think we should start doing it in any of those places). So which of those locations are you wanting this to happen?

comment:4 Changed 11 years ago by Mauro

  • pending changed from 1 to 0

According to me, it would be nice in the "Saved statuses" panel to have not only: Title, Status and Message but also a "Smiley" input.

So if the user sets the smiley it'll appear to other Pidgin user near or will substitute the green circle of status. It'll be nice to see it also in the tooltip.

comment:5 Changed 11 years ago by deryni

We can't send random extra data as a status message (on most protocols), so a smiley can only reliably be sent in the message text and as such can't be used for anything fancier than displaying in the message. As for displaying it in the tooltip window we don't unfortunately have the same layout capabilities there that we do in the conversation window (that I'm aware of) so I'm not sure how possible this really is. But I don't know the tooltip display code that well.

comment:6 Changed 11 years ago by Sim-on

  • Component changed from unclassified to pidgin (gtk)
  • Owner lschiere deleted
  • Summary changed from State smiley appears as text (not as icon) to Tooltips should display emoticons
  • Type changed from defect to enhancement

comment:7 Changed 11 years ago by benjiphil

Also a near duplicate of #1396.

comment:8 Changed 11 years ago by Mauro

I think it's enough if Pigin displays the correct image icon inserted in "Message area" (as above described) in all this cases:

  • when a user click on "Get info" for a user and the Message is displayed
  • in buddy list when user chooses to display buddy details and the message is displayed

comment:9 Changed 11 years ago by Sim-on

  • Resolution set to duplicate
  • Status changed from new to closed

i will close this as a duplicate of #3693 because I think one dicsussion whether to display emotions and links in the buddylist or in the tooltip or in both would be better.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!