Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5441 closed defect

XMPP/Jabber/Gmail and MSN randomly disconnect in 5.4.1 (similar to #5373 and #5438)

Reported by: Willscrlt Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.4.1 Keywords: jabber, msn, GtkEventBox, GtkButton, 2.4.1, 501, feature-not-implemented
Cc:

Description

XMPP/Jabber/Gmail and MSN randomly disconnect in 5.4.1 (similar to #5373 and #5438)

I upgraded to version 2.4.1 yesterday evening, and since then I have been having random disconnects with all of my XMPP/Jabber accounts (most notably Gmail). My two MSN accounts have been randomly disconnected, too. It is possible that Yahoo! has problems, too, since it was disconnected this morning when I turned on my monitor. In fact, the only service that remained connected through the night was AIM. Since reconnecting all of the services this morning, XMPP and MSN are the only two services that have disconnected.

To my knowledge, nothing else has changed on my system that would explain this except for last night's upgrade to 2.4.1 from an earlier 2.3.x version. I am not using any third-party plugins, and all the ones listed are version 2.4.1.

Reading through the open bug reports, #5373 and #5438 sound similar, but narrower in scope (they did not mention MSN and possibly YIM being affected, too).

This is my first (I think) bug report. I do not understand what the following debug messages mean, but hopefully somebody else does. If you need more details, please let me know.


These are the debug messages that occur during a disconnect from MSN:

(08:23:14) msn: C: NS 000: PNG
(08:23:17) jabber: Sending (ssl): <iq type='get' id='purple5edf2956'><ping xmlns='urn:xmpp:ping'/></iq>
(08:23:18) msn: C: NS 000: PNG
(08:23:18) msn: S: NS 000: QNG 50
(08:23:33) msn: servconn read error, len: -1 error: Remote host closed connection.
(08:23:33) msn: Connection error from Notification server (207.46.111.81): Reading error
(08:23:33) msn: C: NS 000: OUT
(08:23:33) msn: Connection error from Notification server (207.46.111.81): Writing error
(08:23:33) msn_session_disconnect: assertion `session->connected' failed
(08:23:33) account: Disconnecting account 013BA1B8
(08:23:33) connection: Disconnecting connection 034F47D8
(08:23:33) connection: Deactivating keepalive.
(08:23:33) msn: destroy httpconn (03507B88)
(08:23:33) jabber: jabber_actions: have pep: NO
(08:23:33) jabber: jabber_actions: have pep: NO
(08:23:33) connection: Destroying connection 034F47D8
(08:23:33) GLib-GObject: invalid cast from `GtkEventBox' to `GtkButton'
(08:23:33) Gtk: gtk_button_get_relief: assertion `GTK_IS_BUTTON (button)' failed
(08:23:36) account: Disconnecting account 013BA098
(08:23:36) connection: Disconnecting connection 034F4F18
(08:23:36) connection: Deactivating keepalive.
(08:23:36) jabber: jabber_actions: have pep: NO
(08:23:36) connection: Destroying connection 034F4F18
(08:23:36) GLib-GObject: invalid cast from `GtkEventBox' to `GtkButton'
(08:23:36) Gtk: gtk_button_get_relief: assertion `GTK_IS_BUTTON (button)' failed

Also I am receiving a lot of these messages:

(08:35:06) jabber: Sending (ssl): <iq type='get' id='purple24f22f1d'><ping xmlns='urn:xmpp:ping'/></iq>
(08:35:06) jabber: Recv (ssl)(221): <iq type="error" id="purple24f22f1d" to="ACCOUNT1@gmail.com/ofcAFEA7D58"><ping xmlns="urn:xmpp:ping"/><error code="501" type="cancel"><feature-not-implemented xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></iq>
(08:35:07) jabber: Sending (ssl): <iq type='get' id='purplea7944f8c'><ping xmlns='urn:xmpp:ping'/></iq>
(08:35:07) jabber: Recv (ssl)(218): <iq type="error" id="purplea7944f8c" to="ACCOUNT2@gmail.com/ofc06CE8795"><ping xmlns="urn:xmpp:ping"/><error code="501" type="cancel"><feature-not-implemented xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></iq>

Also several of these:

(08:32:30) GLib-GObject: invalid cast from `GtkEventBox' to `GtkButton'
(08:32:30) Gtk: gtk_button_get_relief: assertion `GTK_IS_BUTTON (button)' failed
(08:32:31) GLib-GObject: invalid cast from `GtkEventBox' to `GtkButton'
(08:32:31) Gtk: gtk_button_get_relief: assertion `GTK_IS_BUTTON (button)' failed
(08:32:31) msn: C: NS 000: PNG
(08:32:31) msn: S: NS 000: QNG 45
(08:32:34) GLib-GObject: invalid cast from `GtkEventBox' to `GtkButton'
(08:32:34) Gtk: gtk_button_get_relief: assertion `GTK_IS_BUTTON (button)' failed
(08:32:35) GLib-GObject: invalid cast from `GtkEventBox' to `GtkButton'
(08:32:35) Gtk: gtk_button_get_relief: assertion `GTK_IS_BUTTON (button)' failed

Change History (16)

comment:1 Changed 11 years ago by datallah

  • pending changed from 0 to 1

The second and third debug blocks are unrelated.

This is the relevant part of the first debug log:

(08:23:18) msn: S: NS 000: QNG 50
(08:23:33) msn: servconn read error, len: -1 error: Remote host closed connection.

Something (either the remote server, or something between pidgin and it (e.g. a firewall)) is hanging up on the connection.

comment:2 Changed 11 years ago by Proto

I'm getting random disconnects from MSN in 2.4.1 too. Just started getting them after an upgrade from 2.3. I'll post a debug log when I get one.

comment:3 Changed 11 years ago by trac-robot

  • pending changed from 1 to 0
  • Status changed from new to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:4 follow-ups: Changed 11 years ago by shannon_lowder

Can this ticket be re-opened. I am having the same issue. I am on Ubuntu 8.04. I would be happy to supply debugging information. I would also like to point out while using the Spark 2.5.8 I am able to maintain my connection without any issue.

comment:5 in reply to: ↑ 4 Changed 11 years ago by datallah

Replying to shannon_lowder:

Can this ticket be re-opened. I am having the same issue. I am on Ubuntu 8.04. I would be happy to supply debugging information. I would also like to point out while using the Spark 2.5.8 I am able to maintain my connection without any issue.

Please file a separate ticket for your issue and include a debug log.

comment:6 in reply to: ↑ 4 ; follow-up: Changed 11 years ago by lvmisooners

Replying to shannon_lowder:

Can this ticket be re-opened. I am having the same issue. I am on Ubuntu 8.04. I would be happy to supply debugging information. I would also like to point out while using the Spark 2.5.8 I am able to maintain my connection without any issue.

This is still an issue in 2.4.2. Please reopen

comment:7 in reply to: ↑ 6 ; follow-up: Changed 11 years ago by deryni

Replying to lvmisooners:

Replying to shannon_lowder:

Can this ticket be re-opened. I am having the same issue. I am on Ubuntu 8.04. I would be happy to supply debugging information. I would also like to point out while using the Spark 2.5.8 I am able to maintain my connection without any issue.

This is still an issue in 2.4.2. Please reopen

I give you the same advice datallah gave shannon_lowder, "Please file a separate ticket for your issue and include a debug log."

comment:8 in reply to: ↑ 7 Changed 11 years ago by lvmisooners

Replying to deryni:

Replying to lvmisooners:

Replying to shannon_lowder:

Can this ticket be re-opened. I am having the same issue. I am on Ubuntu 8.04. I would be happy to supply debugging information. I would also like to point out while using the Spark 2.5.8 I am able to maintain my connection without any issue.

This is still an issue in 2.4.2. Please reopen

I give you the same advice datallah gave shannon_lowder, "Please file a separate ticket for your issue and include a debug log."

Why do you close tickets for unresolved issues? Why do i need to create a new ticket for the same problem?

comment:9 follow-up: Changed 11 years ago by deryni

Tickets in which the original poster disappear are closed because that hampers the normal workflow. We also have no way of knowing if your issue is in fact the same as theirs without you presenting your version of the information and that is something more easily done in a ticket you own than one someone else does.

comment:10 Changed 11 years ago by shannon_lowder

And it also eliminates the possibility that you can reduce the number of issues by determining one issue covers several users. Increasing your debugging information, and getting more eyes on a topic that grows from covering one user, to one affecting many to all of your users.

comment:11 Changed 11 years ago by deryni

It eliminates nothing, we routinely also close tickets as duplicates and ask users to post their additional information to existing tickets. The question is just when each approach is useful. In the case of a ticket where the original posted has vanished suggesting that other people continue to post there is detrimental to the normal ticket workflow as, for just one example, the pending flag becomes useless. If the two of you don't want to help figure your issues out then by all means continue to question our reasoning here rather than simply taking a moment to create a new ticket with the information we requested. We can handle this either way, only one of which is actually likely to get anything fixed though. Your call.

comment:12 in reply to: ↑ 9 Changed 11 years ago by Willscrlt

Um. If you are speaking about me, the person who originally opened the issue, I have not disappeared. I'm still here reading every reply and growing more and more disappointed that Pidgen's tech support doesn't actually resolve anything.

I still have periods where the original situation happens. Other times it works fine. It's rather intermittent. Obviously the issue is not dead. There are several people who are suffering from it.

If there was something I was supposed to have done to keep the issue alive, then I'm sorry. I don't know all the policies of this forum, and honestly, I don't want to have to learn them.

I did my best to submit logs to you. There don't seem to be any guidelines for how to submit them. Is it any wonder that the other people responding aren't doing things the "right way" either?

So let me put it this way... The case should not have been closed. Anyone who agrees, should add their logs and get this issue reopened again.

--Willscrlt

Replying to deryni:

Tickets in which the original poster disappear are closed because that hampers the normal workflow. We also have no way of knowing if your issue is in fact the same as theirs without you presenting your version of the information and that is something more easily done in a ticket you own than one someone else does.

comment:13 Changed 11 years ago by deryni

Your original report was resolved as best we knew because you never reported back that the original diasgnosis/comment was not in fact the solution and your problem was not in fact solved. I'm entirely unsure how you expected us to know that you were still having problems when you didn't bother to tell us that. The fact that other people are suffering from other disconnection problems is not at all related to the problem evident in your original debug log posting (which is why we suggested they open new tickets).

The only thing you would have needed to do to keep this alive would be to indicate that you read the original comment and that it in fact did not explain the situation and that you are still experiencing problems.

You submitted your log just fine, no one complained about that. Notice, again, that the first comment you received commented on them and on what we believe your problem to have been.

So once more in summary, the other people who are posting to this ticket likely have a different problem than you did because as best as we could tell from your original debug log output your problem was a host/firewall/network issue and not something pidgin is doing wrong or can do anything about. You then did not indicate that the problem still existed or refute our interpretation. The fact that other people have disconnection issues does not make them related to this problem as there are easily dozens of different reasons for disconnection issues, it is this fact that caused us to recommend that those people posting with issues of their own create their own tickets and include the debug log output of their issues so that we can have the information needed to tell them what their problems are and to determine if they are identical to other filed tickets.

Oh, and one last thing, I really do not see the logic in arguing with the people who you are trying to get to help you rather than simply providing them the information they have requested which will enable them to actually help you. If someone could explain that to me I would be most appreciative, as it is not an uncommon reaction and I feel like if I understood it I could better prevent it from getting in the way in the future.

comment:14 Changed 11 years ago by Willscrlt

I'm sorry if I came across as argumentative to the people trying to help. I was just "reacting" to the situation rather than "responding" intelligently. It happens sometimes. :-)

I did not respond after the initial comment because I was waiting for a more concrete suggestion to work from. The MSN issue was apparently a firewall issue. Okay. That didn't help with the Jabber issue, which was mostly what was acting up (and still does intermittently, though it's been lots better lately). The MSN was more of a fluke than a real problem. The Jabber issue was the one that was really irritating me, and I was waiting for some feedback on that part.

Then, seemingly without any warning or cause, the ticket was closed. To me it was like, "Oh. I guess they don't care to help resolve this." I went into "lurk mode" to see if anyone would ever come up with a possible resolution. All I saw were more comments from people suffering the same (or seemingly the same) issue.

I saw the comment "in which the original poster disappear", and that upset me. I wasn't (in my mind) the one who disappeared. The ticket had been closed while I was waiting for a response. If it was closed how and why should I continue to respond. I knew I hadn't disappeared, but rather the system had failed to produce any meaningful answers for me.

Should I have responded to the MSN issue, at least with a "thanks, but that doesn't resolve my bigger Jabber issue"? In retrospect, of course I should have. But not knowing typical response times for issues or even exactly how to report an issue, I didn't. I played the "wait and see" card. Well, I saw. The ticket closed.

I hope that explains the thought process I went through. I'm sure that with your experience here you have a totally different perspective. But I'm probably not that different from a lot of newbies here... except that I've maybe got a bit more experience than many, thus others are probably even less patient and get frustrated more easily.

comment:15 Changed 11 years ago by deryni

Yes, while I do understand your perspective you are correct that you should have responded with an indication that your MSN problem was fixed but that other problems still existed. The debug log snippets you originally posted contain no indications of any problems *other* than the MSN one (yes, your text does but that's somewhat irrelevant here). Given the fact that at least one account/protocol was being disconnected due to your firewall it was entirely reasonable to assume your other accounts were as well, so without further indication from you we assumed all your problems were fixed. We probably could improve the pending close message to indicate what the criteria for 'updates' are a little better and with instructions to post again if your issue is still unresolved that would help some in the future.

As to your jabber issue, if the problem is with an Openfire server or with some custom server I would lay money on it being related to the ping functionality we just added and your server failing to respond to the ping (there are a couple tickets about this). But please post the debug log output of this disconnection so we can actually attempt to diagnose it (actually at this point a new ticket is probably a better idea).

comment:16 Changed 11 years ago by Willscrlt

I just upgraded to the version released yesterday (or at least that was detected yesterday). It now says I am running 2.4.2 with GTK+ Runtime 2.12.8 (which was updated during the Pidgin update) and Glib Runtime 2.14.6.

So far (keeping my fingers crossed), no disconnects from any of the services. It has been wonderful. In fact, right after installing it, messages sent to me over a week ago on YIM showed up. I didn't even know I was having Yahoo problems.

I also started receiving multiple "You have an AIM crush... click here to find out who" messages a day again. That was something I was happy not to be receiving.

I guess my point is that there were a lot of things not working that I didn't know weren't, but the latest upgrade seemed to have fixed everything. Thank goodness!

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!