Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#5475 closed plugin request (fixed)

Screenshot Plugin

Reported by: rtrotter Owned by:
Milestone: Plugin Suggested Component: plugins
Version: 2.4.1 Keywords: screenshot, plugin
Cc: ccpaging, rberger

Description

Short -

Plugin that would allow a user to capture a screenshot, 'highlight' the important part, then send the screenshot as a file to another user.

Long -

I am setting up an internal Jabber server for remote users in my support department. Currently, I am using an Openfire/Spark? combo. Spark is cute and fuzzy and all, but it lacks plugin support and many features of Pidgin that I take for granted. The one feature that makes Spark really work in a support environment is the screenshot feature. When a user has an error on their screen, they can simply click the screenshot button, highlight the area of the screenshot that is needed, saved automatically as a file and the file is sent to the other user.

Apology - I realize that this could easily be avoided by using paint, but it's hard enough to convince some people that screenshots should be an image file and not a MS Word .doc.

Change History (7)

comment:1 Changed 11 years ago by deryni

  • Milestone set to Plugin Suggested

comment:2 Changed 11 years ago by Cube

This sounds extremely useful, I'll pass that to someone who already created the Skype and the Facebook plugin.

comment:3 Changed 10 years ago by ccpaging

QQ plugin also interesting.

comment:4 Changed 10 years ago by deryni

pidgin has supported QQ (to some small degree) for a while now, it comes as part of the normal package. And that request, even if valid, has absolutely nothing to do with this ticket, please don't do that.

comment:5 Changed 10 years ago by rberger

Hello.

Sometimes I need this feature too so I wrote a plugin, available here : http://raoulito.info/pidgin_screenshot/ I haven't intensively tested it, so you can expect a few bugs... I'm waiting for your suggestions to improve it. I will release a more stable / tested version one or two weeks later.

Raoul B.

comment:6 Changed 10 years ago by deryni

  • Resolution set to fixed
  • Status changed from new to closed

Added the plugin to the ThirdPartyPlugins#Miscellaneous page, closing this ticket.

comment:7 Changed 10 years ago by datallah

Ticket #9074 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!