Opened 11 years ago

Closed 10 years ago

#5520 closed enhancement (fixed)

Gmail mail notifications remain after the message(s) has been read

Reported by: trjonescp Owned by: darkrain42
Milestone: 2.6.0 Component: Google Talk
Version: 2.4.1 Keywords:
Cc:

Description

I don't know if this is possible within the context of the Google Talk API/protocol but I think the mail notifications should go away if the messages have been read independently of Pidgin. For example:

  1. New message arrives
  2. Pidgin shows new message notification
  3. User goes directly to gmail.com and reads the message
  4. Pidgin removes the new mail notification message

Change History (4)

comment:1 Changed 11 years ago by rgsteele

It used to be that the notification would disappear after the messages were read. This is a regression that first showed up in version 2.3.1. I've reported this bug in the Ubuntu bug tracker here:

https://bugs.launchpad.net/ubuntu/+source/pidgin/+bug/207528

comment:2 Changed 11 years ago by Maiku

I was poking at this the other day, and it seems that in order to make this work the best there needs to be a way to clear out all of the notification emails for a particular account, and also detect when a user closes the mail notification themselves.

The idea is that each time mail is requested, it needs to be filtered by the last time the user closed the mail notification, whether that was since logging in or the user actually closing it. Then it returns the description of all of the unread messages since then, and it wouldn't just return a count of all unread messages you have in total. Then it would work like other protocols.

Currently, there's no way to clear out all of the email notifications, except for adding zero messages. The other problem is that there's no way to tell when the user closed the notification. There is a callback to tell when the notification was removed, but that's called when you clear the messages programmatically as well.

comment:3 Changed 10 years ago by QuLogic

  • Owner changed from seanegan to darkrain42

comment:4 Changed 10 years ago by darkrain42

  • Milestone set to 2.6.0
  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed in 2.6.0; when I read all my unread email, the notification is removed.

If the issue still exists for you in 2.6.0, re-open this ticket (or comment and someone will re-open it).

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!