Opened 11 years ago

Closed 10 years ago

#5578 closed defect (worksforme)

unsubscribe with XMPP does not work

Reported by: mrmailer Owned by: darkrain42
Milestone: Component: Google Talk
Version: 2.4.1 Keywords: unsubscribe xmpp
Cc:

Description

In simply trying to stop seeing buddies as online, but still allowing them to see you, unsubscribe does not work for gtalk. It may work for a few moments, or even until you restart pidgin, but I have had to do it over and over and over again with the same contacts. The only thing that does work is canceling presence notification as well, but then they cannot see me.

Change History (9)

comment:1 Changed 11 years ago by Sim-on

  • Component changed from unclassified to XMPP
  • Owner changed from lschiere to nwalp

comment:2 Changed 11 years ago by deryni

  • pending changed from 0 to 1

Can you get the debug window (Help->Debug Window) output of what happens when you select Unsubscribe? This sounds to me like the Google Talk servers are not allowing that level of control.

comment:3 Changed 11 years ago by mrmailer

  • pending changed from 1 to 0

(11:24:43) jabber: Sending (ssl): <presence to='contactemail@…' type='unsubscribe'/> (11:24:44) jabber: Recv (ssl)(244): <iq to="myemail@…/Home3DF3B2A0" id="640FE01D" type="set"><query gr:ext="2" xmlns="jabber:iq:roster" xmlns:gr="google:roster"><item jid="contactemail@…" subscription="from" name="Josh"><group>Family</group></item></query></iq> (11:24:44) jabber: Recv (ssl)(260): <iq to="myemail@…/Home3DF3B2A0" id="640FE026" type="set"><query gr:ext="2" xmlns="jabber:iq:roster" xmlns:gr="google:roster"><item jid="contactemail@…" subscription="from" ask="subscribe" name="Josh"><group>Family</group></item></query></iq>

This is a contact I have repeatedly unsubscribed from. Also, they are still showing as online right now. I have to log off and log back on gtalk to get them to show offline, and even still, at some point later they start showing online again.

comment:4 Changed 11 years ago by deryni

  • Owner changed from nwalp to seanegan

Yeah, that looks to me like Google Talk isn't letting you do that. Notice that the first <iq> you get has 'subscription="from"' and that the second has 'subscription="from" ask="subscribe"' without you sending anything between them. That looks to me like Google Talk is sending a subscription request to your buddy for you (presumably as part of making it easier to add people in the first place). Sean this is all yours, this is either a Google Talk bug or a Google Talk design goal, either way this isn't a pidgin bug. So close this once you've commented on it whichever way it works.

comment:5 Changed 11 years ago by mrmailer

If it's a bug in gtalk, and possibly not going to be fixed any time soon, is it possible for pidgin to just not show the contacts that you've unsubscribed to, even though the protocol itself seems to be the issue?

comment:6 Changed 11 years ago by deryni

It would certainly be possible for pidgin to attempt to remember the people you hit Unsubscribe for, but that would make it basically impossible to manage your buddy list from multiple locations. Think about what happens if you unsubscribe on machine A and then later resubscribe on machine B, machine A will still have the buddy in the 'do not display' list. Not to mention this being horrible overhead for something the protocols supports just fine and which is either a Google Talk bug, or something which "is not a bug, it is a feature".

comment:7 Changed 11 years ago by mrmailer

Right, I understand your point. Unfortunately, for now, the only way to not see them on your buddy list is to remove them, meaning they can no longer see you(or cancel presence notification, which does the same thing).

comment:8 Changed 10 years ago by darkrain42

  • Component changed from XMPP to Google Talk
  • Owner changed from seanegan to darkrain42

comment:9 Changed 10 years ago by darkrain42

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this; using my gtalk account, I was able to unsubscribe from a non-gtalk account without generating an immediate authorization request to the non-gtalk account.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!