Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#5763 closed enhancement (duplicate)

Add Mail Recieve Sound constant to libpurple

Reported by: Maxious Owned by:
Milestone: Component: libpurple
Version: 2.4.1 Keywords: email, e-mail, sound, notification
Cc:

Description

In order to properly develop a plugin that provides aural notification of received emails, a new constant is required in libpurple to differentiate this sound from all others.

This is NOT a (direct) duplicate of #4684, #3479, #1324, #780 or #510; it is part of the way to a solution to all those tickets.

Attachments (1)

libpurple-mail-recieve-sound.patch (554 bytes) - added by Maxious 11 years ago.
Patch to add PURPLE_SOUND_MAIL_RECEIVE constant

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by Maxious

Patch to add PURPLE_SOUND_MAIL_RECEIVE constant

comment:1 follow-up: Changed 11 years ago by QuLogic

  • Resolution set to duplicate
  • Status changed from new to closed

The full patch already exists in #780, so I'm not sure why you opened this.

comment:2 in reply to: ↑ 1 Changed 11 years ago by Maxious

Replying to QuLogic:

The full patch already exists in #780, so I'm not sure why you opened this.

Because the full patch hasn't been applied (due to a string freeze in Pidgin?). If this patch is applied, non pidgin users of libpurple can implement this feature if/when they wish.

comment:3 Changed 11 years ago by rekkanoryo

I completely forgot the patch. Others may have too. We do need a sound for it, though.

All that said, none of this is required for non-Pidgin and non-Finch clients to implement a new mail notification--any additional sound events can be specified by the UI.

I'm going to merge the patch for 2.5.0, if we get a sound for it or come to an agreement on what sound we should use.

comment:4 Changed 10 years ago by adot

really looking forward to this being implemented... ...sorry, I understand all the devs here are volunteers, but according to #780 this has been ready for implementation for over a year. I would compile my own build but I hardly know the first thing about programming.

Having this sound event would increase my productivity; I work from home and monitor my business email account using Pidgin and I have to turn on my LCD every hour or so to see whether a notification has popped up. Having the new mail sound event would allow me to continue working uninterrupted and simply be notified with the sound when I have a new email; it seems to be the point of a "notification" in the first place---to not have to constantly be looking.

comment:5 Changed 10 years ago by Hunkah

I am in agreement. I have my back to the computer when I am working, so having a sound notification would do wonders for me. It seems insignificant to some, but to others like me, it is a great feature.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!