Opened 11 years ago

Closed 10 years ago

#5764 closed defect (out of date)

Horizontal rule ( <hr> ) does not come through when using Yahoo

Reported by: Lupicite Owned by: sulabh.dev
Milestone: Component: Yahoo!/Yahoo! JAPAN
Version: 2.4.0 Keywords: horizontal, hr
Cc:

Description

When using Yahoo as the IM provider and both of us are using Pidgin 2.4.0, when one of us sends a message and uses a horizontal rule, the receiver receives an < hr > as opposed to actually drawing the line that the sender sees.

Attachments (1)

horizontal rule not working.JPG (10.0 KB) - added by Lupicite 11 years ago.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by Lupicite

comment:1 Changed 11 years ago by SneakyWho_am_i

I can reproduce on Linux with 2.4.1. I can easily create a horizontal rule with the mouse (and it will appear in scrollback) but if someone sends me one, or if I type in "< hr >" (no quotes, no spaces) then I just see the <, > h and r

comment:2 Changed 11 years ago by datallah

  • Component changed from winpidgin (gtk) to Yahoo!
  • Owner changed from datallah to marv

If you type <hr> then you should see the text on the other end (the <> are escaped if you type them in) - the only issue is that inserting a horizontal rule doesn't go through to the other end correctly.

comment:3 Changed 10 years ago by bernmeister

Pidgin 2.5.7/2.5.8 and upcoming 2.6.0 have a lot of Yahoo fixes...can you please see if it's still an issue?

comment:4 Changed 10 years ago by rekkanoryo

Horizontal rules are not allowed on Yahoo, as they are an HTML feature and Yahoo doesn't do HTML IM. The bug here is that we don't strip them out.

comment:5 Changed 10 years ago by rekkanoryo

  • Owner changed from marv to sulabh.dev

Updating ticket to reflect the new primary maintainer of our Yahoo! code.

comment:6 Changed 10 years ago by sulabh.dev

  • Resolution set to out of date
  • Status changed from new to closed

I can't reproduce this bug in Pidgin 2.6.2. We do appear to be stripping the Horizontal rules. Probably we have fixed this issue since 2.4.0. If it appears to happen in the latest versions, please file a new ticket or comment us to reopen this one.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!