Opened 9 years ago

Closed 4 years ago

#5782 closed plugin request (worksforme)

Buddy list and chats in a single window

Reported by: kprateek88 Owned by:
Milestone: Plugin Suggested Component: pidgin (gtk)
Version: 2.4.1 Keywords: single-window
Cc: cyril42e

Description

There should be an option to have the buddy list and all IM/chat tabs in the same window. Perhaps a two-pane window, with the buddy list in one thinner pane, and tabbed chats in a wider pane (configurable, of course).

I like to think of the buddy list+chats as one entity ("Pidgin"), which should have one window. Right now I must have at least two windows, which [un]minimise/focus/etc separately; and which are treated as two separate windows in the taskbar, Alt+Tab window switcher, other window switchers (using Compiz), and any other place where windows are listed. I use all other applications maximised, but need to manually arrange the Pidgin buddy list and chat windows side by side to appear like one maximised window.

Change History (21)

comment:1 Changed 9 years ago by deryni

  • Milestone set to Plugin Suggested

Placing conversation windows inside the buddy list should be doable with a plugin that registers a conversation placement function. That being said, pidgin already identifies all of its windows as being in the same 'window group' so your window manager would be perfectly within its rights to allow you to minimize/iconify/restore/move/etc. all the windows at the same time (I don't know of any that actually allow for this unfortunately).

comment:2 Changed 6 years ago by monkey.dl

+1 We need single window UI that should be more effective than clickin.. clickin-clickin... tabbin-tabbin through tons of windows

comment:3 Changed 6 years ago by alexykot

+1 for this feature

comment:4 Changed 6 years ago by Sage

+1 That would be great on MS Windows.

comment:5 Changed 6 years ago by proton

Will be usefull on netbooks

comment:6 Changed 6 years ago by mihai.stancu

+1 for this feature, back in the mIRC days on windows it was the way to roll, YM! changed all that, and this is an opportunity to make things right!

comment:7 Changed 6 years ago by Erulisse

+1 I will pay cash to the first person that implements this well.

comment:8 Changed 6 years ago by BW~Merlin

This would be a really awesome feature and one I would love to see included in pidgin.

comment:9 Changed 5 years ago by Peter17

+1 Please!

comment:10 Changed 5 years ago by salinasv

Ticket #13552 has been marked as a duplicate of this ticket.

comment:11 Changed 5 years ago by salinasv

Ticket #10845 has been marked as a duplicate of this ticket.

comment:12 Changed 5 years ago by OramahMaalhur

+1. It's very nice feature of gajim

comment:13 Changed 5 years ago by deryni

  • Type changed from enhancement to plugin request

comment:14 Changed 5 years ago by gwaewion

+1 want this feature too

comment:15 Changed 5 years ago by Uzix

+1 want!

comment:16 Changed 5 years ago by dm0

I actually wrote a plugin to do this myself a while ago, and I recently found this ticket while looking for an official version again. If any of you are really desperate for the functionality, you can test what I wrote. Note that the only testing this code has received was in my own limited use cases. Don't try it if you expect something stable.

I slapped together some boilerplate packaging files to make it look like a real project and uploaded the results here:

https://sites.google.com/site/dm0uploads/window_merge-0.1.tar.gz

https://github.com/dm0-/window_merge

You may run into a potential crash that I didn't get around to addressing yet, but if you make sure your tab placement preference is set to "top", you shouldn't encounter the problem (as far as I can tell).

Anyone can feel free to fork my GitHub? repository, or submit issues and I can try to correct them.

comment:17 Changed 5 years ago by BW~Merlin

dm0 any chance you can make a Windows version as I will be keen to give it ago.

comment:18 Changed 5 years ago by dm0

Alright, I made an attempt at using MinGW here.

https://sites.google.com/site/dm0uploads/window_merge.dll (SHA1:18e742187aee443bf20071948bef8ba67048098b)

That file should be placed in the Application Data\.purple\plugins folder of your home directory. (I think certain versions of Windows use AppData? as well.) You may need to create the plugins folder. I tried it briefly on an old copy of XP, and it seemed to work.

Once I get things sorted, I'll update the GitHub? files to include the MinGW build process so people don't have to trust a random Windows binary.

comment:19 Changed 5 years ago by BW~Merlin

dm0, just installed this on Windows Vista 64bit Ultimate edition SP2 and it is working wonders. I have buddy list on the left and conversations tabbed on the right (yes I read your warring about a potential crash). This is exactly I wanted, I suggest you submit it as a patch for review and I will happily report any bugs I find to you.

comment:20 Changed 5 years ago by rekkanoryo

There is no reason for this to be submitted as a patch--it is something that belongs as a plugin, as it's not something we, as Pidgin developers, want to maintain.

comment:21 Changed 4 years ago by QuLogic

  • Resolution set to worksforme
  • Status changed from new to closed

There's a plugin for this. It's listed on the ThirdPartyPlugins page. I don't see why this ticket needs to remain open.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!