Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5825 closed defect (fixed)

2.4.2 Idle sticks after suspend.

Reported by: dave1g Owned by: lschiere
Milestone: Component: unclassified
Version: 2.4.2 Keywords: idle
Cc:

Description

If I close my laptop lid, and enter suspend mode, when I come back, open the lid, pidgin reconnects, but I'm stuck in the idle state. Even if I message people, I still appear idle both to myself and to other users.

Specifically this is using the aim protocol.

I have my idle settings as Report Idle time: Last sent message

Autoreply when: away

Change status when idle is checked

Minutes before becoming idle: 5

Change status to: Away

Status at Startup

Use Status from last exit at startup is checked.

Attachments (2)

05-17-2008_18.11.50.96.log (162.2 KB) - added by dave1g 11 years ago.
debug log has a few mentions of idle and unidle .…
idle.jpg (82.1 KB) - added by dave1g 11 years ago.
screenshot of im, settings, clock, and idle indication

Download all attachments as: .zip

Change History (19)

Changed 11 years ago by dave1g

debug log has a few mentions of idle and unidle ....

comment:1 Changed 11 years ago by dave1g

this is on windows and it might be required that I am idle before suspending the laptop to trigger the always idle on wakeup.

Changed 11 years ago by dave1g

screenshot of im, settings, clock, and idle indication

comment:2 Changed 11 years ago by bernmeister

Same behaviour for me (on WinXP) but a desktop without any screensaver/powersaver running.

Pidgin idles after 15 minutes (as per my preferences) and only restarting Pidgin will bring back the Available status.

comment:3 Changed 11 years ago by dave1g

strangely it looks like #5853 is the opposite of this bug.

comment:4 Changed 11 years ago by dave314159

I have the same problem on WinXP-SP3.
no screen saver, etc.
"Change status when idle" is not selected.

Interestingly, while experiencing the problem, if I change "report idle time:" to "Never" I immediately show up as idle. If I then change it back to "based on keyboard or mouse use" (my default) or "from last message," I immediately become "idle" again.

I hope that is a useful clue.

comment:5 follow-up: Changed 11 years ago by dave1g

you mean you change to "never" you become UNidle right? Thats what it did when I tried it, but switching back puts me back in the old idle state with the same large idle time.

comment:6 in reply to: ↑ 5 Changed 11 years ago by dave314159

Replying to dave1g:

yes, exactly. (sorry for the typo.)

comment:7 Changed 11 years ago by kozchris

I'm having the same problem here. This is a important issue for me. People use my idle status to know if I'm around. Can't stand the "R U there" pings. Hope this is something easy to fix.

comment:8 Changed 11 years ago by dave1g

yeah it really sucks, this needs to be fixed for 2.5.0 I had to turn off the idle feature completely

comment:9 Changed 11 years ago by dave1g

There seem to be a lot of problems with idle... some the exact opposite of each other (stuck in idle, vs never getting to idle) My problem is the stuck in idle forever one. CCing all to keep track.

#2002 #2525 #2681 #5825 #5853 #5967 #6041

comment:10 Changed 11 years ago by nealo

I have the same problem.

It is not limited to AIM. I am idle on AIM, ICQ, MSN, Yahoo, and Yahoo.jp. I am not idle on sametime and gtalk.

I'm not sure if this is useful: I just added myself as a buddy Yahoo, and my idle time is 337024:51. All other accounts were already added, and show sane idle times: ICQ, AIM, MSN: 15:27. Yahoo.jp: 1:15 (I took my computer out of standby this long ago). Both my Yahoo and Yahoo.jp accounts are away, for some reason.

Settings: Report idle time based on keyboard or mouse use. Auto-reply never (set to never because of this bug). auto-away disabled. Use status from last exit at startup enabled.

comment:11 follow-up: Changed 11 years ago by dave1g

I'm no longer seeing this problem in 2.4.3 on aim is anyone else still seeing this?

comment:12 in reply to: ↑ 11 Changed 11 years ago by Sim-on

  • pending changed from 0 to 1

Replying to dave1g:

I'm no longer seeing this problem in 2.4.3 on aim is anyone else still seeing this?

confirmed with ICQ. Seems to work now :)

comment:13 Changed 11 years ago by Sim-on

  • pending changed from 1 to 0
  • Resolution set to fixed
  • Status changed from new to closed

Oh, i just saw that this is your ticket, dave1g. So i can close this :) Thanks for the help!

@ All other who still have problems: please fill a new ticket or use one of these "duplicates" mentioned above.

comment:14 Changed 11 years ago by dave1g

This has started up for me again :-(

comment:15 Changed 11 years ago by dave1g

I went unidle, but the away message stuck.

(14:38:31) win32placement: Working Area RECT: L:0 R:1680 T:0 B:960
(14:38:31) oscar: Sending IM, charset=0x0000, charsubset=0x0000, length=122
(14:38:31) oscar: rate change (param ID 0x0001): curavg = 6000, maxavg = 6000, alert at 2000, clear warning at 2500, limit at 1500, disconnect at 800 (window size = 80)
(14:38:35) util: Writing file blist.xml to directory C:\Documents and Settings\David\Application Data\.purple
(14:38:35) util: Writing file C:\Documents and Settings\David\Application Data\.purple\blist.xml
(14:38:36) util: Writing file prefs.xml to directory C:\Documents and Settings\David\Application Data\.purple
(14:38:36) util: Writing file C:\Documents and Settings\David\Application Data\.purple\prefs.xml
(14:38:38) prefs: /purple/savedstatus/isidleaway changed, scheduling save.
(14:38:38) idle: Setting dave1g unidle
(14:38:38) oscar: Sending IM, charset=0x0000, charsubset=0x0000, length=2
(14:38:38) oscar: rate change (param ID 0x0001): curavg = 5936, maxavg = 6000, alert at 2000, clear warning at 2500, limit at 1500, disconnect at 800 (window size = 80)

then I set my self to available manually

(14:44:14) prefs: /purple/savedstatus/default changed, scheduling save.
(14:44:14) oscar: Set status to Available
(14:44:14) blist: Updating buddy status for dave1g (AIM)

Then I changed my idle settings to change after 1 minute. And everything was back to working fine..

(14:48:40) prefs: /purple/savedstatus/isidleaway changed, scheduling save.
(14:48:40) oscar: Set status to Away
(14:48:40) idle: Setting dave1g idle 79 seconds
(14:48:40) blist: Updating buddy status for dave1g (AIM)
(14:48:40) oscar: no more icons to request
(14:48:40) blist: Updating buddy status for dave1g (AIM)
(14:48:45) util: Writing file prefs.xml to directory C:\Documents and Settings\David\Application Data\.purple
(14:48:45) util: Writing file C:\Documents and Settings\David\Application Data\.purple\prefs.xml
(14:48:45) util: Writing file accounts.xml to directory C:\Documents and Settings\David\Application Data\.purple
(14:48:45) util: Writing file C:\Documents and Settings\David\Application Data\.purple\accounts.xml
(14:48:45) util: Writing file blist.xml to directory C:\Documents and Settings\David\Application Data\.purple
(14:48:45) util: Writing file C:\Documents and Settings\David\Application Data\.purple\blist.xml
(14:48:52) oscar: incomingim_ch1: unknown TLV 0x000d (len 27)
(14:48:52) oscar: incomingim_ch1: unknown TLV 0x0013 (len 1)
(14:48:52) oscar: Received IM from soothsayergirl with 1 parts
(14:48:52) oscar: Parsing IM part, charset=0x0000, charsubset=0x0000, datalen=124
(14:48:52) oscar: Sending IM, charset=0x0000, charsubset=0x0000, length=122
(14:48:52) oscar: rate change (param ID 0x0001): curavg = 5852, maxavg = 6000, alert at 2000, clear warning at 2500, limit at 1500, disconnect at 800 (window size = 80)
(14:48:59) prefs: /purple/savedstatus/isidleaway changed, scheduling save.
(14:48:59) oscar: Set status to Available
(14:48:59) idle: Setting dave1g unidle
(14:48:59) oscar: Sending IM, charset=0x0000, charsubset=0x0000, length=24
(14:48:59) sound: Playing C:\Program Files\Pidgin\sounds\purple\send.wav
(14:48:59) oscar: rate change (param ID 0x0001): curavg = 5870, maxavg = 6000, alert at 2000, clear warning at 2500, limit at 1500, disconnect at 800 (window size = 80)

comment:16 Changed 11 years ago by kozchris

It seems to be working for me. Thanks.

comment:17 Changed 11 years ago by dave1g

yeah i think at some point i must have accidentally set the away msg, or messed with it while idle, making pidgin think i had manually set it instead of tying it to the idle status

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!