Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#5828 closed defect (duplicate)

Invisible mode in Google Talk

Reported by: Mugunth Owned by: seanegan
Milestone: Component: Google Talk
Version: 2.4.2 Keywords:
Cc: anton, onlineapps

Description

Google talk client does not support invisible mode, but Jabber protocol does. Even the web based google talk that's integrated into gmail supports invisible mode. Can you make a plugin or do something to get this thing work in Pidgin?

Change History (13)

comment:1 Changed 9 years ago by deryni

Actually, XMPP did not (until very recently) really support invisibility in a way that anyone thought was appropriate or useful. The Google web client uses a Google specific invisibility feature that pidgin will not (and I believe can not reasonably) support. I do plan on attempting to support the new official invisibility XMPP proposal but seeing as I how I never use invisibility I am not particularly motivated to do so and as such have not made it a priority. People are welcome to attempt to write the code before I get to it, and I am always open for questions about how to do it. Lastly, even if support for invisibility were implemented according to spec it likely would not work for Google Talk.

Sean, I'm leaving this assigned to you since this seems to be a specific Google Talk request, feel free to reassign it to me if you think this should be a generic XMPP invisibility request instead.

comment:2 Changed 9 years ago by chipwizme

to make oneself invisible on a google talk account, paste the following into the XMPP Console (need to enable the plugin for xmpp console):

<presence>
<priority>5</priority>
</presence>
<presence type="unavailable">
<priority>5</priority>
</presence>

Someone please add this to the pidgin sourcecode?

comment:3 Changed 9 years ago by QuLogic

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #4509.

comment:4 Changed 8 years ago by pidgin

you should reopen this ticket, because gtalk implemented the invisibilty in a different way. gtalk invisibility should be implemented because its also supported via their own gtalk client.

implementing a fully standards compliant xmpp invisibility, like in #4509 is a different thing.

comment:5 Changed 8 years ago by deryni

We will not support the Google Talk invisibility, because it requires using their shared status stuff which we have no interest in supporting.

comment:6 Changed 8 years ago by darkrain42

Ticket #8520 has been marked as a duplicate of this ticket.

comment:7 Changed 8 years ago by anton

Sorry to disagree, but I think Pidgin should never pretend to support "Google Talk" as a component if it does not support specific mechanisms that it currently uses, such as routines for invisibility, file transfer, voice and video chat. Google Talk is not XMPP, they are much different since a long time ago. It is obvious, however, by what I've read here, that Gtalk's protocol and XMPP are still treated like the same thing.

comment:8 follow-up: Changed 8 years ago by deryni

Google Talk is XMPP, Google Talk simply has extensions that pidgin does not (and in the case of the invisibility support, can not and will not) support. The "Google Talk" account "type" in pidgin exists because many users were unaware of the fact that Google Talk was XMPP and were thus unable to figure out how to set up their accounts in pidgin.

Nothing prevents pidgin from supporting Google Talk extensions other than design, desire, and time. More specifically Voice and Video chat are not Google Talk extensions anymore, they are XMPP specifications and are in the process of being worked on. I know nothing about the Google Talk method of file transfer, but if it is what I think it is it will also become an official specification and thus be something that may get worked on.

I would gladly remove the "Google Talk" account type from pidgin were it not for the support headache that would result from such a change.

comment:9 in reply to: ↑ 8 Changed 8 years ago by chipwizme

I have manually implemented invisibility in the XMPP console. both invisibility to everyone and invisibility to only select users works fine.

Replying to deryni:

Google Talk is XMPP, Google Talk simply has extensions that pidgin does not (and in the case of the invisibility support, can not and will not) support. The "Google Talk" account "type" in pidgin exists because many users were unaware of the fact that Google Talk was XMPP and were thus unable to figure out how to set up their accounts in pidgin.

Nothing prevents pidgin from supporting Google Talk extensions other than design, desire, and time. More specifically Voice and Video chat are not Google Talk extensions anymore, they are XMPP specifications and are in the process of being worked on. I know nothing about the Google Talk method of file transfer, but if it is what I think it is it will also become an official specification and thus be something that may get worked on.

I would gladly remove the "Google Talk" account type from pidgin were it not for the support headache that would result from such a change.

comment:10 Changed 8 years ago by deryni

Presumably you used the <presence type="unavailable"/> "invisibility" method, correct?

That is not actually invisibility in any real way, it simply tells the server or the buddy that you are no longer available (the same thing that happens when you sign off). Most notably that doesn't prevent the client from IMing you, it doesn't prevent them from attempting to determine if you are online (and likely being able to succeed if they can guess your resource), and it does prevent the server (if you do this globally) from sending you any messages that aren't sent to your resource specifically. So yes, it sort-of works but isn't a really viable long-term solution.

There is a reason there have been at least four different attempts at defining invisibility on XMPP so far, it isn't an easy thing to do.

comment:11 follow-up: Changed 8 years ago by chipwizme

Most notably that doesn't prevent the client from IMing you

This is the whole point of invisibility. It allows IMs to be sent while being "offline." Since google talk implements offline messages, messages sent while a user is offline are not rejected either, so this doesn't allow too much information to be found. As for resources, I'd like to note that the AIM client features are displayed if an invisible "offline" contact is examined. By the way, how does google talk's shared status system work?

comment:12 in reply to: ↑ 11 ; follow-up: Changed 8 years ago by darkrain42

Replying to chipwizme:

Most notably that doesn't prevent the client from IMing you

You left out the bigger quote:

and it does prevent the server (if you do this globally) from sending you any messages that aren't sent to your resource specifically.

By the way, how does google talk's shared status system work?

Google Talk's Shared Status extension

comment:13 in reply to: ↑ 12 Changed 8 years ago by chipwizme

What's the problem with getting global server messages?

Replying to darkrain42:

Replying to chipwizme:

Most notably that doesn't prevent the client from IMing you

You left out the bigger quote:

and it does prevent the server (if you do this globally) from sending you any messages that aren't sent to your resource specifically.

By the way, how does google talk's shared status system work?

Google Talk's Shared Status extension

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!