Opened 11 years ago

Closed 11 years ago

#6030 closed defect (duplicate)

pidgin copies incorrect data to clipboard

Reported by: fluder Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.4.2 Keywords: clipboard
Cc:

Description

Hello!

Recently I upgraded my pidgin to a newer version (now it is 2.4.2). Now I have one nasty bug. It occurs when I copying some text from _pidgin_ window and then sending pasted data to someone (it was irc protocol in my situation). For example I copying this text: "(20:26:31) O_R_E_A_N_D_: hi", then pasting it to textfield - data in textfield is correct. Then I sending it, and user, that receiving this data sees this: "п»ї(20:26:31) O_R_E_A_N_D_: hi". As we can see there is some strange symbols - п»ї. Next example. I copying/pasting/sending this text: "AQUA вышел из комнаты". User receiving this: "п»їAQUA вышел РёР· комнаты".There is some strange symbols п»ї, but there is also character set conversion problem.

When I copying text from other application and pasting/sending it all works fine, and user receiving correct text. When I copying data from pidgin window to other application all also works fine and data is correct. So this bug occurs only when I copying text from _pidgin_ window and pasting it into pidgin.

Change History (1)

comment:1 Changed 11 years ago by QuLogic

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #5515.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!