Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#6124 closed defect

"Unable to send message" when using aim.

Reported by: Robby23 Owned by: MarkDoliner
Milestone: Component: AIM
Version: 2.5.8 Keywords:
Cc: sp219, aloibeth

Description

Whenever I try and send a message to someone it says "Unable to send message"

Attached is a debug log. At (4:29:13 AM) i sent a msg

Attachments (3)

debug.log (21.1 KB) - added by Robby23 9 years ago.
packet.pcap (176 bytes) - added by Robby23 9 years ago.
AOL labeled packets in wireshark
packet.2.pcap (7.7 KB) - added by Robby23 9 years ago.
AIM Packets

Download all attachments as: .zip

Change History (46)

Changed 9 years ago by Robby23

comment:1 Changed 9 years ago by datallah

  • Component changed from unclassified to AIM
  • Owner changed from lschiere to MarkDoliner

comment:2 Changed 9 years ago by Robby23

anyone?

comment:3 Changed 9 years ago by deryni

  • pending changed from 0 to 1

Does this happen when you try to send a message to anyone or just to some people? Does this happen in all statuses or just some? What is your privacy setting for that account (Tools->Privacy)?

comment:4 Changed 9 years ago by Robby23

  • pending changed from 1 to 0

Privacy is set to block only the users below. No matter what status I'm in it still says the same thing.

If it helps I'm on a 64bit version of windows. I haven't had any problems on my other computer which runs both ubuntu and windows 32bit

comment:5 Changed 9 years ago by MarkDoliner

This is an AIM account and not ICQ, right? I'm not sure why that would happen. Do you have any strange plugins loaded? Maybe something that would be changing your message to an empty string before it gets sent?

comment:6 Changed 9 years ago by MarkDoliner

Oh, and does this happen when you try to send a message to anyone or just to some people?

comment:7 Changed 9 years ago by Robby23

I don't have any plugins installed, just basically installed it and I was never able to IM anyone. I'm using AIM. And it seems to happen when I try and send a message to anyone. Not one person that I've found that I can IM

comment:8 Changed 9 years ago by Robby23

anyone?

comment:9 Changed 9 years ago by deryni

  • pending changed from 0 to 1

Can you get a packet capture of pidgin attempting to send the message? I don't have anything more useful to suggest here and I don't know if Mark does or not.

comment:10 Changed 9 years ago by MarkDoliner

No I don't know why that would happen. It seems really strange.

comment:11 Changed 9 years ago by Robby23

  • pending changed from 1 to 0

How would you suggest I capture the packet. Any specific way? Also, I've tried reinstalling and still nothing. It works fine like I said on my other computer thats loaded with both Ubuntu and Windows 32bit.

comment:12 Changed 9 years ago by deryni

  • pending changed from 0 to 1

You can use a tool like Wireshark to get the packet capture.

Do you have accounts on other protocols? Have you tried them on this machine? Do they work?

comment:13 Changed 9 years ago by Robby23

  • pending changed from 1 to 0

I tried using an account on IRC and it works fine. I tried using another AIM account and that also fails. It seems to only be a problem with AIM.

As for capturing packets how would I filter it so only packets sent and received through pidgin would show.

Changed 9 years ago by Robby23

AOL labeled packets in wireshark

comment:14 Changed 9 years ago by deryni

  • pending changed from 0 to 1

While I don't know how to filter by application you should be able to filter either by destination IP or by port (possibly both) to get just the pidgin AIM traffic. Unfortunately the packet capture you uploaded doesn't appear to contain enough information to be useful.

Changed 9 years ago by Robby23

AIM Packets

comment:15 Changed 9 years ago by Robby23

  • pending changed from 1 to 0

Anyone =( ?

comment:16 Changed 9 years ago by deryni

Sorry, I somehow managed to miss your addition of the attachment. Unfortunately I can't make heads or tails out of what is going on in that second packet capture but I don't see anything that looks like a message being sent.

The only thing I can see, looking back at your debug log, is that right before the oscar prpl attempts to send the IM it prints out that it is going to only the message is listed as having a length of zero. Assuming I am reading the code around there correctly having a length of zero will mean that the oscar code will not bother trying to actually send the message. Why your message would have a length of zero I have no idea, it shouldn't (assuming you are actually typing a message and don't have any plugins loaded which are playing with your outgoing messages). We may need to wait for Mark to have time to look at this.

comment:17 Changed 9 years ago by MarkDoliner

I really don't know why that would.

If you're sure that you don't have any strange plugins loaded, then maybe g_convert() is failing in purple_plugin_oscar_convert_to_best_encoding()? We don't actually check the return value from g_convert() when converting to ASCII (because the conversion should never fail because we've already verified that the message is all ASCII characters). I don't even know why we bother calling g_convert() in that case.

comment:18 follow-up: Changed 9 years ago by Robby23

I don't have any plugins enabled if that helps any.

comment:19 in reply to: ↑ 18 Changed 9 years ago by zdneal

Replying to Robby23:

I don't have any plugins enabled if that helps any.

I had this same error, I tried going back to version 2.3.1 and that didn't help. However, when I re-installed the gtk+ from that old version it worked. One was something rev b and the one that works is something rev a. I can't seem to find out what version I have of gtk that is working, but the one that shipped with pidgin 2.4.3 didn't work with AIM on win2k for me.

comment:20 Changed 9 years ago by deryni

The Help->About dialog should indicate what version of Glib and GTK+ are installed and being used? Are either of you using a localized version of Windows? What about pidgin translations?

comment:21 Changed 9 years ago by faraher

I am getting the same error with AIM. I am not using any translations and privacy settings are not blocking anyone. I am using Extended Preferences 0.7 and Windows Pidgin Options 2.4.3 Plugins. What version of GTK+ was used in 2.3.1?

Debugging Information
  Plugins: Enabled
  SSL: SSL support is present.
  GTK+ Runtime: 2.12.8
  Glib Runtime: 2.14.6

  Library Support
    Cyrus SASL: Enabled
    Gadu-Gadu library (libgadu): Internal
    GtkSpell: Enabled
    GnuTLS: Disabled
    Network Security Services (NSS): Enabled
    Perl: Disabled
    Tcl: Disabled
    Tk: Disabled

comment:22 Changed 9 years ago by faraher

I downgraded to 2.3.1 and that seems to work fine.

comment:23 follow-up: Changed 9 years ago by Sim-on

  • Status changed from new to pending

Is this still a problem with 2.5.0 ?

comment:24 in reply to: ↑ 23 Changed 9 years ago by goodespeler

Replying to Sim-on:

Is this still a problem with 2.5.0 ?

Yup. Just installed and test. Still getting an unable to send message. Wish I wasn't...

comment:25 Changed 9 years ago by Sim-on

  • Status changed from pending to new
  • Version changed from 2.4.2 to 2.5.0

comment:26 Changed 9 years ago by heyhihello

I can confirm after trial and error with Pidgin portable 2.5.2 (and .3) that this is a problem with the GTK folder. If I splice in the GTK folder from Pidgin portable 2.3.1 I can send my AIM messages fine. The only downside is the interface is changed slightly. (I'm not sure of other ramifications)

comment:27 Changed 9 years ago by sp219

I am having the same issue with AIM on Pidgin 2.5.5 on Windows XP:


Debugging Information

Plugins: Enabled SSL: SSL support is present. GTK+ Runtime: 2.14.7 Glib Runtime: 2.18.4

Library Support

Cyrus SASL: Enabled Gadu-Gadu library (libgadu): Internal GtkSpell?: Enabled GnuTLS: Disabled Network Security Services (NSS): Enabled Perl: Disabled Tcl: Disabled Tk: Disabled


Hopefully someone can figure this out. Anyone have a workaround?

comment:28 follow-up: Changed 8 years ago by bernmeister

Is this still happening on 2.5.8 using the GTK+ that comes with it? You may have to do a full uninstall of Pidgin/GTK first...

comment:29 Changed 8 years ago by darkrain42

  • Status changed from new to pending

comment:30 in reply to: ↑ 28 Changed 8 years ago by goodespeler

Replying to bernmeister:

Is this still happening on 2.5.8 using the GTK+ that comes with it? You may have to do a full uninstall of Pidgin/GTK first...

Just did a complete uninstall and reinstall and I'm still getting the "Unable to send message."

comment:31 Changed 8 years ago by darkrain42

  • Status changed from pending to new
  • Version changed from 2.5.0 to 2.5.8

comment:32 follow-up: Changed 8 years ago by heyhihello

For me, this is more of an off and on issue. It'll be working fine for weeks then start doing this. goodespeler, would you mind giving Pidgin 2.5.8 portable a shot: http://downloads.sourceforge.net/portableapps/PidginPortable_2.5.8.paf.exe?download_redirect_do_not_right_click

It's completely self contained so you don't have to uninstall anything.

comment:33 in reply to: ↑ 32 Changed 8 years ago by goodespeler

Replying to heyhihello:

For me, this is more of an off and on issue. It'll be working fine for weeks then start doing this. goodespeler, would you mind giving Pidgin 2.5.8 portable a shot: http://downloads.sourceforge.net/portableapps/PidginPortable_2.5.8.paf.exe?download_redirect_do_not_right_click

It's completely self contained so you don't have to uninstall anything.

Tried portable and got the same error message - which is unfortunate! I was hoping for promising results.

comment:34 Changed 8 years ago by Datafreak

Hi,

please test this GTK: http://www.datafreak.eu/downloads/windows/GTK.rar

With this i can send messages.

MFG Datafreak

comment:35 Changed 8 years ago by datallah

Datafreak: Which GTK+ version are you linking to?

comment:36 Changed 8 years ago by Datafreak

Debugging-Information

Plugins: Enabled SSL: SSL support is present. GTK+ Runtime: 2.12.8 Glib Runtime: 2.14.3

comment:37 Changed 8 years ago by goodespeler

Any updates on this bad boy?

comment:38 Changed 8 years ago by Datafreak

knock, knock - any news here?

Regards, Datafreak

comment:39 Changed 8 years ago by deryni

  • Status changed from new to pending

What's the status of this issue? Is this still happening with pidgin 2.6.6 and the version of GTK+ it bundles? Is it constant, intermittent, triggered by certain messages, happen more with certain people, etc?

comment:40 Changed 8 years ago by goodespeler

I've since upgraded machines and moved to Win 7 so I can longer replicate the issue.

comment:41 Changed 8 years ago by Datafreak

Hi,

I have test this with a protable version of pidgin (2.6.6): Portable - Pidgin Variante 1 from http://www.portable-pidgin.de/

If i send a Message with ICQ, i became this error:

(4:31:03 PM) Unable to send message.

In my Debug Windows i find this:

(16:31:03) oscar: Claiming to have a buddy icon

(16:31:03) oscar: Sending IM, charset=0x0000, charsubset=0x0000, length=0

comment:42 Changed 8 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:43 Changed 7 years ago by aloibeth

I'm also getting "Unable to send message" when trying to use the AIM protocol. This started today so I updated to the latest version of pidgin and the latest GTK but nothing seems to help :(

(18:49:17) oscar: Sending IM, charset=0x0000, charsubset=0x0000, length=0

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!