Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#6199 closed patch (fixed)

fix QQ Qun (NULL) error in 2.4.1

Reported by: colyli Owned by: csyfek
Milestone: 2.5.0 Component: QQ
Version: 2.4.1 Keywords: Qun NULL
Cc: ccpaging@…

Description

Since pidgin 2.3.1, name of QQ Qun always gets displayed as (NULL). This patch fixes this error against 2.4.1. This is a pretty yearning fix for QQ users, hope can be applied ASAP.

Signed-off-by: Coly Li <coyli@…> --- diff -ru pidgin-2.4.1-origlibpurple/protocols/qq/char_conv.c pidgin-2.4.1/libpurple/protocols/qq/char_conv.c --- pidgin-2.4.1-origlibpurple/protocols/qq/char_conv.c 2008-04-01 01:21:24.000000000 +0800 +++ pidgin-2.4.1/libpurple/protocols/qq/char_conv.c 2008-06-27 23:16:27.000000000 +0800 @@ -132,8 +132,8 @@

g_return_val_if_fail(data != NULL && from_charset != NULL, -1);

  • len = data[0];
  • *ret = _my_convert((gchar *) (data + 1), (gssize) len, UTF8, from_charset);

+ len = strlen(data); + *ret = _my_convert((gchar *) data, (gssize) len, UTF8, from_charset);

return len + 1;

}

diff -ru pidgin-2.4.1-origlibpurple/protocols/qq/group_info.c pidgin-2.4.1/libpurple/protocols/qq/group_info.c --- pidgin-2.4.1-origlibpurple/protocols/qq/group_info.c 2008-04-01 01:21:24.000000000 +0800 +++ pidgin-2.4.1/libpurple/protocols/qq/group_info.c 2008-06-27 23:15:46.000000000 +0800 @@ -170,6 +170,7 @@

GSList *pending_id; gint pascal_len, i; guint32 unknown4;

+ guint16 unknown2;

guint8 unknown1;

g_return_if_fail(data != NULL && len > 0);

@@ -198,7 +199,7 @@

read_packet_dw(data, cursor, len, &(group->group_category)); read_packet_w(data, cursor, len, &max_members); read_packet_b(data, cursor, len, &unknown1);

  • read_packet_dw(data, cursor, len, &(unknown4)); /* versionID */

+ read_packet_w(data, cursor, len, &(unknown2));

pascal_len = convert_as_pascal_string(*cursor, &(group->group_name_utf8), QQ_CHARSET_DEFAULT); *cursor += pascal_len;

Change History (13)

comment:1 Changed 11 years ago by QuLogic

  • Type changed from defect to patch

comment:2 Changed 11 years ago by Sim-on

  • Owner changed from seanegan to csyfek

comment:3 Changed 11 years ago by csyfek

  • Cc ccpaging@… added
  • Milestone set to 2.4.3
  • Status changed from new to assigned

comment:4 Changed 11 years ago by QuLogic

  • Milestone 2.4.3 deleted

It's better to set milestone when it's committed (unless it's one of those long-term milestones) because then we don't have to go fixing it if the patch wasn't committed.

comment:5 Changed 11 years ago by csyfek@…

(In 54416c3a9ed80862d700c73b4a62bffe02e23534):
Sun Jun 29 22:00:12 CST 2008 csyfek@…

  • 20080629-fixed-qun-processing Merged patches from moo, ccpaging and coly

Tickets: References #6199

Sat Jun 28 13:25:40 CST 2008 csyfek@…

  • 20080628-get-friends Patches from moo and ccpaging.

Tickets: Fixes #4956. Fixes #2998.

comment:6 Changed 11 years ago by csyfek

  • Milestone set to Patches Needing Improvement

comment:7 Changed 11 years ago by MarkDoliner

csyfek: I noticed that you've set this to "Patches Needing Improvement"... have you talked to colyli about any changes that he could make? I guess I'm just curious what the status is on this patch/ticket. Thanks!

comment:8 Changed 11 years ago by csyfek

Mark: I've talked with coly and we found out that problem related to the version of QQ protocol. So this problem will be hopefully solved when we update the protocol section.

comment:9 Changed 11 years ago by MarkDoliner

Great!

comment:10 follow-up: Changed 11 years ago by slacka

I can confirm that the bug has not been fixed in pidgin-2.5.0. Are there any workarounds?

comment:11 in reply to: ↑ 10 Changed 11 years ago by ccpaging

Any detail information in your can?

OS version, pidgin about, pidgin debug information.

comment:12 Changed 11 years ago by csyfek

  • Resolution set to fixed
  • Status changed from new to closed

This bug has been solved. 2.5.0 (NULL) problem is due to the text converting problem of pidgin itself.

comment:13 Changed 10 years ago by darkrain42

  • Milestone changed from Patches Needing Improvement to 2.5.0
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!