Opened 11 years ago

Closed 11 years ago

#6200 closed patch (fixed)

Make i.p.gobjectification build on win32

Reported by: phroggie Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.4.2 Keywords:
Cc:

Description

Attached patch brings im.pidgin.gobjectification to a buildable (and nearly usable) state for win32 users.

Attachments (3)

win32-gobjectification.diff (13.7 KB) - added by phroggie 11 years ago.
win32-gobjectification.v2.diff (9.7 KB) - added by phroggie 11 years ago.
Remove bits that Sadrul checked in
win32-gobjectification.v3.diff (10.9 KB) - added by phroggie 11 years ago.
Upgrade win32 i.p.gobject to build msn instead of msnp9

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by phroggie

comment:1 Changed 11 years ago by Lee Roach <phroggster@…>

(In 09c9df753700d1a38895d5ae3425da0e262395bf):
Various compilation fixes. References #6200.

Changed 11 years ago by phroggie

Remove bits that Sadrul checked in

Changed 11 years ago by phroggie

Upgrade win32 i.p.gobject to build msn instead of msnp9

comment:2 Changed 11 years ago by phannent

Hello,

I can confirm this patch applies just fine. I have compiled a windows version for testing: http://www.hannent.eu/pidgin/gobject/

comment:3 follow-up: Changed 11 years ago by datallah

glib-genmarshal fails for me. Are you using a different version of glib than 2.6.10?

comment:4 Changed 11 years ago by phannent

I am using: GTK+ Runtime: 2.12.8 Glib Runtime: 2.14.6

Sorry, I did not realise.

comment:5 Changed 11 years ago by datallah

I'm actually referring to the version of GTK+ that it is being built against, not what is used at runtime.

comment:6 in reply to: ↑ 3 Changed 11 years ago by phroggie

Replying to datallah:

glib-genmarshal fails for me. Are you using a different version of glib than 2.6.10?

Using the official dev package from BuildingWinPidgin: gtk-dev-2.6.10-rev-a.tar.gz. What's the hangup from glib-genmarshal?

comment:7 Changed 11 years ago by datallah

I'm not sure what the issue is - I haven't had time to do any debugging yet, the command just fails (returns an error exit code) and I can't get it to output anything.

comment:8 Changed 11 years ago by phroggie

If you're getting something along the lines of

../../win32-dev/gtk_2_0/bin/glib-genmarshal --prefix=purple_smarshal marshallers.list --body > marshallers.c
make[1]: *** [marshallers.c] Error 53

try adding "/cygdrive/c/Program\ Files/Common?\ Files/GTK/2.0/bin" (or similar) to $PATH. glib-genmarshal likely isn't finding it's needed libraries. Do a "make clean" after this, and try building again.


I notice after updating to b5610bfa that perl compilation fails with something like

/cygdrive/c/perl/bin/perl C:/perl/lib/ExtUtils/xsubpp -typemap C:/perl/lib/ExtUtils/typemap -typemap ../../../../libpurple/plugins/perl/common/typemap Status.xs > Status.c
Error: 'GValue *' not in typemap in Status.xs, line 244
Error: 'GValue *' not in typemap in Status.xs, line 250
Error: 'GValue *' not in typemap in Status.xs, line 282
Error: 'GValue *' not in typemap in Status.xs, line 359
make[1]: *** [Status.c] Error 1

I don't know the best way around this, shy of disabling perl (which might be a good thing until i.p.gobjectification is stable), or requiring perl-glib for compilation and runtime. Try the attached V3 patch against 2bec3817 in the meantime.

comment:9 Changed 11 years ago by datallah

  • Resolution set to fixed
  • Status changed from new to closed

This has been committed in revision c0f5cd0dee6b7415c1b282c3623bf48ed91ef769.

Thanks.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!