Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#6220 closed defect (fixed)

ICQ reports that "client is too old"

Reported by: nouse66 Owned by: MarkDoliner
Milestone: 2.4.3 Component: ICQ
Version: 2.4.2 Keywords:
Cc:

Description

When I try to connect to an ICQ account I get the following message:

"The client version you are using is too old. Please upgrade at http://pidgin.im/"

Debug log:

(09:41:27) jabber: jabber_actions: have pep: NO
(09:41:27) account: Connecting to account 318427324
(09:41:27) connection: Connecting. gc = 05EC0710
(09:41:27) oscar: registered module misc (family 0xffff, version = 0x0000, tool 0x0000, tool version 0x0000)
(09:41:27) oscar: registered module oservice (family 0x0001, version = 0x0003, tool 0x0110, tool version 0x0629)
(09:41:27) oscar: registered module locate (family 0x0002, version = 0x0001, tool 0x0110, tool version 0x0629)
(09:41:27) oscar: registered module buddy (family 0x0003, version = 0x0001, tool 0x0110, tool version 0x0629)
(09:41:27) oscar: registered module messaging (family 0x0004, version = 0x0001, tool 0x0110, tool version 0x0629)
(09:41:27) oscar: registered module admin (family 0x0007, version = 0x0001, tool 0x0010, tool version 0x0629)
(09:41:27) oscar: registered module popup (family 0x0008, version = 0x0001, tool 0x0104, tool version 0x0001)
(09:41:27) oscar: registered module bos (family 0x0009, version = 0x0001, tool 0x0110, tool version 0x0629)
(09:41:27) oscar: registered module userlookup (family 0x000a, version = 0x0001, tool 0x0110, tool version 0x0629)
(09:41:27) oscar: registered module stats (family 0x000b, version = 0x0001, tool 0x0104, tool version 0x0001)
(09:41:27) oscar: registered module chatnav (family 0x000d, version = 0x0001, tool 0x0010, tool version 0x0629)
(09:41:27) oscar: registered module chat (family 0x000e, version = 0x0001, tool 0x0010, tool version 0x0629)
(09:41:27) oscar: registered module odir (family 0x000f, version = 0x0001, tool 0x0010, tool version 0x0629)
(09:41:27) oscar: registered module bart (family 0x0010, version = 0x0001, tool 0x0010, tool version 0x0629)
(09:41:27) oscar: registered module feedbag (family 0x0013, version = 0x0004, tool 0x0110, tool version 0x0629)
(09:41:27) oscar: registered module icq (family 0x0015, version = 0x0001, tool 0x0110, tool version 0x047c)
(09:41:27) oscar: registered module auth (family 0x0017, version = 0x0000, tool 0x0000, tool version 0x0000)
(09:41:27) oscar: registered module alert (family 0x0018, version = 0x0001, tool 0x0010, tool version 0x0629)
(09:41:27) oscar: Adding handler for ffff/0003
(09:41:27) oscar: Adding handler for ffff/0006
(09:41:27) oscar: Adding handler for 0007/0003
(09:41:27) oscar: Adding handler for 0007/0005
(09:41:27) oscar: Adding handler for 0007/0007
(09:41:27) oscar: Adding handler for 0018/0001
(09:41:27) oscar: Adding handler for 0018/0007
(09:41:27) oscar: Adding handler for 0017/0003
(09:41:27) oscar: Adding handler for 0017/0007
(09:41:27) oscar: Adding handler for 0017/000a
(09:41:27) oscar: Adding handler for 0010/0005
(09:41:27) oscar: Adding handler for 0009/0001
(09:41:27) oscar: Adding handler for 0009/0003
(09:41:27) oscar: Adding handler for 0003/0001
(09:41:27) oscar: Adding handler for 0003/0003
(09:41:27) oscar: Adding handler for 0003/000b
(09:41:27) oscar: Adding handler for 0003/000c
(09:41:27) oscar: Adding handler for 000e/0001
(09:41:27) oscar: Adding handler for 000e/0003
(09:41:27) oscar: Adding handler for 000e/0004
(09:41:27) oscar: Adding handler for 000e/0002
(09:41:27) oscar: Adding handler for 000e/0006
(09:41:27) oscar: Adding handler for 000d/0001
(09:41:27) oscar: Adding handler for 000d/0009
(09:41:27) oscar: Adding handler for 0013/0001
(09:41:27) oscar: Adding handler for 0013/0003
(09:41:27) oscar: Adding handler for 0013/0006
(09:41:27) oscar: Adding handler for 0013/000e
(09:41:27) oscar: Adding handler for 0013/0008
(09:41:27) oscar: Adding handler for 0013/0009
(09:41:27) oscar: Adding handler for 0013/0015
(09:41:27) oscar: Adding handler for 0013/0019
(09:41:27) oscar: Adding handler for 0013/001b
(09:41:27) oscar: Adding handler for 0013/001c
(09:41:27) oscar: Adding handler for 0004/0007
(09:41:27) oscar: Adding handler for 0004/000a
(09:41:27) oscar: Adding handler for 0004/000b
(09:41:27) oscar: Adding handler for 0004/0001
(09:41:27) oscar: Adding handler for 0004/0014
(09:41:27) oscar: Adding handler for 0004/000c
(09:41:27) oscar: Adding handler for 0015/00f3
(09:41:27) oscar: Adding handler for 0015/00f2
(09:41:27) oscar: Adding handler for 0002/0003
(09:41:27) oscar: Adding handler for 0002/0006
(09:41:27) oscar: Adding handler for 0002/0001
(09:41:27) oscar: Adding handler for 0002/fffd
(09:41:27) oscar: Adding handler for 0001/0001
(09:41:27) oscar: Adding handler for 0001/000f
(09:41:27) oscar: Adding handler for 0001/001f
(09:41:27) oscar: Adding handler for 0001/0021
(09:41:27) oscar: Adding handler for 0001/000a
(09:41:27) oscar: Adding handler for 0001/0005
(09:41:27) oscar: Adding handler for 0001/0013
(09:41:27) oscar: Adding handler for 0001/0010
(09:41:27) oscar: Adding handler for 0008/0002
(09:41:27) oscar: Adding handler for 000a/0001
(09:41:27) oscar: Adding handler for 000a/0003
(09:41:27) oscar: oscar_login: gc = 05EC0710
(09:41:27) dnsquery: Performing DNS lookup for login.oscar.aol.com
(09:41:27) dnsquery: IP resolved for login.oscar.aol.com
(09:41:27) proxy: Attempting connection to 205.188.153.121
(09:41:27) proxy: Connecting to login.oscar.aol.com:5190 with no proxy
(09:41:27) proxy: Connection in progress
(09:41:27) proxy: Connected to login.oscar.aol.com:5190.
(09:41:27) oscar: connected to FLAP server of type 0x0017
(09:41:27) oscar: Username sent, waiting for response
(09:41:28) oscar: inside auth_resp (Username: 318427324)
(09:41:28) jabber: jabber_actions: have pep: NO
(09:41:28) oscar: Login Error Code 0x001c
(09:41:28) oscar: Error URL: http://ftp.icq.com/pub/ICQ6/Install_ICQ6U2.exe
(09:41:28) account: Disconnecting account 02262288
(09:41:28) connection: Disconnecting connection 05EC0710
(09:41:28) oscar: Destroying oscar connection of type 0x0017.  Disconnect reason is 0
(09:41:28) oscar: Disconnected.  Code is 0x0000 and msg is 
(09:41:28) oscar: Signed off.
(09:41:28) jabber: jabber_actions: have pep: NO
(09:41:28) connection: Destroying connection 05EC0710

Attachments (2)

pidgin-oscar-versionfix.patch (441 bytes) - added by nhulsch 8 years ago.
just a version fix of the oscar.h - no guarantee that there are major protocol fixes that break your pidgin…
liboscar.zip (96.8 KB) - added by Sim-on 8 years ago.
for Windows: copy the file in this archiv to C:\Programs\Pidgin

Download all attachments as: .zip

Change History (21)

comment:1 Changed 8 years ago by jerrinot

same here. Probably some ugly change in ICQ protocol, as identical problem is in kopete: http://bugs.kde.org/show_bug.cgi?id=165502#c1

comment:2 in reply to: ↑ description Changed 8 years ago by antifumo

Confirm the bug (on v. 2.4.2), and also does the same with many older versions. Personally I wouldn't say that the priority of this bug is "minor", there's no more ICQ connectivity for anybody!

Changed 8 years ago by nhulsch

just a version fix of the oscar.h - no guarantee that there are major protocol fixes that break your pidgin...

comment:3 Changed 8 years ago by Jointy

Works fanastic....

Best Thanks

I have test it on amd64 gentoo with pidgin 2.4.2.

regards j0inty

comment:4 Changed 8 years ago by maniax

Priority: minor?

Are you kidding, this kills the ICQ for everybody :)

The patch works without issues, at least for now.

comment:5 Changed 8 years ago by Sim-on

  • priority changed from minor to blocker

the minority is unimportant...

i will attach another ! UNOFFICIAL ! patch provided in the IRC channel for Windows. It works well!

Changed 8 years ago by Sim-on

for Windows: copy the file in this archiv to C:\Programs\Pidgin

comment:6 Changed 8 years ago by antifumo

I also tried the patch proposed on the Ubuntu linux forums (http://launchpadlibrarian.net/15741199/pidgin-2.4.2-icq.patch), which basically increases the client ID number (0x010a to 0x010b), and it works fine on the Windows version. If somebody wants to manually patch the binary file on windows, this modification on version 2.4.2 changes byte #105319 in liboscar.dll to 0x0b (before it is 0x0a).

comment:7 Changed 8 years ago by landro

I can confirm this bug on Ubuntu Linux 8.10. Patching by http://launchpadlibrarian.net/15741199/pidgin-2.4.2-icq.patch worked for me. At first glance, this seems to be similar to pidgin-oscar-versionfix.patch as proposed by nhulsch.

comment:8 follow-up: Changed 8 years ago by j00bhaka

How do I download that attachment for windows?

comment:9 in reply to: ↑ 8 ; follow-up: Changed 8 years ago by landro

Replying to j00bhaka:

How do I download that attachment for windows?

Download liboscar.zip (added by Sim-on) and replace the liboscar.dll of your pidgin installation.

comment:10 in reply to: ↑ 9 ; follow-up: Changed 8 years ago by j00bhaka

Replying to landro:

Replying to j00bhaka:

How do I download that attachment for windows?

Download liboscar.zip (added by Sim-on) and replace the liboscar.dll of your pidgin installation.

I would, but I cannot find the download link :x! I r blind? ;]

comment:11 in reply to: ↑ 10 Changed 8 years ago by Laney

Replying to j00bhaka:

Replying to landro:

Replying to j00bhaka:

How do I download that attachment for windows?

Download liboscar.zip (added by Sim-on) and replace the liboscar.dll of your pidgin installation.

I would, but I cannot find the download link :x! I r blind? ;]

Scroll up, it's just below the original bug report.

comment:12 Changed 8 years ago by nouse66

Confirming that the windows patch worked great for me on vista.

comment:14 Changed 8 years ago by j00bhaka

Thank you very much!

comment:15 Changed 8 years ago by Sim-on

Quotation of IRC:

(00:40:21) rekkanoryo: we know the problem, we have fixed the problem, and are getting ready to release a new version

comment:16 Changed 8 years ago by rekkanoryo

  • Resolution set to fixed
  • Status changed from new to closed

We have released 2.4.3, which fixes this issue.

comment:17 in reply to: ↑ description Changed 7 years ago by mike3050

Replying to nouse66:

When I try to connect to an ICQ account I get the following message:

"The client version you are using is too old. Please upgrade at http://pidgin.im/"

Debug log:

I had the same problem,but follow what other says above and you wills solve it.

comment:18 follow-up: Changed 7 years ago by darkrain42

mike3050, please file a new ticket for your issue and include the Help->Debug Window output.

comment:19 in reply to: ↑ 18 Changed 7 years ago by mike3050

spam comment removed --darkrain

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!