Opened 11 years ago

Closed 10 years ago

#6239 closed defect (fixed)

Window icon should not be padded with black if buddy icon is not square

Reported by: Aaron44126 Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.4.2 Keywords:
Cc: aaronkelley@…

Description

If a buddy icon is not square (i.e., it is taller than it is wide or vice versa), it may be padded with black when it is rendered as the Window icon, that is, the icon that appears in the top-left corner of the window and on the taskbar.

Generally, these icons are handled well - support for partial transparencies (in PNGs) for example seems to be present. It just doesn't like non-square icons.

Here is an example of what I'm talking about: Click here

Thanks!

Change History (4)

comment:1 Changed 11 years ago by Aaron44126

To be clear, I am suggesting that the icon be centered and padded with "transparent" rather than padded with black.

comment:2 Changed 10 years ago by bernmeister

I don't know if this has been fixed or not, but on my buddy list I've got a couple of instances where the icon is narrow and the sides appear to be transparent.

Is this still happening on 2.5.8?

comment:3 Changed 10 years ago by darkrain42

  • Status changed from new to pending

comment:4 Changed 10 years ago by Aaron44126

  • Resolution set to fixed
  • Status changed from pending to closed

I can't reproduce it anymore... I'm going to call it fixed.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!