Opened 11 years ago

Closed 11 years ago

#6252 closed defect (duplicate)

Pidgin randomly crashes

Reported by: GrayFox777 Owned by: lschiere
Milestone: Component: unclassified
Version: 2.4.3 Keywords: crash, talk, anytime
Cc:

Description

It just crashes at any random time. It happens at least once a day, but sometimes more than that. It never happened before I upgraded from the old version I was using. I tried downgrading, but the crashes still occurred, so I just upgraded again and tried the debug version. However, it did not create a pidgin.RPT file when it crashed!

When it crashes, the IM window just kinda freezes. Sometimes, the text blows up into a huge 72pt font (just a guess)!

Attachments (2)

pidgin2.RPT (4.4 KB) - added by GrayFox777 11 years ago.
pidgin.rpt (I just renamed it is all)
pidgin3.RPT (2.6 KB) - added by GrayFox777 11 years ago.
another one

Download all attachments as: .zip

Change History (20)

comment:1 Changed 11 years ago by GrayFox777

Also, as of now.... it has randomly just closed twice. It didn't crash these two times I'm talking about.... it just closed itself. I don't know what I was doing the first time, but I was scrolling through an IM window after talking to someone that had just signed off AIM. It didn't randomly close before I got the debug version.

comment:2 Changed 11 years ago by GrayFox777

Here's a link to a screenshot of a crash... (I'm guessing the times the program just closed are basically crashes, even though I didn't get the useless "send an error report" window. http://img379.imageshack.us/img379/3038/crashtl5.jpg

comment:3 Changed 11 years ago by GrayFox777

(19:59:08) GLib-GObject: invalid cast from `GtkEventBox' to `GtkButton'
(19:59:08) Gtk: gtk_button_get_relief: assertion `GTK_IS_BUTTON (button)' failed

I get those errors pretty often. Not sure if they have anything to do with this problem though.

comment:4 Changed 11 years ago by GrayFox777

I got a pidgin.rpt thing! Finally!

-------------------

Error occured on Thursday, July 10, 2008 at 04:28:01.

Windows Version 6.0 Build 6001 Service Pack 1

C:\Program Files\Pidgin\pidgin.exe caused an Access Violation at location 67ad44ff in module C:\Program Files\Common Files\GTK\2.0\bin\libcairo-2.dll 
Reading from location 000000ac.

Registers:
eax=00000000 ebx=05f224a0 ecx=76709d78 edx=00000000 esi=080053c0 edi=11051918
eip=67ad44ff esp=0022e990 ebp=0022e9a8 iopl=0         nv up ei pl nz na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00210206

Call stack:
67AD44FF C:\Program Files\Common Files\GTK\2.0\bin\libcairo-2.dll  cairo_surface_set_device_offset
         C:\Program Files\Common Files\GTK\2.0\bin\libgdk-win32-2.0-0.dll [2.12.8.0]
6C35B347 C:\Program Files\Common Files\GTK\2.0\bin\libgdk-win32-2.0-0.dll  gdk_window_begin_paint_region
         C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.12.8.0]
6188ACD8 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll  gtk_main_do_event
         C:\Program Files\Common Files\GTK\2.0\bin\libgdk-win32-2.0-0.dll [2.12.8.0]
6C35C4C3 C:\Program Files\Common Files\GTK\2.0\bin\libgdk-win32-2.0-0.dll  gdk_window_clear_area_e
6C35CC0D C:\Program Files\Common Files\GTK\2.0\bin\libgdk-win32-2.0-0.dll  gdk_window_process_updates
         C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.12.8.0]
6195A222 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll  gtk_text_view_new_with_buffer
         C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.14.6.0]
63A43945 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll  g_closure_invoke
63A57125 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll  g_signal_has_handler_pending
63A57EDA C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll  g_signal_emit_valist
63A58166 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll  g_signal_emit
         C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.12.8.0]
617928F0 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll  gtk_adjustment_value_changed
618F829A C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll  gtk_scrolled_window_get_shadow_type
6188C522 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll  gtk_marshal_VOID__UINT_STRING
         C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.14.6.0]
63A43945 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll  g_closure_invoke
63A56D56 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll  g_signal_has_handler_pending
63A57C2C C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll  g_signal_emit_valist
63A58166 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll  g_signal_emit
         C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.12.8.0]
619BE564 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll  gtk_widget_activate
618896C1 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll  gtk_propagate_event
6188AAE3 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll  gtk_main_do_event
         C:\Program Files\Common Files\GTK\2.0\bin\libgdk-win32-2.0-0.dll [2.12.8.0]
6C3712CE C:\Program Files\Common Files\GTK\2.0\bin\libgdk-win32-2.0-0.dll  gdk_event_get_graphics_expose
         C:\Program Files\Common Files\GTK\2.0\bin\libglib-2.0-0.dll [2.14.6.0]
685DE887 C:\Program Files\Common Files\GTK\2.0\bin\libglib-2.0-0.dll  g_main_context_dispatch
685DFD6B C:\Program Files\Common Files\GTK\2.0\bin\libglib-2.0-0.dll  g_main_context_acquire
685DFF5A C:\Program Files\Common Files\GTK\2.0\bin\libglib-2.0-0.dll  g_main_loop_run
         C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.12.8.0]
61889F3E C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll  gtk_main
         C:\Program Files\Pidgin\pidgin.dll [2.4.3.0]
64A8ED51 C:\Program Files\Pidgin\pidgin.dll  pidgin_main  /home/stu/build/win32/pidgin-2.4.3-mtn/pidgin/gtkmain.c:897
         C:\Program Files\Pidgin\pidgin.exe [2.4.3.0]
00401EFF C:\Program Files\Pidgin\pidgin.exe  WinMain@16  win32/winpidgin.c:658
00402736 C:\Program Files\Pidgin\pidgin.exe
004010B6 C:\Program Files\Pidgin\pidgin.exe  __mingw_CRTStartup  /home/bitwalk/redhat/BUILD/mingw-3.14/mingw-runtime-3.14/crt1.c:237
00401138 C:\Program Files\Pidgin\pidgin.exe

Changed 11 years ago by GrayFox777

pidgin.rpt (I just renamed it is all)

Changed 11 years ago by GrayFox777

another one

comment:5 Changed 11 years ago by GrayFox777

I've come up with a theory. I think it happens when there are two actions involving the program. Example: If I get 2 IMs from two different people at almost the same time. Example 2: If you scroll while someone sends you an IM. Just theories though. And it doesn't happen every single time.

comment:6 Changed 11 years ago by GrayFox777

Still can't get a debug log though. When I use...

cd "C:\Program Files\Pidgin"
pidgin.exe -d > debug.log

I just get "Access is denied."

comment:7 Changed 11 years ago by dave1g

#5662 has similar crash. if you are having difficulty getting the debug log, see TipsForBugReports#PreemptiveDebugLogging

comment:8 Changed 11 years ago by dave1g

and maybe #5593

comment:9 Changed 11 years ago by GrayFox777

That .bat script didn't work either. And yeah, this does seem a lot like Ticket #5593. Happens pretty often to me though.... usually a few times a day. However, I've downgraded GTK+ and it hasn't happened since, but time will tell....

comment:10 Changed 11 years ago by GrayFox777

Two days with no problems. This might be a problem with GTK+ and not Pidgin itself.

comment:11 Changed 11 years ago by GrayFox777

Currently on day five. No crashes. I think it's safe to say that GTK+ caused the problem.

comment:12 Changed 11 years ago by dave1g

what version of gtk were you on before, and which gtk version did you switch to, to fix the problem?

comment:13 Changed 11 years ago by GrayFox777

I was using whatever GTK+ version came with Pidgin 2.4.3. I switched to GTK+ Runtime 2.12.1 rev b and the problem went away.

comment:14 Changed 11 years ago by dave1g

I see 2.12.1 available here, http://ftp.gnome.org/pub/gnome/binaries/win32/gtk+/2.12/ , I will try it, but where did you get revision B?

comment:15 Changed 11 years ago by GrayFox777

It came with Pidgin 2.3.1, I believe.

comment:16 Changed 11 years ago by GrayFox777

Uninstall GTK+, install Pidgin 2.3.1 with GTK+, then install Pidgin 2.4.3 (but say no to the updated version of GTK+)

comment:17 Changed 11 years ago by dave1g

I think I have identified the exact problem with GTK/Cairo. Details on their trackers.

When the GTK and Cairo bugs listed are fixed, these pidgin/gaim tickets should be hopefully all be resolved as well

GTK bug - http://bugzilla.gnome.org/show_bug.cgi?id=543209

Cairo bug - http://bugs.freedesktop.org/show_bug.cgi?id=15761

Pidgin/gaim bugs: #5662 #5893 #4826 #5593 #5594 #6252

Mirror of old gaim sourceforge tracker: http://article.gmane.org/gmane.comp.gnome.gaim.bugs/175

comment:18 Changed 11 years ago by rlaager

  • Resolution set to duplicate
  • Status changed from new to closed

We seem to be closing these as a duplicate of #5662.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!