Opened 11 years ago

Closed 11 years ago

#6257 closed defect (fixed)

Pidgin crashes when sending THIS message

Reported by: mt1086 Owned by: QuLogic
Milestone: Component: MSN
Version: 2.4.2 Keywords:
Cc:

Description

Hi,

I'm using pidgin 2.4.2. When i send the message "http://jdownloaderinstall.ath.cx/" with the protocol MSNP14. Sometimes it just says that the message can't be send but most of the times the conversation windows halts (after interaction with the UI, eg: clicking the right button on the conversation window) for a while and then it says that the message wasn't delivered.

Matias.

Change History (11)

comment:1 Changed 11 years ago by mt1086

Damn, i couln't edit the post. If I start pidgin with --debug option, the log is huge, maybe this is useful:

15:56:13) msn: S: NS 000: CHL 0 23415605318445312121
(15:56:13) MSNP14: get payload len:0
(15:56:13) msn: C: NS 000: QRY 16 PROD01065C%ZFN6F 32
(15:56:13) msn: S: NS 000: QRY 16
(15:56:13) MSNP14: get payload len:0
(15:56:15) MSNP14: send IM {<A HREF="http://jdownloaderinstall.ath.cx/">http://jdownloaderinstall.ath.cx/</A>} to nicolas_espina@hotmail.com
(15:56:15) MSNP14: prepare to send online Message
(15:56:15) MSNP14: send via switchboard
(15:56:15) msn: new httpconn (0x8922848)
(15:56:15) msn: C: NS 000: XFR 17 SB
(15:56:15) MSNP14: switchboard send msg..
(15:56:15) msn: Appending message to queue.
(15:56:15) msn: S: NS 000: XFR 17 SB 207.46.26.130:1863 CKI 953447149.113162184.963130 U messenger.msn.com 1
(15:56:15) MSNP14: get payload len:0
(15:56:15) MSNP14: Switchboard:auth:{953447149.113162184.963130} socket:{207.46.26.130:1863}
(15:56:15) dns: DNS query for '207.46.26.130' queued
(15:56:15) dns: Created new DNS child 12100, there are now 1 children.
(15:56:15) dns: Successfully sent DNS request to child 12100
(15:56:15) dns: Got response for '207.46.26.130'
(15:56:15) dnsquery: IP resolved for 207.46.26.130
(15:56:15) proxy: Attempting connection to 207.46.26.130
(15:56:15) proxy: Connecting to 207.46.26.130:1863 with no proxy
(15:56:15) proxy: Connection in progress
(15:56:15) proxy: Connected to 207.46.26.130:1863.
(15:56:15) msn: C: SB 001: USR 1 torresmatias@hotmail.com 953447149.113162184.963130
(15:56:16) msn: S: SB 001: USR 1 OK torresmatias@hotmail.com %2e%20Matias%20%2e%20
(15:56:16) MSNP14: get payload len:0
(15:56:16) msn: C: SB 001: CAL 2 nicolas_espina@hotmail.com
(15:56:16) msn: S: SB 001: CAL 2 RINGING 953447149
(15:56:16) MSNP14: get payload len:0
(15:56:16) dbus: Need to register an object with the dbus subsystem. (If you are not a developer, please ignore this message.)
(15:56:16) dbus: The signal "drawing-tooltip" caused some dbus error. (If you are not a developer, please ignore this message.)
(15:56:16) msn: S: SB 001: JOI nicolas_espina@hotmail.com -%20N%20I%20C%20O%20------%3E%20Oxyura%20Vittata%20%28Yo%20Banco%20Al%20Pato%21%29 1342472230
(15:56:16) MSNP14: get payload len:0
(15:56:16) msn: Processing queue
(15:56:16) msn: Sending message
(15:56:16) msn: C: SB 001: MSG 3 A 183
(15:56:16) MSNP14: switchboard send msg..
(15:56:16) msn: C: SB 001: MSG 4 U 98
(15:56:17) msn: S: SB 001: NAK 3
(15:56:17) MSNP14: get payload len:0

...
(15:56:46) msn: S: NS 000: NLN NLN pablo_leon90@hotmail.com 1 Pablo 2254290988 %3Cmsnobj%20Creator%3D%22pablo_leon90%40hotmail.com%22%20Type%3D%223%22%20SHA1D%3D%22lLSUrZnxsuLyOw%2BqMHJv%2BaSmEts%3D%22%20Size%3D%222802%22%20Location%3D%220%22%20Friendly%3D%22SQBNAEcAXwAwADgAMAA0AAAA%22%2F%3E 
(15:56:46) MSNP14: get payload len:0
(15:56:46) blist: Updating buddy status for pablo_leon90@hotmail.com (MSN)
(15:56:46) cap: Executing: insert into cap_status (buddy, account, protocol, status, event_time) values(pablo_leon90@hotmail.com, torresmatias@hotmail.com, prpl-msn, available, now());
(15:56:46) msn: servconn read error,len: 0, errno: 2, error: No existe el fichero ó directorio
(15:56:46) msn: Connection error from Switchboard server (207.46.26.130): Error de lectura
(15:56:46) msn: destroy httpconn (0x8922848)

comment:2 Changed 11 years ago by rekkanoryo

  • pending changed from 0 to 1

GetABacktrace when it crashes again. There are known regular expressions that the MSN servers actively filter, and it seems that the MSNP14 code isn't handling it correctly.

comment:3 Changed 11 years ago by rekkanoryo

  • Component changed from unclassified to MSN
  • Owner changed from lschiere to QuLogic

comment:4 Changed 11 years ago by QuLogic

I think you meant to point to getting a backtrace here.

comment:5 Changed 11 years ago by QuLogic

It looks like after sending some blocked text, the SB sends an error, and then closes the connection. Somewhere this is causing some sort of deadlock. Some kind of broken select(), perhaps.

When you start typing, Pidgin will try to send a typing notification, notice the connection to the SB is gone, and wake up.

comment:6 Changed 11 years ago by mt1086

  • pending changed from 1 to 0

I'll send you a backtrace tomorrow, thanks for the quick replies.

comment:7 Changed 11 years ago by Sim-on

  • pending changed from 0 to 1

comment:8 Changed 11 years ago by mt1086

  • pending changed from 1 to 0

How do I get a backtrace if the program sits on a deadlock?? (Sorry, I don't know to say that in English, accepting corrections).

comment:9 Changed 11 years ago by QuLogic

I don't need a backtrace. It's easy to reproduce.

comment:10 Changed 11 years ago by qulogic@…

(In e0c15c710af77a687e1adb624fdf03917bfef2fe):
In MSN servconn, make handling of EAGAIN similar to that in httpconn. Now it should report an error when the server blocks some text and then disconnects, instead of continuously trying to read something and seeming totally frozen.

Also, stopped checking for EBADF, since it's not checked in httpconn.c or soap.c. I hope that doesn't break anything.

References #6257.

comment:11 Changed 11 years ago by QuLogic

  • Resolution set to fixed
  • Status changed from new to closed

In e56d7c10f8cc1dc7085e856b4028be46df81d9bd:

MSNP15 is here! Hopefully I didn't break anything. Sorry for the ton of mail here.

Fixes #3264. Fixes #3939. Fixes #4332. Fixes #4339. Fixes #4875
Fixes #4877. Fixes #5379. Fixes #5545. Fixes #5984. Fixes #6210.
Fixes #6257. Fixes #5212, I hope.
Somewhere or other, this also fixes #4876.
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!