Opened 11 years ago

Closed 11 years ago

#6266 closed defect (invalid)

segfault when receiving message (gstreamer)

Reported by: tomblue Owned by: lschiere
Milestone: Component: unclassified
Version: 2.4.3 Keywords: gstreamer
Cc:

Description

Pidgin 2.4.3 (Gentoo, AMD64) crashes when receiving a message and a chat window is currently open. This happens almost always (approx. 9 times out of 10).

To reproduce:

The easiest way is to add yourself as buddy (I've tested XMPP and ICQ). Once you've done this: write a message to yourself. When you hit the send key Pidgin will crash miserably.

Attachments (3)

coredump.log (43.0 KB) - added by tomblue 11 years ago.
stdout messages
stderror.log (359 bytes) - added by tomblue 11 years ago.
stderror message
backtrace.log (3.3 KB) - added by tomblue 11 years ago.
gdb backtrace of the crash

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by tomblue

stdout messages

Changed 11 years ago by tomblue

stderror message

comment:1 Changed 11 years ago by deryni

  • pending changed from 0 to 1

Follow the directions here to get a backtrace.

Changed 11 years ago by tomblue

gdb backtrace of the crash

comment:2 Changed 11 years ago by tomblue

  • pending changed from 1 to 0

I've added the gdb backtrace. Unfortunately there are no function names included in the trace, just '??'. But the crash seems to occur with libgstreamer. I've recompiled Pidgin without gstreamer support and everything works fine now.

I'm going to add another backtrace (with enabled debugging symbols in gstreamer) asap. That should hopefully reveal the function which causes the segfault.

comment:3 Changed 11 years ago by deryni

  • pending changed from 0 to 1

comment:4 Changed 11 years ago by tomblue

  • pending changed from 1 to 0

Tried to create a backtrace with enabled debug use flag of both gstreamer and pidgin. Unfortunately there are still no function names in the backtrace, just '??'.

comment:5 Changed 11 years ago by deryni

  • pending changed from 0 to 1

I would suggest you either attempt to recompile both gstreamer and pidgin from scratch (without any funny compiler flags you may or may not have) and then file a bug with gentoo about this if it still crashes inside gstreamer.

comment:6 Changed 11 years ago by QuLogic

I see you're using Pidgin 2.4.3, but what version of gstreamer do you have? In fact, just run equery l gst and post the output.

comment:7 Changed 11 years ago by tomblue

  • pending changed from 1 to 0

Sorry about the delay. Here you go:

[ Searching for package 'gst' in all categories among: ]

  • installed packages

[I--] [ ~] media-libs/gst-plugins-base-0.10.20 (0.10)
[I--] [ ] media-libs/gst-plugins-good-0.10.6 (0.10)
[I--] [ ~] media-libs/gst-plugins-ugly-0.10.8 (0.10)
[I--] [ ~] media-libs/gstreamer-0.10.20 (0.10)
[I--] [ ] media-plugins/gst-plugins-a52dec-0.10.6 (0.10)
[I--] [ ] media-plugins/gst-plugins-alsa-0.10.14 (0.10)
[I--] [M~] media-plugins/gst-plugins-cdio-0.10.7 (0.10)
[I--] [ ] media-plugins/gst-plugins-cdparanoia-0.10.14 (0.10)
[I--] [ ] media-plugins/gst-plugins-dvdread-0.10.6 (0.10)
[I--] [ ] media-plugins/gst-plugins-esd-0.10.6 (0.10)
[I--] [ ] media-plugins/gst-plugins-ffmpeg-0.10.2 (0.10)
[I--] [ ] media-plugins/gst-plugins-gconf-0.10.6 (0.10)
[I--] [ ] media-plugins/gst-plugins-gnomevfs-0.10.14 (0.10)
[I--] [ ] media-plugins/gst-plugins-mad-0.10.6 (0.10)
[I--] [ ~] media-plugins/gst-plugins-meta-0.10-r2 (0.10)
[I--] [ ] media-plugins/gst-plugins-mpeg2dec-0.10.6 (0.10)
[I--] [ ] media-plugins/gst-plugins-ogg-0.10.14 (0.10)
[I--] [ ] media-plugins/gst-plugins-pango-0.10.14 (0.10)
[I--] [ ] media-plugins/gst-plugins-vorbis-0.10.14 (0.10)
[I--] [ ] media-plugins/gst-plugins-x-0.10.14 (0.10)
[I--] [ ] media-plugins/gst-plugins-xvideo-0.10.14 (0.10)

comment:8 Changed 11 years ago by datallah

  • Keywords gstreamer added
  • Summary changed from segfault when receiving message to segfault when receiving message (gstreamer)

comment:9 Changed 11 years ago by QuLogic

I think I had something like this before, but then I upgraded all the gstreamer plugins, so I don't know which one fixed it exactly. Maybe you can try upgrading gst-plugins-good and see if that helps?

comment:10 Changed 11 years ago by tomblue

Recently there has been a gstreamer update. This seems to have fixed the problem. Pidgin is not crashing anymore. These are the now installed gst libs:

[I--] [ ~] media-libs/gst-plugins-base-0.10.20 (0.10)
[I--] [ ] media-libs/gst-plugins-good-0.10.8-r1 (0.10)
[I--] [ ~] media-libs/gst-plugins-ugly-0.10.8 (0.10)
[I--] [ ~] media-libs/gstreamer-0.10.20 (0.10)
[I--] [ ] media-plugins/gst-plugins-a52dec-0.10.8 (0.10)
[I--] [ ] media-plugins/gst-plugins-alsa-0.10.20 (0.10)
[I--] [M~] media-plugins/gst-plugins-cdio-0.10.7 (0.10)
[I--] [ ] media-plugins/gst-plugins-cdparanoia-0.10.14 (0.10)
[I--] [ ] media-plugins/gst-plugins-dvdread-0.10.8 (0.10)
[I--] [ ] media-plugins/gst-plugins-esd-0.10.8 (0.10)
[I--] [ ] media-plugins/gst-plugins-ffmpeg-0.10.2 (0.10)
[I--] [ ] media-plugins/gst-plugins-gconf-0.10.8-r1 (0.10)
[I--] [ ] media-plugins/gst-plugins-gnomevfs-0.10.20 (0.10)
[I--] [ ] media-plugins/gst-plugins-mad-0.10.8 (0.10)
[I--] [ ~] media-plugins/gst-plugins-meta-0.10-r2 (0.10)
[I--] [ ] media-plugins/gst-plugins-mpeg2dec-0.10.8 (0.10)
[I--] [ ] media-plugins/gst-plugins-ogg-0.10.20 (0.10)
[I--] [ ] media-plugins/gst-plugins-pango-0.10.20 (0.10)
[I--] [ ] media-plugins/gst-plugins-vorbis-0.10.20 (0.10)
[I--] [ ] media-plugins/gst-plugins-x-0.10.20 (0.10)
[I--] [ ] media-plugins/gst-plugins-xvideo-0.10.20 (0.10)

comment:11 Changed 11 years ago by QuLogic

  • Resolution set to invalid
  • Status changed from new to closed

Seems to be a GStreamer problem.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!