Opened 11 years ago

Closed 11 years ago

#6270 closed defect (fixed)

Gadu-Gadu "Unable to read socket"

Reported by: zonemr Owned by: bartosz
Milestone: 2.5.4 Component: Gadu-Gadu
Version: 2.5.0 Keywords:
Cc:

Description

Over the last few days it's been impossible to connect to GG.

The connection seems to succeed, but contacts can't be pulled from the server and messages can't be exchanged. After ~20 seconds, the connection dies "Unable to read socket".

Attachments (1)

pidgin-2.5-gg-empty-list-fix.patch (588 bytes) - added by zonemr 11 years ago.
Potential fix for GG connection problems with empty contact lists.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 11 years ago by zonemr

Update:

The GG protocol plugin is just a shim for libgadu. The libgadu sources bundled with libpurple are ancient and no longer work.

Upgrading to the latest libgadu resolved the problem for us.

http://toxygen.net/libgadu/

comment:2 Changed 11 years ago by zonemr

Afraid I spoke to soon. Updating libgadu DOES NOT resolve the problem.

We might have just been lucky on our first attempt (it seems to work one time in 20).

comment:3 Changed 11 years ago by Sim-on

in a way this is related to #6232?

comment:4 follow-up: Changed 11 years ago by Sim-on

  • Status changed from new to pending

is this still an issue with 2.5.0 ?

comment:5 in reply to: ↑ 4 Changed 11 years ago by zonemr

  • Status changed from pending to new

Replying to Sim-on:

is this still an issue with 2.5.0 ?

Yep :( Still seeing the same problem.

comment:6 Changed 11 years ago by zonemr

  • Version changed from 2.4.3 to 2.5.0

Ok, I think I've found the cause of this. This happens if the client-side contact list is empty.

According to the protocol document, a list of contacts should be sent upon login (GG_NOTIFY_FIRST/GG_NOTIFY_LAST). If the contact list is empty, a GG_LIST_EMPTY (0x12) packet should be sent. Pidgin doesn't do this.

It seems many GG servers will NOT respond to ANY other packets until this is sent. Therefore, the connection will just sit there doing nothing until it times out.

Changed 11 years ago by zonemr

Potential fix for GG connection problems with empty contact lists.

comment:7 Changed 11 years ago by hajder

I have to confirm that problem is connected with empty contact list in Pidgin. I haven't tried a patch supplied here, but in newest version at the moment (2.5.2) bug is still present. After adding only one contact I've successfully connected with server, however there's an issue with downloading contact list.

comment:8 Changed 11 years ago by martin@…

  • Milestone set to 2.5.4
  • Resolution set to fixed
  • Status changed from new to closed

(In b02e49ab446349d1bda77b32abd5de731fa8bcee):
Fix a connection timeout that occurs with empty Gadu-Gadu buddy lists. Fixes #6270.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!