Opened 11 years ago

Closed 11 years ago

#6282 closed defect (invalid)

finch crashes randomly when idle

Reported by: bulibuta Owned by:
Milestone: Component: libpurple
Version: 2.4.2 Keywords: crash finch
Cc:

Description

I left finch running for one night and here's what I come home to :-)

#0 0x09b9be0e in jabber_caps_ext_iqcb () from /usr/local/lib/libjabber.so.0.0 #1 0x09b8bc0e in jabber_iq_parse () from /usr/local/lib/libjabber.so.0.0 #2 0x09b8c47c in jabber_process_packet () from /usr/local/lib/libjabber.so.0.0 #3 0x09b94623 in jabber_parser_element_end_libxml ()

from /usr/local/lib/libjabber.so.0.0

#4 0x0d42b2f8 in xmlParseEndTag2 () from /usr/local/lib/libxml2.so.9.8 #5 0x0d42f01f in xmlParseTryOrFinish () from /usr/local/lib/libxml2.so.9.8 #6 0x0d42f4f4 in xmlParseChunk () from /usr/local/lib/libxml2.so.9.8 #7 0x09b94742 in jabber_parser_process () from /usr/local/lib/libjabber.so.0.0 #8 0x09b8c945 in jabber_recv_cb_ssl () from /usr/local/lib/libjabber.so.0.0 #9 0x0ef54b3f in recv_cb () from /usr/local/lib/libpurple.so.3.2 #10 0x1c01c6f2 in finch_xfers_get_ui_ops () #11 0x0df8e8b3 in g_vasprintf () from /usr/local/lib/libglib-2.0.so.1600.0 #12 0x0df6126d in g_source_is_destroyed ()

from /usr/local/lib/libglib-2.0.so.1600.0

#13 0x0df62271 in g_main_context_dispatch ()

from /usr/local/lib/libglib-2.0.so.1600.0

#14 0x0df62596 in g_main_context_dispatch ()

from /usr/local/lib/libglib-2.0.so.1600.0

#15 0x0df62aa2 in g_main_loop_run () from /usr/local/lib/libglib-2.0.so.1600.0 #16 0x05f33459 in gnt_main () from /usr/local/lib/libgnt.so.3.1 #17 0x1c01cc59 in main ()

Now seriously, if you need any further info I'll be happy to provide it.

$ dmesg | head OpenBSD 4.3-current (GENERIC) #940: Thu Jun 19 07:41:29 MDT 2008

deraadt@…:/usr/src/sys/arch/i386/compile/GENERIC

cpu0: Intel(R) Pentium(R) 4 CPU 2.80GHz ("GenuineIntel?" 686-class) 2.80 GHz cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,CNXT-ID,xTPR real mem = 1064333312 (1015MB) avail mem = 1020952576 (973MB) mainbus0 at root bios0 at mainbus0: AT/286+ BIOS, date 09/03/04, BIOS32 rev. 0 @ 0xfd6e0, SMBIOS rev. 2.31 @ 0xef620 (82 entries) bios0: vendor FUJITSU SIEMENS Phoenix Technologies Ltd. version "5.00 R2.10.1534.01" date 09/03/2004 bios0: FUJITSU SIEMENS SCENIC E

Change History (5)

comment:1 Changed 11 years ago by bulibuta

Once again with code tags, forgot this is web2.0

#0  0x09b9be0e in jabber_caps_ext_iqcb () from /usr/local/lib/libjabber.so.0.0
#1  0x09b8bc0e in jabber_iq_parse () from /usr/local/lib/libjabber.so.0.0
#2  0x09b8c47c in jabber_process_packet () from /usr/local/lib/libjabber.so.0.0
#3  0x09b94623 in jabber_parser_element_end_libxml ()
   from /usr/local/lib/libjabber.so.0.0
#4  0x0d42b2f8 in xmlParseEndTag2 () from /usr/local/lib/libxml2.so.9.8
#5  0x0d42f01f in xmlParseTryOrFinish () from /usr/local/lib/libxml2.so.9.8
#6  0x0d42f4f4 in xmlParseChunk () from /usr/local/lib/libxml2.so.9.8
#7  0x09b94742 in jabber_parser_process () from /usr/local/lib/libjabber.so.0.0
#8  0x09b8c945 in jabber_recv_cb_ssl () from /usr/local/lib/libjabber.so.0.0
#9  0x0ef54b3f in recv_cb () from /usr/local/lib/libpurple.so.3.2
#10 0x1c01c6f2 in finch_xfers_get_ui_ops ()
#11 0x0df8e8b3 in g_vasprintf () from /usr/local/lib/libglib-2.0.so.1600.0
#12 0x0df6126d in g_source_is_destroyed ()
   from /usr/local/lib/libglib-2.0.so.1600.0
#13 0x0df62271 in g_main_context_dispatch ()
   from /usr/local/lib/libglib-2.0.so.1600.0
#14 0x0df62596 in g_main_context_dispatch ()
   from /usr/local/lib/libglib-2.0.so.1600.0
#15 0x0df62aa2 in g_main_loop_run () from /usr/local/lib/libglib-2.0.so.1600.0
#16 0x05f33459 in gnt_main () from /usr/local/lib/libgnt.so.3.1
#17 0x1c01cc59 in main ()

$ dmesg | head
OpenBSD 4.3-current (GENERIC) #940: Thu Jun 19 07:41:29 MDT 2008
    deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel(R) Pentium(R) 4 CPU 2.80GHz ("GenuineIntel" 686-class) 2.80 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,CNXT-ID,xTPR
real mem  = 1064333312 (1015MB)
avail mem = 1020952576 (973MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 09/03/04, BIOS32 rev. 0 @ 0xfd6e0, SMBIOS rev. 2.31 @ 0xef620 (82 entries)
bios0: vendor FUJITSU SIEMENS // Phoenix Technologies Ltd. version "5.00 R2.10.1534.01" date 09/03/2004
bios0: FUJITSU SIEMENS SCENIC E
$ finch --version
Finch 2.4.2

comment:2 Changed 11 years ago by Sim-on

  • Component changed from unclassified to finch (gnt/ncurses)
  • Owner changed from lschiere to sadrul

comment:3 Changed 11 years ago by deryni

  • Component changed from finch (gnt/ncurses) to libpurple
  • Owner sadrul deleted

This looks like it is crashing in the XMPP caps code, not in finch.

bulibuta: Can you get the Debug Window output from before this crash? Run pidgin -d and redirect it to a file. Specifically whatever XMPP stanzas come in immediately before the crash, they may have to do with a file transfer or they may just be normal <presence> stanzas. I'm not sure.

comment:4 Changed 11 years ago by bulibuta

I can't reproduce this, it happened while leaving finch running over the night. Since it has been running w/o any problems for more than 1 week. So... yeah.

comment:5 Changed 11 years ago by deryni

  • Resolution set to invalid
  • Status changed from new to closed

I'm going to close this ticket then, if it happens again post back here with the debug window output I asked for.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!