Opened 11 years ago

Closed 8 years ago

#6297 closed defect (fixed)

Gadu-Gadu: Find Buddies doesn't work

Reported by: MarkS Owned by: bartosz
Milestone: 2.8.0 Component: Gadu-Gadu
Version: 2.4.3 Keywords:
Cc:

Description

Accounts ==> Gadu-Gadu==> Find buddies....

Enter seach criteria(EX) City: Atlanta Gender: Female

Window disappear and you don't get any results.

Debug attached.

Related to this AdiumX ticket: 10211 However, in Adium the result are displayed but the button within the display window either crash or don't work.

Attachments (1)

Pidgin_Find_Buddies_Issue.rtf (817.6 KB) - added by MarkS 11 years ago.
Pidgin Find Buddies Gadu Debug

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by MarkS

Pidgin Find Buddies Gadu Debug

comment:1 Changed 11 years ago by N00byStance

I can't reproduce it, it works for me, but maybe it is this kind of bug that sometimes occurs and sometimes not... I'll try later to be sure.

comment:2 Changed 11 years ago by MarkS

I was using Windows XP with Service Pack 3

N00byStance - What OS did you test this on?

comment:3 Changed 11 years ago by N00byStance

MarkS: Ubuntu 8.04. Still can't reproduce.

comment:4 Changed 11 years ago by MarkS

Thanks N00byStance. I think it might be a Windows only bug since I got a different result with Adium. I linked a Adium ticket to this ticket. If you wouldn't mind, would you be able to check to see reproduce the same issue I experienced in Adium. After doing a search and having a list of name, I clicked on continue and Adium crashed on me.

comment:5 Changed 10 years ago by bernmeister

Is this still happening on 2.5.8?

comment:6 Changed 10 years ago by darkrain42

  • Milestone set to Patches welcome

comment:7 Changed 8 years ago by matekm

This is the same problem as in #11958

comment:8 Changed 8 years ago by datallah@…

  • Milestone changed from Patches welcome to 2.8.0
  • Resolution set to fixed
  • Status changed from new to closed

(In 34621a972a410e8b184e161a071d3e957a57ba28):
Hopefully fix some long-running issues with some Gadu-Gadu functionality not working on Windows.

This fixes the struct packing to match what libgadu expects it to be. Big thanks goes to "matekm" for figuring out what the problem was and testing.

(hopefully) Fixes #11958, #6297

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!