Opened 11 years ago

Closed 11 years ago

#6314 closed defect (fixed)

Pidgin freezes when loosing internet connection

Reported by: Cube Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.4.3 Keywords:
Cc:

Description

Not really much to explain, when I unplug my internet, Pidgin freezes and I must kill the process and restart it.

This behavious has been observed on Windows Vista x64.

Change History (8)

comment:1 Changed 11 years ago by ari

I've gotten a lot of reports about this, and it seems to be related to Jabber. Steps to reproduce:

1) use SSH to create a port forward tunnel for jabber

eg: -L 5222:some.remote.host:5222 localhost

2) connect to the remote server via the tunnel (that is, set the jabber prefs to connect to localhost:5222)

3) after the connection is up, exit the SSH connection and fully terminate any forwarded ports via ctrl-c, if SSH does not exit on its own

Immediately thereafter, Pidgin will go into a 100% CPU usage loop. If one restarts the SSH link fairly quickly after, Pidgin will return to normal. However, if a long period of time transpires with no connectivity, Pidgin appears to become permanently non-responsive. A backtrace of the running process doesn't seem to show anything interesting, just the normal gtk event loop:

#0  0x00007fda90728911 in __pthread_mutex_unlock_usercnt ()
   from /lib/libpthread.so.0
#1  0x00007fda90bf295d in IA__g_main_context_prepare (context=0x1a53ae0, 
    priority=0x7fff9b6e5774) at /tmp/buildd/glib2.0-2.16.3/glib/gmain.c:2327
#2  0x00007fda90bf3028 in g_main_context_iterate (context=0x1a53ae0, block=1, 
    dispatch=1, self=<value optimized out>)
    at /tmp/buildd/glib2.0-2.16.3/glib/gmain.c:2622
#3  0x00007fda90bf3657 in IA__g_main_loop_run (loop=0x250c4a0)
    at /tmp/buildd/glib2.0-2.16.3/glib/gmain.c:2850
#4  0x00007fda92563587 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#5  0x000000000047b00b in main (argc=1, argv=0x7fff9b6e7c28)
    at ../../pidgin/gtkmain.c:890

comment:2 Changed 11 years ago by chemistrydioxide

this might be a duplicate of #5927

comment:3 Changed 11 years ago by Sim-on

  • Resolution set to duplicate
  • Status changed from new to closed

comment:4 Changed 11 years ago by ari

Why would this be a duplicate? #5927 is about a crash (possibly in OSCAR), this one is about a freeze, specifically in Jabber.

comment:5 Changed 11 years ago by Sim-on

sorry, you are right. But this could be similar ;) But nervetheless please get a debug log. Is this still an issue with 2.5.0?

comment:6 Changed 11 years ago by Sim-on

  • Component changed from unclassified to winpidgin (gtk)
  • Owner changed from lschiere to datallah
  • Resolution duplicate deleted
  • Status changed from closed to new

comment:7 Changed 11 years ago by ari

Apparently this has been fixed in 2.5.0.

comment:8 Changed 11 years ago by Sim-on

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!