Opened 11 years ago

Closed 11 years ago

#6318 closed defect (worksforme)

Pidgin doesn't launch (even after reinstallation) after combining partitions

Reported by: shleepy Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.4.3 Keywords: error 126, partition
Cc:

Description

I recently combined a couple of partitions, causing my Pidgin folder to be moved from drive E to D. Now, trying to launch Pidgin gives me the following error messages:

Unable to Locate Component - "This application has failed to start because libglib-2.0-0.dll was not found. Re-installing the application may fix this problem."

Then, after pressing OK, I get another Error - "Error loading pidgin.dll. Error: (126) The specified module could not be found. This probably means that GTK+ can't be found."

Reinstalling Pidgin does not help, and neither does copying/using the Pidgin folder from my other computer. Not sure what to try...

I am using Vista Ultimate x64. Pidgin is installed on my secondary hard-drive, not the one on which Windows is located.

Change History (7)

comment:1 Changed 11 years ago by deryni

  • pending changed from 0 to 1

When you reinstalled pidgin did you also reinstall GTK+? If you did not try doing that (possibly after uninstalling it first) and see if that helps.

comment:2 Changed 11 years ago by shleepy

  • pending changed from 1 to 0

I had the GTK checkbox checked during installation (after uninstalling). Other than that, I don't know how to independently reinstall GTK+.

comment:3 Changed 11 years ago by datallah

  • Component changed from unclassified to winpidgin (gtk)
  • Owner changed from lschiere to datallah
  • pending changed from 0 to 1

The problem is probably that the GTK+ registry keys still point to the old location.

If you look at HKEY_LOCAL_MACHINE\SOFTWARE\GTK\2.0\ in regedit, are the paths there correct?

comment:4 Changed 11 years ago by shleepy

  • pending changed from 1 to 0

I don't even have a GTK directory in the registry. I think the problem is that GTK isn't being reinstalled properly, for some reason, and the Pidgin installer doesn't properly detect it as not installed.

Note that I have since found out about Pidgin Portable, and it works fine. Hmm...

comment:5 Changed 11 years ago by datallah

  • pending changed from 0 to 1

Reinstalling GTK+ using the standalone GTK+ installer (available from the sf.net downloads section) will probably resolve the situation.

comment:6 Changed 11 years ago by shleepy

  • pending changed from 1 to 0

Roger that. Installed GTK, then installed Pidgin. Now, no problems. Thanks!

comment:7 Changed 11 years ago by datallah

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!