Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6320 closed defect (fixed)

MSN offline messages are not sent

Reported by: themadhatter Owned by: khc
Milestone: Component: MSN
Version: 2.4.3 Keywords:
Cc:

Description

When I send offline messages to my contacts, they report not to have received them. I am using the latest monotone source (and this has been reproducable for some time). Due to its development status, I did not pay it too much heed.

Now, I noticed that in the changelog, MSNP15 is said to have been enabled, and so I thought I ought to mention this.

Kind Regards, Matthew

Change History (14)

comment:1 Changed 11 years ago by khc

how latest is latest?

comment:2 Changed 11 years ago by themadhatter

I update to head every day, sometimes more than that.

I navigated back here to say that some people receive them, and some people don't, and it seems a little inconsistent. For instance, my friend, with MSN Messenger 8.1 reports not to have received them, whereas another friend says they have received them.

It is certainly MUCH better than it was. I will be testing it by sending random messages to my friends in the next few days.

I have again just updated to head, and recompiled... so we will see how it goes.

Thanks for your prompt reply!

comment:3 follow-up: Changed 11 years ago by themadhatter

Hmmm... I receive an interesting error, which may be useful. The people who do not receive my offline messages (on the latest head), now generate the following error, when they are offline:

" (13:01:27) Message was not sent because an unknown encoding error occured. "

(Note the spelling mistake of "occured" too :P)

Hope this helps, Matthew

comment:4 Changed 11 years ago by themadhatter

Another interesting quirk:

Apparently my friend received this message: 15/07/2008 1:00 PM:

eIf you receive this, can you please tell me?

Rather than the actual message I sent, which did not have the 'e' in front of it. :S

comment:5 Changed 11 years ago by khc

how long are the messages usually are?

comment:6 Changed 11 years ago by themadhatter

The messages are typically very short. Usually about as long as... the first sentence in this post. Certainly not more than the entirety of this post.

comment:7 Changed 11 years ago by themadhatter

The latest head (as of now) does not generate the " (13:01:27) Message was not sent because an unknown encoding error occured. " Error.

I think it may now be working, but I will not know until my friend (who is offline), notifies me as such.

Kind Regards, Matthew

comment:8 in reply to: ↑ 3 Changed 11 years ago by QuLogic

Replying to themadhatter:

" (13:01:27) Message was not sent because an unknown encoding error occured. "

This error should have been fixed in aa1091727852b14118b50e7b20134127c4bf09d3. (Though there bugs there, so c7cd6a4c341ff512ad7adad3fe410b621991aed9 is better.)

comment:9 Changed 11 years ago by themadhatter

I cannot reproduce the errors I was having before, and it appears that it is all working. I shall add a new bug report if I find anything more.

Thanks for the prompt response! Matthew

comment:10 Changed 11 years ago by QuLogic

  • Resolution set to fixed
  • Status changed from new to closed

comment:11 Changed 11 years ago by qulogic@…

(In 5d46ff2bb6f7d636573cccf1bc6864ae33ad9225):
Fix up some spelling mistakes in MSN oim.c.

References #6320.

comment:12 follow-up: Changed 11 years ago by Hannes Rannes

Does still not work here with Pidgin 2.5.0.

comment:13 in reply to: ↑ 12 ; follow-up: Changed 11 years ago by QuLogic

Replying to Hannes Rannes:

Does still not work here with Pidgin 2.5.0.

Please open a new ticket instead of commenting on some random other one.

That said, when did you download Pidgin? The initial Windows release did not have MSNP15 enabled.

comment:14 in reply to: ↑ 13 Changed 11 years ago by Hannes Rannes

Replying to QuLogic:

Replying to Hannes Rannes:

Does still not work here with Pidgin 2.5.0.

Please open a new ticket instead of commenting on some random other one.

That said, when did you download Pidgin? The initial Windows release did not have MSNP15 enabled.

It is THE one ticket, which exactly deals the problem. But thanks for your answer, that solved the problem. I redownloaded the installation files and now it works! :)

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!