Opened 11 years ago

Closed 11 years ago

#6362 closed defect

no error message if XMPP file transfer proxy is not available

Reported by: hede Owned by: datallah
Milestone: Component: XMPP
Version: 2.4.1 Keywords: jabber xmpp file transfer proxy
Cc:

Description

I tried to start a file transfer via XMPP. First it seems to work, Pidgins transfer window opens and the status is "waiting for transfer to start" and remains as that (I'm using the german translation, maybe the original english text is different...) The file transfer does not start, nor is there any error message/window.

Because I'm behind a NAT-router I use proxy.jabber.org:7777 as a proxy for file transfers.

This proxy Server seems to be down for now:

~$ telnet proxy.jabber.org 7777 Trying 208.68.163.220... telnet: Unable to connect to remote host: Connection refused

But Pidgin doesnt tell me, the transfer window is still open and nothing happened so far. The receiver gets no message as well. I opened the debug window, it seems pidgin detects that there is some problem. but why does that get ignored?

(19:53:04) jabber: Sending (ssl): <iq type='set' id='purpleXXXX' to='BBBB@…/Home'><si xmlns='http://jabber.org/protocol/si' id='purpleXXXX' profile='http://jabber.org/protocol/si/profile/file-transfer'><file xmlns='http://jabber.org/protocol/si/profile/file-transfer' name='NNNN.jpg' size='40704'/><feature xmlns='http://jabber.org/protocol/feature-neg'><x xmlns='jabber:x:data' type='form'><field var='stream-method' type='list-single'><option><value>http://jabber.org/protocol/bytestreams</value></option></field></x></feature></si></iq> (19:53:14) jabber: Sending (ssl): <iq type='get' id='purpleXXXX'><ping xmlns='urn:xmpp:ping'/></iq> (19:53:14) jabber: Recv (ssl)(226): <iq from='AAAA@…' to='AAAA@…/Home' type='error' id='purpleXXXX'><ping xmlns='urn:xmpp:ping'/><error code='503' type='cancel'><service-unavailable xmlns='urn:ietf:params:xml:ns:xmpp-stanzas'/></error></iq>

Change History (5)

comment:1 Changed 11 years ago by datallah

  • Owner changed from nwalp to datallah
  • Status changed from new to assigned

comment:2 Changed 11 years ago by deryni

  • pending changed from 0 to 1

The error you are seeing in that debug output is related to the xmpp ping pidgin sends and not to the file transfer you tried to start. Unless there is some error message that comes in later related to the file transfer stanza I'm not sure there is anything pidgin could be responding to.

comment:3 Changed 11 years ago by hede

  • pending changed from 1 to 0

OK, maybe I have no debugging/logging output of this error. But nevertheless the fact is: I start a file transfer and nothing happens. No crash, not even some error message. It simply waits while saying "waiting for transfer to start". I do not know for shure what the receiver gets, "he" (the other XMPP user) said its nothing ... maybe he plays tricks on me ;-)

I cannot investigate further into it now, because the other XMPP-user I know to test this over the internet is offline right now. But I will do that this evening... tomorrow... maybe later :-) For now I do not understand how XMPP works, but I'll try to the next days, look into the source, try to use other proxys (is a proxy needed at all?) ...

comment:4 Changed 11 years ago by deryni

  • pending changed from 0 to 1

If you can get the xml sent and received by both sides during the file transfer attempt we can begin to figure out if your friend is getting anything at all and if there is anything you are getting back that we can use as a status/error indicator. As to whether you need a proxy, I believe you will need a proxy whenever the sender of the file does not have a publicly reachable IP address (but my knowledge of the XMPP file transfer mechanism has always been spotty).

comment:5 Changed 11 years ago by trac-robot

  • pending changed from 1 to 0
  • Status changed from assigned to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!