Opened 11 years ago

Closed 11 years ago

#6386 closed defect (invalid)

Segmentation fault on Yoper Linux

Reported by: Pikidalto Owned by: lschiere
Milestone: Component: unclassified
Version: 2.4.3 Keywords:
Cc:

Description

I compiled Pidgin 2.4.3 on Yoper Linux. When I first tried to run it, it did not seem to load, so I tried to load it from a terminal and noticed it crashing with a Segmentation Fault. Attatched is the output of a 'pidgin -d' and a 'gdb pidgin'.

Attachments (1)

pidgin_seg_fault (14.2 KB) - added by Pikidalto 11 years ago.
'pidgin -d' and 'gdb pidgin' output (now includes 'uname -a' and 'uname -r'

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by Pikidalto

'pidgin -d' and 'gdb pidgin' output (now includes 'uname -a' and 'uname -r'

comment:1 Changed 11 years ago by datallah

  • pending changed from 0 to 1

It looks like it is crashing when initializing the sound stuff.

There are no debug symbols in your backtrace, which renders it mostly useless - the only useful thing to note is that it is crashing in liboil. Did you compile that too?

Did you use custom CFLAGS or something to build pidgin? Are you using a patched version?

comment:2 Changed 11 years ago by Pikidalto

  • pending changed from 1 to 0

I did not compile liboil or use a custom CFLAGS to compile. I can note, however, that an updated liboil (added either on the 21st or 22nd of July, 2008 to the Yoper repositories) seems to have fixed the problem, which leads me to think that it was a corrupt liboil build in the Yoper repositories than an actual problem with Pidgin itself.

comment:3 Changed 11 years ago by datallah

  • Resolution set to invalid
  • Status changed from new to closed

Aha, that explains it.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!