Opened 11 years ago

Closed 10 years ago

Last modified 9 years ago

#6410 closed enhancement (wontfix)

Display remote protocol icon for Jabber->Transport contacts

Reported by: ilgaspa Owned by: nwalp
Milestone: Component: XMPP
Version: 2.4.3 Keywords: jabber transport protocol icon XMPP
Cc: ilgaspa@…

Description

Right now it's easy to "detect" wich protocol a buddy belongs to, by hovering the contact and looking at the protocol icon in the tooltip.. however, let's suppose that we have an MSN contact belonging to our JABBER/XMPP account, through an MSN transport. Hovering this contact displays the JABBER/XMPP protocol icon, wich is right and wrong: right because it's indeed a JABBER/XMPP contact, but wrong because we're chatting with an MSN user...

Would be possible differentiating the JABBER/XMPP protocol icon to allow to recognize if a buddy is a "pure" JABBER/XMPP contact or an MSN (ICQ, YAHOO, WATHEVER) contact linked through a transport? The best way would be the JABBER/XMPP protocol icon hovered with the icon of the "true" contact protocol (a la Kopete).

Don't know if I should file this under bugs or enhanchements: after all as I said before the current implementation is right and wrong at the same time O_o I'll file it as a bug just to be sure..

Change History (5)

comment:1 Changed 11 years ago by datallah

  • Summary changed from Wrong protocol icon displayed for Jabber->Transport contacts to Display remote protocol icon for Jabber->Transport contacts
  • Type changed from defect to enhancement

I suspect that this is not something we'll want to tackle because (as you noted) arguably the behavior is correct and would be complicated to change.

comment:2 Changed 11 years ago by deryni

In some discussion on this in the devel chat room I commented that I'm uncertain how kopete can tell what protocol the buddies come from and that if the only way to tell is to disco the gateway and then match that domain against the buddies domains I don't want to mess with it. If, however, the buddies themselves are marked with the protocol they come from then I see no reason why we shouldn't include that as a line-item in the tooltip, but I don't think we would want to change or emblemize the xmpp icon.

comment:3 Changed 10 years ago by mgleich

If the automatically detection of the protocol icon to the protocol where the come from is not a way for you. What do you think over a manual setting. I have 4 accounts with XMPP (2 jabber accounts, meebo and hab.la). And for these it would be nice, when I could be set different icons. A simple solution (I hope) would be pidgin searching in the directories under /pixmaps/protocols to find PROTOCOL.HOST.png images to get the right icon. For instance jabber.meebo.org.png or jabber.hab.la.png.

comment:4 Changed 10 years ago by rekkanoryo

  • Resolution set to wontfix
  • Status changed from new to closed

The buddies on the roster are XMPP buddies, regardless of the fact that they are accessed via a transport. This is a LOT more work than it could ever possibly be worth and appears not to be cleanly possible.

comment:5 Changed 9 years ago by darkrain42

Ticket #11302 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!