Opened 11 years ago

Closed 11 years ago

#6412 closed defect (invalid)

Ubuntu 8.04: Pidgin 2.4.3 has segfaulted and attempted to dump a core file

Reported by: Oleg Owned by: lschiere
Milestone: Component: unclassified
Version: 2.4.3 Keywords:
Cc:

Description

My configuration:

  • pidgin 2.4.3 built from sources
  • Ubuntu desktop 8.04, russian localization
  • ICQ and MSN protocols are active

Here is the console output:

oleg@krim:~$ pidgin
Pidgin 2.4.3 has segfaulted and attempted to dump a core file.
This is a bug in the software and has happened through
no fault of your own.

If you can reproduce the crash, please notify the developers
by reporting a bug at:
http://developer.pidgin.im/simpleticket/

Please make sure to specify what you were doing at the time
and post the backtrace from the core file.  If you do not know
how to get the backtrace, please read the instructions at
http://developer.pidgin.im/wiki/GetABacktrace

If you need further assistance, please IM either SeanEgn or 
LSchiere (via AIM).  Contact information for Sean and Luke 
on other protocols is at
http://developer.pidgin.im/wiki/DeveloperPages
Aborted

Please contact me if you need more details.

Best regards, Oleg Yaroshevych.

Change History (9)

comment:1 Changed 11 years ago by deryni

  • pending changed from 0 to 1

Read that message please, and follow the directions there. Specifically the "make sure to specify what you were doing at the time and post the backtrace from the core file" parts.

comment:2 Changed 11 years ago by Oleg

  • pending changed from 1 to 0

I used MSN protocol: sending/receiving messages.

comment:3 Changed 11 years ago by deryni

  • pending changed from 0 to 1

That's a start, now how about the backtrace/core file part.

comment:4 Changed 11 years ago by Oleg

  • pending changed from 1 to 0

Ok. I will try to download IDE with debugger and provide stack trace, loaded modules, etc.

comment:5 Changed 11 years ago by deryni

  • pending changed from 0 to 1

You don't need to download an IDE you need to read the GetABacktrace link from the message you pasted here.

comment:6 Changed 11 years ago by Oleg

  • pending changed from 1 to 0

Okay, here is gdb log.

Looks like problem occurs when any ICQ contact in my contact list goes offline.

oleg@krim:~$ gdb pidgin
GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...
(gdb) handle SIGSEGV nostop
Signal        Stop	Print	Pass to program	Description
SIGSEGV       No	Yes	Yes		Segmentation fault
(gdb) run
Starting program: /usr/local/bin/pidgin 
[Thread debugging using libthread_db enabled]
[New Thread 0xb7082720 (LWP 16032)]
[New Thread 0xb69e4b90 (LWP 16035)]
[New Thread 0xb54cfb90 (LWP 16443)]

Program received signal SIGSEGV, Segmentation fault.

Program received signal SIGSEGV, Segmentation fault.
Pidgin 2.4.3 has segfaulted and attempted to dump a core file.
This is a bug in the software and has happened through
no fault of your own.

If you can reproduce the crash, please notify the developers
by reporting a bug at:
http://developer.pidgin.im/simpleticket/

Please make sure to specify what you were doing at the time
and post the backtrace from the core file.  If you do not know
how to get the backtrace, please read the instructions at
http://developer.pidgin.im/wiki/GetABacktrace

If you need further assistance, please IM either SeanEgn or 
LSchiere (via AIM).  Contact information for Sean and Luke 
on other protocols is at
http://developer.pidgin.im/wiki/DeveloperPages
Pidgin 2.4.3 has segfaulted and attempted to dump a core file.
This is a bug in the software and has happened through
no fault of your own.

If you can reproduce the crash, please notify the developers
by reporting a bug at:
http://developer.pidgin.im/simpleticket/

Please make sure to specify what you were doing at the time
and post the backtrace from the core file.  If you do not know
how to get the backtrace, please read the instructions at
http://developer.pidgin.im/wiki/GetABacktrace

If you need further assistance, please IM either SeanEgn or 
LSchiere (via AIM).  Contact information for Sean and Luke 
on other protocols is at
http://developer.pidgin.im/wiki/DeveloperPages

Program received signal SIGABRT, Aborted.
[Switching to Thread 0xb54cfb90 (LWP 16443)]
0xb7fbb410 in __kernel_vsyscall ()
(gdb) bt full
#0  0xb7fbb410 in __kernel_vsyscall ()
No symbol table info available.
#1  0xb7333085 in raise () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#2  0xb7334a01 in abort () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#3  0x080bf570 in sighandler (sig=11) at gtkmain.c:193
No locals.
#4  <signal handler called>
No symbol table info available.
#5  0xb7709398 in ?? () from /usr/lib/libdbus-1.so.3
No symbol table info available.
#6  0xb7709449 in ?? () from /usr/lib/libdbus-1.so.3
No symbol table info available.
#7  0xb7703e0c in ?? () from /usr/lib/libdbus-1.so.3
No symbol table info available.
#8  0xb76efaa5 in ?? () from /usr/lib/libdbus-1.so.3
No symbol table info available.
#9  0xb76efbba in ?? () from /usr/lib/libdbus-1.so.3
No symbol table info available.
#10 0xb76f146b in dbus_connection_send_with_reply ()
   from /usr/lib/libdbus-1.so.3
No symbol table info available.
---Type <return> to continue, or q <return> to quit---
#11 0xb76f166a in dbus_connection_send_with_reply_and_block ()
   from /usr/lib/libdbus-1.so.3
No symbol table info available.
#12 0xb76eb26a in ?? () from /usr/lib/libdbus-1.so.3
No symbol table info available.
#13 0xb76eb44d in dbus_bus_add_match () from /usr/lib/libdbus-1.so.3
No symbol table info available.
#14 0xb4ccb5d0 in libhal_ctx_init () from /usr/lib/libhal.so.1
No symbol table info available.
#15 0xb5e2221e in ?? () from /usr/lib/gstreamer-0.10/libgsthalelements.so
No symbol table info available.
#16 0xb5e226e1 in ?? () from /usr/lib/gstreamer-0.10/libgsthalelements.so
No symbol table info available.
#17 0xb5e20717 in ?? () from /usr/lib/gstreamer-0.10/libgsthalelements.so
No symbol table info available.
#18 0xb7f39117 in gst_element_change_state ()
   from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#19 0xb7f39663 in ?? () from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#20 0xb7f381c3 in gst_element_set_state () from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#21 0xb7f2a1fc in ?? () from /usr/lib/libgstreamer-0.10.so.0
---Type <return> to continue, or q <return> to quit---
No symbol table info available.
#22 0xb7f39117 in gst_element_change_state ()
   from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#23 0xb7f39663 in ?? () from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#24 0xb7f381c3 in gst_element_set_state () from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#25 0xb5faf5ef in ?? () from /usr/lib/gstreamer-0.10/libgstgconfelements.so
No symbol table info available.
#26 0xb5fac94b in ?? () from /usr/lib/gstreamer-0.10/libgstgconfelements.so
No symbol table info available.
#27 0xb5face69 in ?? () from /usr/lib/gstreamer-0.10/libgstgconfelements.so
No symbol table info available.
#28 0xb7f39117 in gst_element_change_state ()
   from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#29 0xb7f39663 in ?? () from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#30 0xb7f381c3 in gst_element_set_state () from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#31 0xb7f2a1fc in ?? () from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
---Type <return> to continue, or q <return> to quit---
#32 0xb7f39117 in gst_element_change_state ()
   from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#33 0xb7f39663 in ?? () from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#34 0xb7f381c3 in gst_element_set_state () from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#35 0xb5eaac27 in ?? () from /usr/lib/gstreamer-0.10/libgstplaybin.so
No symbol table info available.
#36 0xb5eac73c in ?? () from /usr/lib/gstreamer-0.10/libgstplaybin.so
No symbol table info available.
#37 0xb5eb9494 in ?? () from /usr/lib/gstreamer-0.10/libgstplaybin.so
No symbol table info available.
#38 0xb76bea4f in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#39 0xb76b1759 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#40 0xb76c5d1d in ?? () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#41 0xb76c7916 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#42 0xb76c7c59 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
No symbol table info available.
#43 0xb7f3aa1a in gst_element_no_more_pads ()
   from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#44 0xb5fa719e in ?? () from /usr/lib/gstreamer-0.10/libgstdecodebin.so
No symbol table info available.
#45 0xb76bea4f in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#46 0xb76b1759 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#47 0xb76c5d1d in ?? () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#48 0xb76c7916 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#49 0xb76c7c59 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#50 0xb7f3aa1a in gst_element_no_more_pads ()
   from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#51 0xb5e878e8 in ?? () from /usr/lib/gstreamer-0.10/libgstwavparse.so
No symbol table info available.
#52 0xb5e884cd in ?? () from /usr/lib/gstreamer-0.10/libgstwavparse.so
---Type <return> to continue, or q <return> to quit---
No symbol table info available.
#53 0xb5e88b1f in ?? () from /usr/lib/gstreamer-0.10/libgstwavparse.so
No symbol table info available.
#54 0xb7f6d340 in ?? () from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#55 0xb764069b in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#56 0xb763ea6f in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#57 0xb745c4fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#58 0xb73dee5e in clone () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
(gdb) 

comment:7 Changed 11 years ago by deryni

  • pending changed from 0 to 1

That appears to be crashing in either dbus or gstreamer. If you turn sound events off does it stop crashing?

comment:8 Changed 11 years ago by Oleg

  • pending changed from 1 to 0

Looks like it works after I turned off sounds. Thanks.

comment:9 Changed 11 years ago by deryni

  • pending changed from 0 to 1
  • Resolution set to invalid
  • Status changed from new to closed

I believe someone mentioned that there was a recent dbus/gstreamer/pulseaudio update that fixed a similar issue for them, so you might want to check to make sure your system is up to date. Also, checking for existing ubuntu bugs of this sort might be useful.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!