Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#6425 closed enhancement (duplicate)

Pidgin shows top of current chat session after reopen chat window

Reported by: Menedas Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.5.1 Keywords: top chat history persistent conversation
Cc:

Description (last modified by Menedas)

I'm using the history plugin and persistent conversation. Problem is now, when I close the chat window and open it again, it doesn't shows me the bottom of the current chat. So I have to scroll manually back to the last line of the chat. Would like that pidgin scrolls automaticly to the bottom.

Change History (11)

comment:1 Changed 11 years ago by datallah

  • Status changed from new to pending

I can't recreate this with the latest code.

comment:2 Changed 11 years ago by Menedas

  • Description modified (diff)
  • Status changed from pending to new

I've tested it now with 2.5.2dev Version where the problem still exists. When the chat window is opened again then it doesn't show me the last line of the chat. The window just shows the mid of the chat, lots of lines above the last line.

comment:3 Changed 11 years ago by Menedas

  • Description modified (diff)

comment:4 Changed 11 years ago by datallah

  • Status changed from new to pending

Please outline some specific steps that can be used to recreate this.

comment:5 Changed 11 years ago by Menedas

  • Status changed from pending to new
  • Version changed from 2.4.3 to 2.5.1
  • activate persistent chat
  • activate history.dll plugin
  • make a longer chat (till it needs to scroll)
  • close chat window (chat session shouldn't been closed)
  • reopen chat window of that chat again

-> chat window does not show the last line of the chat

comment:6 follow-up: Changed 11 years ago by XBit

I have the same issue with the reopened conversations. It is quite annoying to have to scroll down when a conversation reapers. If I can help in any way to debug this, please let me know.

comment:7 in reply to: ↑ 6 Changed 10 years ago by Coeluh

Replying to XBit:

I have the same issue with the reopened conversations. It is quite annoying to have to scroll down when a conversation reapers. If I can help in any way to debug this, please let me know.

Exactly what I got! Quite annoying!

comment:8 Changed 10 years ago by darkrain42

Does the history plugin need to be enabled for this to occur? Please try disabling it and restarting pidgin and testing.

Update: If so, this and #7485 are probably the same issue.

comment:9 Changed 10 years ago by Coeluh

I am not running the history plugin, so this happens without the plugin.

comment:10 Changed 10 years ago by darkrain42

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #7485.
Per Coeluh's comment, I'm consolidating these two tickets.

comment:11 Changed 10 years ago by Menedas

Strange, to close the older ticket and not the newer one.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!