Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6452 closed defect (duplicate)

memory usage bulks with time

Reported by: Kenny_Duehit Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.4.3 Keywords: memory
Cc:

Description

on startup pidgin absorbs 11mb of memory, this is perfect. I'd be happy if it took 30mb. I went to bed and when I awoke, it had absorbed 1.4Gig of memory. 1.4 GIG! LOL

pidgin 2.4.3 --- main chat protocol is MSN --- pidgin-facebookchat-1.23 plugin is installed...but my facebook chat account was disabled and not logged in at the time. --- no other pugins active...not even smilies ;)

my specs: vista ultimate x64, Athlon 2.4GHz, Radeon X800XL, 2Gb ram

need anymore info about the problem, please ask.

Attachments (2)

Reading 1.jpg (261.5 KB) - added by Kenny_Duehit 11 years ago.
This is the first reading
Reading 2.jpg (241.2 KB) - added by Kenny_Duehit 11 years ago.
Reading 2

Download all attachments as: .zip

Change History (9)

comment:1 Changed 11 years ago by datallah

  • Component changed from unclassified to winpidgin (gtk)
  • Owner changed from lschiere to datallah

Please take a look at the process information in the task manager: CPU usage, memory usage, # Threads, Handles, User, GDI Objects

You will need to add extra columns to get that information as some of them are not displayed by default.

Are you using ZoneAlarm??

comment:2 Changed 11 years ago by Kenny_Duehit

I'll leave it running overnight again for the problem to build up and give you info tomorrow morning.

no I do not run ZoneAlarm?

comment:3 Changed 11 years ago by Kenny_Duehit

well when i woke up this morning pidgin had crashed. But I took two readings during the night when it had consumed about 600mb and 780mb.

I *think* the issue might have something to do with my wallpaper changer...I closed it for an hour or 2 after pidgin had reached 650mb, and in about 2 hours pidgins memory usage had dropped to 215mb. I reopened my wallpaper changer and on the first change of wallpaper it jumped up to 700mb. Very weird.

Wallpaper Changer v1.90 http://www.wallpaperchanger.de/

READING 1 (after about 11 hours) name: pidgin.exe *32 CPU: 00 Memory (private working set): 609,524 K Handles: 236 Threads: 9 USER Objects: 145 GDI Objects: 1684

READING 2 (after about 13 hours and the restarting of my wallpaper changer) name: pidgin.exe *32 CPU: 98 Memory (private working set): 794,732 K Handles: 234 Threads: 8 USER Objects: 147 GDI Objects: 1829

note that Reading 2 was taken about 15 seconds after my wallpaper had changed. I started forcing the wallpaper changes and observing the memory of pidgin....with every change pidgin consumed more memory.

if you would like me to run any more tests or need more info please ask. more then glad to help.

Changed 11 years ago by Kenny_Duehit

This is the first reading

Changed 11 years ago by Kenny_Duehit

Reading 2

comment:4 Changed 11 years ago by datallah

  • Resolution set to duplicate
  • Status changed from new to closed

The leakage when changing wallpaper is a long running issue. I'm pretty sure there has been an upstream bug for it for a long time (I can't find it right now). I tried to track it down at one point, but wasn't able to recreate it. For the foreseeable future, this is going to be in the category of "don't do it."

Duplicate of #4722

comment:5 Changed 11 years ago by deryni

Do we think this might actually be an issue with http://www.wallpaperchanger.de/ ? #5620 is also a duplicate of #4722 and uses it.

Kenny_Duehit: Can you try some other wallpaper switching application and see if you can repeat the results?

comment:6 Changed 11 years ago by Kenny_Duehit

i have things to go do but i will when i return in +8 hours

comment:7 Changed 11 years ago by Kenny_Duehit

Could not recreate the problem...but also could not find a wallpaper changing program that functions the same way that WallpaperChanger? functions. They have a "monitor folder" option. You can dump photos into the folder and not have to worry about adding them to the program.

I'm sorry to say that Pidgin got the boot. I will come back once this is all resolved...but until then it is easier to find another IM manager then it is a convenient wallpaper changer.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!