Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#6454 closed defect (fixed)

Windows silent install broken by GTK+ upgrade dialog

Reported by: PeteBoyd Owned by: datallah
Milestone: 2.5.0 Component: winpidgin (gtk)
Version: 2.4.3 Keywords:
Cc:

Description

When installing Pidgin silently using the /S switch, the installer presents a dialog asking "GTK+ 2.12.8 Rev a setup - GTK+ 2.12.1 rev b is already installed. Do you wish to re-install with 2.12.8 rev a?". I'm not sure where this system-wide GTK+ came from on my system, certainly not the last version of Pidgin I have deployed. From what i can see Pidgin never included this particular version. That doesn't matter, because the Pidgin installer complains even when reinstalling the same version as is already installed.

Change History (6)

comment:1 Changed 11 years ago by datallah

  • pending changed from 0 to 1

I think this is actually working as intended (as documented in the wiki).

The GTK+ installer has two silent states. One with message boxes: /S, and one without: /S /NOUI. This is because the installer was made to run from within the Pidgin installer (when the pidgin installer is in non-silent mode), where you would expect to see message boxes for errors.

Are you seeing the message box when running the pidgin installer with GTK+ embedded, or when running the standalone gtk+ installer?

If it is embedded in the pidgin installer and you're running something like pidgin-x.y.z.exe /DS=1 /SMS=0 /L=1033 /S /D=C:\Pidgin, then it probably is actually a bug (the pidgin installer should be passing the /NOUI flag to the gtk+ installer when running in silent mode).

2.12.1 rev. b. was also distributed by us.

comment:2 Changed 11 years ago by PeteBoyd

  • pending changed from 1 to 0

I'm seeing this when installing Pidgin 2.4.3 with its embedded GTK+, using only the '/S' switch. I believe this was fine with Pidgin 2.4.1. Before that I installed Pidgin with GTK+, using a single system-wide GTK+ for all apps.

I took my info on which versions of GTK+ Pidgin has included from its changelog, but looking again now at http://pidgin.im/ChangeLog just to check I can't find any mention of GTK+ versions.

comment:3 Changed 11 years ago by PeteBoyd

I meant to say, if you want me to try that full suite of installer switches in your example then let me know.

comment:4 Changed 11 years ago by datallah

It sounds like this isn't working quite as intended, I'll fix it :)

comment:5 Changed 11 years ago by datallah@…

  • Milestone set to 2.5.0
  • Resolution set to fixed
  • Status changed from new to closed

(In 9e3f088fc7df07bdb891f336b152797fd4f1ff07):
Fix the win32 installer not to cause messageboxes in the gtk installer when running in silent mode. Fixes #6454

comment:6 Changed 11 years ago by PeteBoyd

Thankyou

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!