Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6627 closed defect (fixed)

Pidgin 2.5 Crash On Mouseover

Reported by: smarthero Owned by: MarkDoliner
Milestone: 2.5.1 Component: AIM
Version: 2.5.0 Keywords:
Cc: dodgy, edemaine, djkerber, Root

Description

Recently upgraded to 2.5, install went fine. However, when I attempt to mouse over or click a specific name on my buddy list, Pidgin immediately crashes. I've included the RPT file.

Attachments (7)

pidgin.RPT (3.2 KB) - added by smarthero 9 years ago.
Pidgin Crash Report File
pidgin.2.RPT (3.2 KB) - added by Broodhill 9 years ago.
pidging crash report file
pidgin.3.RPT (6.4 KB) - added by pidginuser408 9 years ago.
pidgin.4.RPT (2.9 KB) - added by dodgy 9 years ago.
pidgin.5.RPT (3.4 KB) - added by edemaine 9 years ago.
liboscar.dll (1.6 MB) - added by datallah 9 years ago.
Test fix for liboscar.dll
pidgin.6.RPT (6.2 KB) - added by Mother Fo 9 years ago.
Mother Fo's RPT File

Download all attachments as: .zip

Change History (63)

Changed 9 years ago by smarthero

Pidgin Crash Report File

comment:1 follow-up: Changed 9 years ago by datallah

  • Status changed from new to pending

Are you running Pidgin in a language other than en_US?

comment:2 Changed 9 years ago by 2phr

Also getting this problem..

Only happens when mouse over AIM contacts in list (at least, not MSN, ICQ, IRC, XMPP). ANd only happens when tooltip attempts to appear.

comment:3 in reply to: ↑ 1 Changed 9 years ago by smarthero

  • Status changed from pending to new

Replying to datallah:

Are you running Pidgin in a language other than en_US?

No, it's English.

comment:4 Changed 9 years ago by 2phr

Only US english here, no translations installed. It's possible to successfully open the chat window if you can double click the contact in the list before the tooltip appears.

Changed 9 years ago by Broodhill

pidging crash report file

comment:5 follow-up: Changed 9 years ago by Broodhill

I have the same problem, but it aint happening on all contacts, only those whose nickname begins with an "A" I think

comment:6 in reply to: ↑ 5 ; follow-up: Changed 9 years ago by smarthero

Replying to Broodhill:

I have the same problem, but it aint happening on all contacts, only those whose nickname begins with an "A" I think

Haven't encountered that, the nick began with an 's' A number of other AIM contacts are fine to mouse over, but when the tooltip tries to load it goes kaput.

comment:7 in reply to: ↑ 6 Changed 9 years ago by Broodhill

Replying to smarthero:

Replying to Broodhill:

I have the same problem, but it aint happening on all contacts, only those whose nickname begins with an "A" I think

Haven't encountered that, the nick began with an 's' A number of other AIM contacts are fine to mouse over, but when the tooltip tries to load it goes kaput.

I only noticed it happens on my contacts that begin with an 'A' not on any others.. And I have no plugins enabled

Changed 9 years ago by pidginuser408

Changed 9 years ago by dodgy

comment:8 Changed 9 years ago by dodgy

I've found it happens when you mouseover an AIM contact who is away, not sure if it happens for someone who is active.

Changed 9 years ago by edemaine

comment:9 Changed 9 years ago by edemaine

I confirm the problem with certain AIM contacts (no MSN, XMPP, MSN contacts cause the problem for me) on Windows Vista. The crash happens when hovering over an AIM contact starting with the 's', but not one starting with the letter 'K'. Both have buddy icons, and both are away. pidgin.5.RPT attached.

comment:10 Changed 9 years ago by 2phr

I added myself (AIM) to the contact list to test this further, and mouseover on myself in the list only crashes when the status is set to Away with the away icon. It doesnt even crash if set Away but with a custom text. Also, setting the icon on or off doesn't make any difference, or changing the alias name. It's totally down to the AIM contact being in the standard Away state.

comment:11 Changed 9 years ago by ulibass

maybe i have the same problem, but... pidgin crashes in various ways and in various situations

many times it has crashed when

  • mouseover on icq-contacts (i could reproduce it with one account with away-status)
  • trying to open a chat window (same icq-contact)

my pidgin runs on vista home, german version

at the moment only my msn, yahoo and icq-accounts are active with myspace and/or aim account active it crashes more often (even with no further action except connect)

additional info (i know, this is subject in some other tickets) with gadu gadu account active it crashes on every connect (2.4.3 did it too; 2.4.1 crashed most times, somtimes not; with earlier versions i had no problem with gadu gadu)

Changed 9 years ago by datallah

Test fix for liboscar.dll

comment:12 follow-up: Changed 9 years ago by datallah

I've attached a test liboscar.dll that you can overwrite C:\Program Files\Pidgin\liboscar.dll with to see if it resolves this issue.

comment:13 in reply to: ↑ 12 Changed 9 years ago by smarthero

Replying to datallah:

I've attached a test liboscar.dll that you can overwrite C:\Program Files\Pidgin\liboscar.dll with to see if it resolves this issue.

This seems to be a solid fix, haven't had a crash yet, properly displays the 'Away' tooltip.

comment:14 Changed 9 years ago by Broodhill

It works for me too with that .dll file

comment:15 Changed 9 years ago by datallah@…

  • Milestone set to 2.5.1
  • Resolution set to fixed
  • Status changed from new to closed

(In 975aa92fa23adeff2b6212736536261186f70528):
Fix printf of a NULL string and also an invalid free. Fixes #6627

comment:16 Changed 9 years ago by 2phr

Patch worked ok here. No longer crashing on away AIM contact. Thanks.

Changed 9 years ago by Mother Fo

Mother Fo's RPT File

comment:17 follow-up: Changed 9 years ago by Mother Fo

I uploaded my rpt file. I was having the same issue and I've even loaded the new file, but it's still crashing for me.

Hope that helps :)

comment:18 Changed 9 years ago by nobuyuki

Thanks, the replacement dll fixed my tooltip problem as well.

comment:19 in reply to: ↑ 17 Changed 9 years ago by datallah

Replying to Mother Fo:

I uploaded my rpt file. I was having the same issue and I've even loaded the new file, but it's still crashing for me.

Hope that helps :)

Yours is a different issue, please file it as a separate bug, so that we can keep track.

comment:20 Changed 9 years ago by kahlil88

Why is the new DLL 1.6 MB? The one in C:\Program Files\Pidgin is only 237 KB. I have dialup...

comment:21 Changed 9 years ago by bernmeister

The new liboscar.dll is a debug build, so it's going to be a lot bigger than the release version.

comment:22 follow-up: Changed 9 years ago by kahlil88

Does this effect non-Windows systems? I primarily use Ubuntu GNU/Linux (then again, I get my Pidgin packages from GetDeb?).

comment:23 follow-up: Changed 9 years ago by jodfoster

I lost the ability to have an AIM account by copying over the liboscar.dll file.

comment:24 in reply to: ↑ 23 ; follow-up: Changed 9 years ago by datallah

Replying to jodfoster:

I lost the ability to have an AIM account by copying over the liboscar.dll file.

You probably didn't download the file successfully, try again.

comment:25 in reply to: ↑ 22 Changed 9 years ago by datallah

Replying to kahlil88:

Does this effect non-Windows systems? I primarily use Ubuntu GNU/Linux (then again, I get my Pidgin packages from GetDeb?).

This will not affect Linux, only systems that use Glib's internal vsnprintf() implementation (Windows, BSDs).

comment:26 in reply to: ↑ 24 Changed 9 years ago by jodfoster

Replying to datallah:

Replying to jodfoster:

I lost the ability to have an AIM account by copying over the liboscar.dll file.

You probably didn't download the file successfully, try again.

Thanks, that worked!

comment:27 Changed 9 years ago by kpow

I tried the fix above, and it seems to work

comment:28 Changed 9 years ago by Seanathan

The above replacement for liboscar.dll fixes the mouseover issue for me as well.

=)

comment:29 Changed 9 years ago by mystycs

How do i know its safe to download this .dll?

comment:30 Changed 9 years ago by deryni

You get to decide if you trust the pidgin developer who uploaded it, and that he has no reason to upload something you shouldn't trust. But good for you for asking.

comment:31 Changed 9 years ago by Tyrven

This solved the problem for me, as well. Thank you for the quick fix!

comment:32 follow-up: Changed 9 years ago by mystycs

Guys, i found another fix, Just install the Debug Version of Pidgin, or do a reinstall and delete all the files associated with pidgin, then install it again.

comment:33 in reply to: ↑ 32 Changed 9 years ago by datallah

Replying to mystycs:

Guys, i found another fix, Just install the Debug Version of Pidgin, or do a reinstall and delete all the files associated with pidgin, then install it again.

This isn't a valid fix. Note that this crash doesn't happen every time you hover over a buddy, there is a specific scenario under which it happens.

comment:34 Changed 9 years ago by rekkanoryo

Ticket #6804 has been marked as a duplicate of this ticket.

comment:35 follow-up: Changed 9 years ago by Hrki

When i replaced with this dll the ICQ protocol is removed?! WTF?!?!

comment:36 Changed 9 years ago by rekkanoryo

Ticket #6817 has been marked as a duplicate of this ticket.

comment:37 in reply to: ↑ 35 Changed 9 years ago by datallah

Replying to Hrki:

When i replaced with this dll the ICQ protocol is removed?! WTF?!?!

You probably replaced the file with the trac "view attachment" screen instead of the actually dll file.

comment:38 Changed 9 years ago by deryni

Ticket #6832 has been marked as a duplicate of this ticket.

comment:39 Changed 9 years ago by deryni

Ticket #6835 has been marked as a duplicate of this ticket.

comment:40 Changed 9 years ago by Tokar

I had the same probelm. That new liboscar.dll seems to have fixed it now, thanks.

comment:41 Changed 9 years ago by QuLogic

Ticket #6838 has been marked as a duplicate of this ticket.

comment:42 Changed 9 years ago by QuLogic

Ticket #6839 has been marked as a duplicate of this ticket.

comment:43 Changed 9 years ago by rekkanoryo

Ticket #6847 has been marked as a duplicate of this ticket.

comment:44 Changed 9 years ago by datallah

Ticket #6843 has been marked as a duplicate of this ticket.

comment:45 Changed 9 years ago by deryni

Ticket #6853 has been marked as a duplicate of this ticket.

comment:46 Changed 9 years ago by deryni

Ticket #6857 has been marked as a duplicate of this ticket.

comment:47 Changed 9 years ago by QuLogic

Ticket #6861 has been marked as a duplicate of this ticket.

comment:48 Changed 9 years ago by Sim-on

Ticket #6872 has been marked as a duplicate of this ticket.

comment:49 Changed 9 years ago by Sim-on

Ticket #6865 has been marked as a duplicate of this ticket.

comment:50 Changed 9 years ago by Sim-on

Ticket #6877 has been marked as a duplicate of this ticket.

comment:51 Changed 9 years ago by TheTrueAPlus

Ive noticed that it is with my contacts who use Adium.

comment:52 Changed 9 years ago by datallah

Ticket #6882 has been marked as a duplicate of this ticket.

comment:53 Changed 9 years ago by Sim-on

Ticket #6891 has been marked as a duplicate of this ticket.

comment:54 Changed 9 years ago by rekkanoryo

Ticket #6894 has been marked as a duplicate of this ticket.

comment:55 Changed 9 years ago by strategist333

New liboscar.dll works for me. Thanks.

comment:56 Changed 9 years ago by Sim-on

Ticket #6897 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!