Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6637 closed defect (fixed)

"Has You" no more available in 2.5.0

Reported by: benjiphil Owned by: khc
Milestone: 2.5.2 Component: MSN
Version: 2.5.0 Keywords: Has You
Cc: UPi, Fenris, hongkong, fsilveira

Description

We can't see the "Has You" field in the tooltips in 2.5.0. Did we forgot something about it when implementing MSNP15 ?

Attachments (1)

NoHasYou.JPG (35.4 KB) - added by benjiphil 9 years ago.
Winpidgin 2.5.0. Using the FR locale, but same bug when forcing Pidginlang to EN.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 9 years ago by bernmeister

I see it on mine (running WinPidgin? 2.5.0). Can you produce a screen shot of the tool tip?

Changed 9 years ago by benjiphil

Winpidgin 2.5.0. Using the FR locale, but same bug when forcing Pidginlang to EN.

comment:2 Changed 9 years ago by cnicog

I can't see the "has you:" either.. using windows xp sp3

comment:3 Changed 9 years ago by bernmeister

Hmmm...the irony.

I started doing more testing on this. I've got myself added to my buddy list (using MSN, Yahoo, ICQ, AIM, Gmail). They are all one meta-contact.

If I hover over myself when AVAILABLE, I see the tooltip. If I expand the meta-contact and hover over MSN, I DON'T see the HAS YOU label in the tooltip.

Also, hovering over other MSN contacts I don't see HAS YOU either. So I guess I can retract my first post.

When I did this new testing, I hovered over my MSN account and all was fine. I set my status to AWAY and hovered over myself...and Pidgin crashed...reliably!

I installed the debug version to get a back trace and when starting the debug version I was getting buddy list syncronisation errors popping up!

Looks like I'll put up a couple of new tickets...sheesh!

comment:4 Changed 9 years ago by datallah

  • Component changed from libpurple to MSN
  • Owner set to khc

comment:5 Changed 9 years ago by Dimmuxx

Line 359 is commented out in msn/userlist.c and I think that it might be related to this.

comment:6 Changed 9 years ago by UPi

I can't see "has you" either, pidgin 2.5.0 using Windows XP SP 2.

comment:7 Changed 9 years ago by Fenris

FWIW I get the "Has You" for MSN contacts on Win32 with an XP SP3 system, but under Linux (Fedora 9, rpms built from the 2.4.3 spec files) I don't see it at all. Can't see any reason why this should be different, but maybe some of the #defines are not the same depending on the platform?

comment:8 Changed 9 years ago by Fenris

Just to clarify, this is for 2.5.0 on both platforms, the 2.4.3 comment is purely related to the basis for the spec files. I'm pretty sure I used to see the Has You with 2.4.3 on Linux.

comment:9 Changed 9 years ago by QuLogic

Ticket #6920 has been marked as a duplicate of this ticket.

comment:10 Changed 9 years ago by Fenris

Checking further with 2.5.1 on both Win32 and Linux, the Has You has disappeared completely from both meta-contacts and expanded contacts whether hovering over the former or over the MSN contact of the latter.

comment:11 Changed 9 years ago by fsilveira

It is not implemented in libpurple/protocols/msn/msn.c, only in libpurple/protocols/msnp9/msn.c. Here is a simple patch to fix it:

--- pidgin-2.5.1.orig/libpurple/protocols/msn/msn.c     2008-09-05 16:34:53.000000000 -0300
+++ pidgin-2.5.1/libpurple/protocols/msn/msn.c  2008-09-05 16:33:29.000000000 -0300
@@ -769,6 +769,9 @@
        {
                const char *phone;
 
+               purple_notify_user_info_add_pair(user_info, _("Has you"),
+                                                                          ((user->list_op & (1 << MSN_LIST_RL)) ? _("Yes") : _("No")));
+
                purple_notify_user_info_add_pair(user_info, _("Blocked"),
                                                                           ((user->list_op & (1 << MSN_LIST_BL)) ? _("Yes") : _("No")));
 

comment:12 Changed 9 years ago by benjiphil

I can confirm, it works fine with this Reverse List check. I feel like it was missing since the beginning of MSNP14 development.

comment:13 Changed 9 years ago by qulogic@…

  • Milestone set to 2.5.2
  • Resolution set to fixed
  • Status changed from new to closed

(In 6a2fea9024166e4d473b00a87489c720617e3094):
We can't have ./configure lying to you, can we?

Fixes #6637.

comment:14 Changed 9 years ago by Sim-on

Ticket #7127 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!