Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#6743 closed defect (fixed)

Windows package of 2.5.0 do not have cool last eyed pidgin icon

Reported by: axet Owned by: datallah
Milestone: 2.7.3 Component: artwork
Version: 2.5.1 Keywords:
Cc: Root

Description

linux has it.

Attachments (1)

pidgin.ico (24.6 KB) - added by axet 11 years ago.
fixed 4 and 8 bit color

Download all attachments as: .zip

Change History (17)

comment:1 Changed 11 years ago by hbons

  • Owner set to hbons

Hmm, I have adjusted the .ico file to use the latest icon, but only for the highest color depth, because I didn't know how to reduce the colors. If someone with more Windows icon experience can create the correct file that would be great.

comment:2 Changed 11 years ago by hbons

  • Milestone set to 2.5.1

comment:3 Changed 11 years ago by axet

Problem happens only with localized version of pidgin (russian localization). I can't reproduce it for english version.

I tried run pidgin on russian windows server 2003 and got wrong icon in window menu. And i have no idea how to switch pidgin to english interface. On other os windows xp eng i have normal icon and pidgin switched to english interfaces. Also i have no idea how to switch to russian to test.

thx.

comment:4 Changed 11 years ago by axet

That problem can be related to windows server 2003 and not to lacalization. When i open icon file in gimp i found several images contain old in new pidgin icons. Probably windows server have different priorities to load images from icon then windows xp. Look like is nessesery to remove unused icon.

Changed 11 years ago by axet

fixed 4 and 8 bit color

comment:5 Changed 11 years ago by axet

Look like problem related to display bit depth. On my server i use low 8bit remote desktop.

i used this problem to change icons http://icofx.ro/, they work fine under fedora build wine.

comment:6 Changed 11 years ago by hbons

Servers probably don't care about high color depth, I'm sure that must be the reason.

comment:7 Changed 11 years ago by axet

  • Version changed from 2.5.0 to 2.5.1

2.5.1 still have old icon

comment:8 Changed 11 years ago by datallah

  • Milestone 2.5.1 deleted

comment:9 Changed 10 years ago by bernmeister

An icon has been added to this ticket...so should this be changed to Patches Needing Review?

comment:10 Changed 10 years ago by darkrain42

  • Component changed from pidgin (gtk) to artwork
  • Milestone set to Patches Needing Review

I hesitate to characterize this as a "Patch", but, well, it's the closest to accurate. :)

comment:11 Changed 9 years ago by salinasv

  • Milestone changed from Patches Needing Review to 2.7.1

Is this still valid? I'm setting the milestone to 2.7.1 to get it applied or closed.

comment:12 Changed 9 years ago by Robby

  • Milestone changed from 2.7.1 to 2.7.2

comment:13 Changed 9 years ago by salinasv

  • Owner changed from hbons to datallah

Daniel, can you take a look at this. I'm assigning it to you because it looks like windows related and you can tell if this is still valid.

comment:14 Changed 9 years ago by MarkDoliner

  • Milestone changed from 2.7.2 to 2.7.3

This change will actually go out in 2.7.3.

comment:15 Changed 9 years ago by MarkDoliner

  • Resolution set to fixed
  • Status changed from new to closed

Committed. Sorry for the long turn around time! People please test, because I didn't. I looked at axet's image and compared each layer to the version previously checked in and axet's looks better. It's basically the same file except two layers have a Pidgin head with bigger eyes.

comment:16 Changed 9 years ago by markdoliner@…

(In 588fbc09c11c17e34981e5c1c3d1cbf2cc4e2a16):
Update pidgin.ico file. This image is made of a bunch of different size Pidgin icons, each one is basically its own layer. And I guess MS Windows picks an appropriate one to use as the icon. Apparently two of the images in the old version of this file had goofy looking eyes. Maybe Hylke created a better version of these small icons, but somehow this image wasn't updated. Then "axet" modified the .ico and submitted an updated version. Fixes #6743

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!