Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7056 closed enhancement (duplicate)

group contacts based on email/JID/Passport

Reported by: BUGabundo Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.5.1 Keywords: groups,expand,collapse,contacts, UI,Uniformity
Cc: BUGabundo

Description

On the second paragraph of http://developer.pidgin.im/wiki/Using%20Pidgin#CanIgroupbuddiesbytheirownerlikeTrilliansorMirandasMetacontacts it states that

If you use the Alias function, by either highlighting a buddy and pressing F2 or right-clicking and selecting "Alias...," when two or more buddies in the same group are aliased to the same name, Pidgin will prompt you to automatically merge them together into one contact.

It would be great if Pidgin could (optionally automatically) group contacts into a single contact base on their email address/JID/Passport when you have the same over different accounts. I use 3 XMPP account and MSN (plus several others, not relevant here) and I have many contacts that have the same email. When I add new contacts to all 4 accounts I have to MANUALLY group them, when this can easily be done by the Alias code - but the Alias function only works for already existing contacts and requires manual intervention too.

Can some dev accept this ticket and work something out? Thanks in advance

Change History (10)

comment:1 Changed 11 years ago by BUGabundo

I guess that http://developer.pidgin.im/ticket/2030 is in some way a dupe of this ticket.

comment:2 follow-up: Changed 11 years ago by deryni

Automatic contactizing by alias should work for newly added buddies if they are given an existing alias. Is it not?

comment:3 in reply to: ↑ 2 Changed 11 years ago by BUGabundo

Replying to deryni:

Automatic contactizing by alias should work for newly added buddies if they are given an existing alias. Is it not?

I always leave Alias in blank for new contacts! Is Blank = to Blank?

comment:4 follow-up: Changed 11 years ago by deryni

  • Status changed from new to pending

No we don't match the empty alias (at least I seriously hope we don't), that would cause every buddy without an alias in the group to be matched to each other. Something that is decidedly not what anyone would want.

If you try giving the buddy an alias when you add them does pidgin ask if you want to contactize them? If it does is that enough for you or is there something else you still want?

comment:5 in reply to: ↑ 4 Changed 11 years ago by BUGabundo

  • Status changed from pending to new

Replying to deryni:

No we don't match the empty alias (at least I seriously hope we don't), that would cause every buddy without an alias in the group to be matched to each other. Something that is decidedly not what anyone would want.

As far as I know, it wont group empty Alias. that was only a generic question. But I manage to get it working by expanding and separating two already manually group contact, and just editing one of its EMPTY Alias. I just clicked and saved, even as empty, and Pidgin suggested me to group them back. kinda strange.

Replying to deryni:

If you try giving the buddy an alias when you add them does pidgin ask if you want to contactize them? If it does is that enough for you or is there something else you still want?

I would like for it to be automatic even without any Alias, so it could/should be based on email not an Alias.

Offtopic: maybe i'm miss understanding this, but what are Alias for? (nick)Names I want to place on my contacts overiting what they choose to show, correct? If so, I dont want to have Alias on them, if not, please explain further. Thanks.

comment:6 follow-up: Changed 11 years ago by deryni

Yes, that is what the alias is for.

I do not think automatically grouping based on the buddy name is a good idea. For example, AIM and Yahoo names are indistinguishable, but there is no guarantee that users with the same AIM and Yahoo names are the same person.

I have no idea why pidgin would ask you to group buddies with the same empty alias. Are you sure the alias was empty (and not defaulting to the username)?

comment:7 in reply to: ↑ 6 Changed 11 years ago by BUGabundo

Replying to deryni:

I do not think automatically grouping based on the buddy name is a good idea. For example, AIM and Yahoo names are indistinguishable, but there is no guarantee that users with the same AIM and Yahoo names are the same person.

Yes, I already had that talk with a friend. This would only work for accounts that use a FULL email, not just IDs. So MSN and XMPP work fine, but Yahoo or AIM won't.

Replying to deryni:

I have no idea why pidgin would ask you to group buddies with the same empty alias. Are you sure the alias was empty (and not defaulting to the username)?

It might have assumed the email, instead of blank or empty

comment:8 Changed 11 years ago by rlaager

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #336.

comment:9 follow-up: Changed 11 years ago by BUGabundo

#336 should be a dupe of this one, and not the other way around, since this one as much more discussion.

What do u mean with:

we know *for certain* they are the same account on a given service.

Do you mean group on the same service, or cross service?

comment:10 in reply to: ↑ 9 Changed 11 years ago by rlaager

Replying to BUGabundo:

#336 should be a dupe of this one, and not the other way around, since this one as much more discussion.

More discussion is not necessarily better. For example, in this case, I'd prefer to boil down the useful points here and update the description on #336, which is what I just finished doing.

I think time has proven the URL idea in #336 isn't really necessary, so I've updated it to reflect the idea of using email-based comparison, as you've suggested here. This is also more useful today, when we have AIM/ICQ & Yahoo/MSN interoperation.

What do u mean with:

we know *for certain* they are the same account on a given service.

Do you mean group on the same service, or cross service?

The proposal that I've made will NOT group "rlaager" on AIM with "rlaager" on Yahoo, because they're not necessarily the same (and in this example, are not). It will, however, group richielaager on AIM with richielaager on ICQ. The revised proposal would also group rlaager on Yahoo with the Yahoo buddy "rlaager" on MSN and both of those with the MSN buddy with a passport of "rlaager@…" (if that's still possible).

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!