Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#7108 closed defect (duplicate)

XMPP file transfer using file transfer proxy doesn't work

Reported by: mcepl Owned by: deryni
Milestone: Component: XMPP
Version: 2.5.1 Keywords:
Cc:

Description

when trying to transfer any file over Jabber (be it with my friend or with disk.jabbim.cz), on my side the transfer is cancelled and on the other side Stalled (using psi). Using porxy.jabber.org and proxy.jabbim.cz (both of which are known to work in the time of attempt). When trying disk.jabbim.cz, the resulting file is 0 byte long.

Logs are attached.

Using Pidgin 2.5.1-3.fc10 on Fedora Rawhide

Attachments (2)

purple-debug.log (4.5 KB) - added by mcepl 11 years ago.
from Help/Debug?
purple-debug02.log (2.5 KB) - added by mcepl 11 years ago.
another attempt

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by mcepl

Changed 11 years ago by mcepl

another attempt

comment:1 Changed 11 years ago by datallah

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #5840.
This is caused by a broken proxy.

comment:2 Changed 11 years ago by deryni

Both of them? The first one certainly looks like it but the second one doesn't.

comment:3 Changed 11 years ago by datallah

Oh, I hadn't looked at the second one.

The second log actually looks incomplete like there might have been a filter on the debug window or was selectively copied and pasted. (Specifically it looks like there is some output missing before the last stanza).

comment:4 follow-up: Changed 10 years ago by thenktor

My Openfire server gives me a lot errors like this: 2008.11.18 14:53:16 [org.jivesoftware.openfire.filetransfer.proxy.ProxyConnectionManager?$1$1.run(ProxyConnectionManager?.java:115)] Error processing file transfer proxy connection java.io.IOException: Only SOCKS5 supported at org.jivesoftware.openfire.filetransfer.proxy.ProxyConnectionManager?.processConnection(ProxyConnectionManager?.java:143) at org.jivesoftware.openfire.filetransfer.proxy.ProxyConnectionManager?.access$100(ProxyConnectionManager?.java:44) at org.jivesoftware.openfire.filetransfer.proxy.ProxyConnectionManager?$1$1.run(ProxyConnectionManager?.java:112) at java.util.concurrent.Executors$RunnableAdapter?.call(Executors.java:441) at java.util.concurrent.FutureTask?$Sync.innerRun(FutureTask?.java:303) at java.util.concurrent.FutureTask?.run(FutureTask?.java:138) at java.util.concurrent.ThreadPoolExecutor?$Worker.runTask(ThreadPoolExecutor?.java:886) at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:908) at java.lang.Thread.run(Thread.java:619)

I don't know if this is Pidgin related or a server problem, but file transfer is not possible with Pidgin. Gajim has no problems with file transfers.

comment:5 in reply to: ↑ 4 Changed 10 years ago by datallah

Replying to thenktor:

My Openfire server gives me a lot errors like this: 2008.11.18 14:53:16 [org.jivesoftware.openfire.filetransfer.proxy.ProxyConnectionManager?$1$1.run(ProxyConnectionManager?.java:115)] Error processing file transfer proxy connection java.io.IOException: Only SOCKS5 supported at org.jivesoftware.openfire.filetransfer.proxy.ProxyConnectionManager?.processConnection(ProxyConnectionManager?.java:143) at org.jivesoftware.openfire.filetransfer.proxy.ProxyConnectionManager?.access$100(ProxyConnectionManager?.java:44) at org.jivesoftware.openfire.filetransfer.proxy.ProxyConnectionManager?$1$1.run(ProxyConnectionManager?.java:112) at java.util.concurrent.Executors$RunnableAdapter?.call(Executors.java:441) at java.util.concurrent.FutureTask?$Sync.innerRun(FutureTask?.java:303) at java.util.concurrent.FutureTask?.run(FutureTask?.java:138) at java.util.concurrent.ThreadPoolExecutor?$Worker.runTask(ThreadPoolExecutor?.java:886) at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:908) at java.lang.Thread.run(Thread.java:619)

I don't know if this is Pidgin related or a server problem, but file transfer is not possible with Pidgin. Gajim has no problems with file transfers.

This is a different issue. Please file a new ticket including the debug output from Pidgin.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!