Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7172 closed defect (invalid)

Position of conversation window

Reported by: Migi Owned by: lschiere
Milestone: Component: unclassified
Version: 2.5.1 Keywords:
Cc:

Description

Pidgin don't remember position of conversation window. New window is opening in left-top corner.

Change History (15)

comment:1 Changed 10 years ago by datallah

  • Status changed from new to pending

Which OS?

comment:2 Changed 10 years ago by penguino

I can verify this happens in linux, Debian Lenny. I am using KDE.

Pidgin 2.5.1 compiled using all default options (yes I had to fix the certificate problem for MSN too).

Every time you open a chat window, whether you click on the person in the buddy list, OR click on an incoming conversation in the system tray, the window appears always in the top left corner of the desktop and has to be dragged to reposition it. This is non critical but it is very annoying and also something of a privacy concern (I used Pidgin at work and I dont like conversations appearing at the top of my screen).

Apart from that (and the certificate problem), 2.5.1 seems remarkably clean.

comment:3 Changed 10 years ago by datallah

  • Resolution set to invalid
  • Status changed from pending to closed

Pidgin doesn't place the window, it is up to your window manager to decide the position.

comment:4 follow-up: Changed 10 years ago by penguino

It used to work fine. What has changed?

comment:5 Changed 10 years ago by penguino

Oh, and can you kindly Un-Close this bug again please. I do not believe there has been sufficient analysis yet to warrant closure.

comment:6 follow-up: Changed 10 years ago by penguino

By the way, I think you possibly mis-understand the problem. If the window is left open, and just minimized, yes of course the window manager remembers the position. But when the window is *initialized*, ie. launched from the system tray or from the buddy list, then it always appears in the top left corner. Previously the window position remained stored.

Hope that clarifies.

comment:7 in reply to: ↑ 4 Changed 10 years ago by datallah

Replying to penguino:

It used to work fine. What has changed?

There was a bug for a few versions which cause the window placement code to be in effect on platforms other then Windows.

comment:8 in reply to: ↑ 6 Changed 10 years ago by datallah

Replying to penguino:

By the way, I think you possibly mis-understand the problem. If the window is left open, and just minimized, yes of course the window manager remembers the position. But when the window is *initialized*, ie. launched from the system tray or from the buddy list, then it always appears in the top left corner. Previously the window position remained stored.

There is no misunderstanding, we're talking about the same thing.

comment:9 Changed 10 years ago by penguino

Thats a real shame then, the new behaviour is most annoying.

comment:10 Changed 10 years ago by deryni

I fully agree that it is annoying that most window managers are incapable of allowing users to control when and where windows open. I fully support a campaign to fix that. It really isn't something that most applications should care about just about ever.

comment:11 Changed 10 years ago by penguino

I agree, but the functionality needs to be there one way or another. Or rather, it was working fine and then was removed. This represents a drop in user satisfaction.

comment:12 Changed 10 years ago by deryni

Actually, it was never 'working' (not as intended anyway), it was added for Windows only but also happened to work on non-Windows. That was reported as a bug and was subsequently fixed.

And yes, the functionality should be there, in the window managers.

comment:13 Changed 10 years ago by penguino

Yes, I'm aware of the 'bug' history, but the ability/workaround is not there now, and the interface as a result is not as nice to use as it was.

comment:14 Changed 10 years ago by deryni

I sympathize with your inability to have the conversation windows placed where you want them to be, but feel no compulsion to break the window management system for those users (myself included) who use capable window managers to fix things for those users who do not. As I've said on more than one occasion (here and other places) if your window manager doesn't do what you want it to do complain to the authors until it does or find a new one that does it already. Working around crappy software in other unrelated software is not a good idea if at all avoidable.

comment:15 Changed 10 years ago by penguino

The points you re-raise are perfectly fine. It was however, working fine before and now isn't. It is not as nice to use, and in fact is rather annoying. If you are concerned about build purity then perhaps a -- configure option would be a nice solution.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!