Opened 12 years ago

Closed 6 years ago

#730 closed enhancement (fixed)

Support for Adium "Message Styles"

Reported by: lithium Owned by: seanegan
Milestone: 3.0.0 Component: pidgin (gtk)
Version: 2.0 Keywords: webkit adium message styles
Cc: ferk, Dawudd, salinasv, IceWil, znotdead, marsjaninzmarsa

Description

It would be nice if Pidgin could support the "Message Styles" as implemented by AdiumX:

http://www.adiumxtras.com/index.php?a=search&cat_id=5

Change History (49)

comment:1 Changed 12 years ago by lschiere

  • Owner set to marv

I have always considered these one of the more noticable flaws of Adium. ;-)

Tim, I'm inclined to reject this, what think you?

comment:2 Changed 12 years ago by lithium

Flaw? It's the outstanding feature of Adium... Those Styles can be very fun to use and support for the format seems to be getting common (aready supported by Kopete, Landell, Banter and probably others too)

comment:3 Changed 12 years ago by liviopl

I would be very nice. But there's a question: which component to use? GtkHTML, GtkMozEmbed? or GtkWebCore??

comment:4 follow-up: Changed 12 years ago by marv

I think this would be a good plugin.

I'm not sure how feasible this is to do as a plugin right now. I see the biggest problem being the subset of html we support rendering. I don't recall us supporting background images, for example. If we ever switched to a full html renderer than this might be completely possible.

comment:5 Changed 12 years ago by seanegan

  • Milestone set to 2.2.0
  • Owner changed from marv to seanegan
  • Status changed from new to assigned

comment:6 Changed 12 years ago by lithium

So the HTML renderer seems to be the biggest problem. IMHO the best thing to do would be going for WebKit (when that is ready). WebKit/GTK has made huge progress in the last few month. Judging from the test browser, rendering is nice and fast and the memory usage is quite low compared to mozilla.

comment:7 Changed 12 years ago by liviopl

Mozilla would only slow down Pidgin. Many people are talking with people in one time - using tabs/panels.

Epiphany is browser using Mozilla, main interface is fast, but Mozilla is slowing down Epiphany. This is good example to not use Mozilla, but WebKit.

WebKit should be implemented, but available as option/flag in configure.

comment:8 in reply to: ↑ 4 Changed 12 years ago by liviopl

Replying to marv:

I think this would be a good plugin.

Plugin? Why don't include this in core, like it was done in Adium?

comment:9 follow-up: Changed 11 years ago by jcarter

Has any progress been made on this I was really looking forward to seeing it in action.

comment:10 in reply to: ↑ 9 Changed 11 years ago by seanegan

Replying to jcarter:

Has any progress been made on this I was really looking forward to seeing it in action.

Yes. See http://www.pidgin.im/~seanegan/cgi-bin/pyblosxom.cgi/htmlwidget.html

liviopl: it's a plugin until it's stable and featurful enough to replace the current 'GtkIMHtml' widget we currently use.

comment:11 Changed 11 years ago by liviopl

Sean, can I ask you something? Could you give me Pidgin-Devel screenshot with Renkoo style :> ?

comment:12 Changed 11 years ago by seanegan

http://pidgin.im/~seanegan/webkit7.png is a slightly older screenshot using that theme.

comment:13 Changed 11 years ago by jcarter

I've been fiddling with the file on your blog for a while and I can't get it to work (I'm pretty bad at programming) aside from the how-to's is there any help you can offer?

comment:14 Changed 11 years ago by liviopl

Woa, looks great in Pidgin (better than in Adium X) :) .

comment:15 Changed 11 years ago by npike

any progress on this?

comment:16 Changed 11 years ago by liviopl

Sean has made this, but this will not be official until WebKit becomes usable (long time we must wait until).

comment:17 Changed 11 years ago by liviopl

Hmmm. What about using GtkMozEmbed? with Gecko 1.9? Fast and usable.

Gecko 1.9 is fast enough, while WebKit freezes many times, when unexpected.

comment:18 Changed 11 years ago by Megarain

Could some one attach the compiled plugin file to this ticket? That would be really helpful.

comment:19 follow-up: Changed 11 years ago by liviopl

http://www.pidgin.im/~seanegan/cgi-bin/pyblosxom.cgi/htmlwidget.html (q: "it's here right now (...)").

Your problem if you don't know how to compile. We're not Microsoft, we give source, they give closed virus.

comment:20 in reply to: ↑ 19 Changed 11 years ago by Megarain

Replying to liviopl:

http://www.pidgin.im/~seanegan/cgi-bin/pyblosxom.cgi/htmlwidget.html (q: "it's here right now (...)").

Your problem if you don't know how to compile. We're not Microsoft, we give source, they give closed virus.

Wow, that's some hate.

I'm just suggesting that we offer a compiled version of the preview for people just starting out with contributing to the source.

comment:21 Changed 11 years ago by dolfelt

I have been trying to compile this, but I keep getting syntax errors in the compiler. I included the webkit, but it still does not work. I was able to compile the Pidgin source just fine. Could someone give me insight on how to compile this (e.g. where to put the dependencies, and what they are)? Or possibly attach a compiled dll file? Thanks!

comment:22 Changed 11 years ago by seanegan

I'll check this into mtn next week at which point it will be better supported.

comment:23 Changed 11 years ago by liviopl

Check if your code is ABI/API compatible with WebKit. There was significal change in naming. Check if your code uses WebKitPage? or something like this.

comment:24 Changed 11 years ago by dolfelt

I am getting an undefined reference for the Webkit functions. I believe it is because all the functions are having _imp added in front of them. How do I stop / fix this? If I can figure this out, I should be able to get it to compile.

comment:25 Changed 11 years ago by liviopl

Sean, I think you can now consider using GtkMozEmbed?. Gecko 1.9 is very fast, indeed, while Webkit-GTK freezes frequently.

comment:26 Changed 11 years ago by dolfelt

Is there any update on this plugin? I am really excited to start testing with it and improving it. If it could be checked into mtn or a dll uploaded, that would be wonderful!

comment:27 Changed 11 years ago by Sim-on

  • Milestone set to 2.4.2

comment:28 Changed 11 years ago by lithium

I'm really looking forward to this. In the GNOME world, projects have also started moving to WebKit. Yelp and Evolution will probably move to it for the 2.24 release and Epiphany has just announced they will drop Gecko¹ and exclusively use WebKit.

[1] http://mail.gnome.org/archives/epiphany-list/2008-April/msg00000.html

comment:29 Changed 11 years ago by liviopl

Switching to WebKit... Huh.

I wish luck...

comment:30 Changed 11 years ago by IbrahimA

So this might be possible in the next release? I was about to try to compile the plugin myself, but I guess I can wait for the next version. That WebKit source is huge, and I'd probably fail at compiling it anyway.

comment:31 Changed 11 years ago by bsiegel

I'm working on a plugin which I would like to be able to open a window within Pidgin (similar to how purple_notify_formatted works) that contains an embedded <object> (Flash movie). I'm pretty sure GtkImHtml? can't do it, so I assume the only hope I have for this is if WebKit gets integrated?

comment:32 Changed 11 years ago by QuLogic

  • Milestone 2.4.2 deleted

So, Sean, are you ever going to commit that MTN branch?

Anyway, I've been fiddling with this, and there seem to be a few changes needed. webkit.c should #include <webkit/webkitwebview.h> and <webkit/webkitnetworkrequest.h>, not <webkitwebview.h> and <webkitnetworkrequest.h>. Additionally, replace_message_tokens, replace_header_tokens, replace_template_tokens, get_webkit, and escape_message should be static to avoid warnings (I think that's the right fix, anyway). On line 428, there is the declaration of GtkIMHtmlSmiley *imhtml_smiley after some code, so it needs to be moved up to avoid another warning.

Stu's autotools patch needed a little tweaking as well. Pkg-config required the name 'webkit-1.0' instead of 'WebKitGtk'. I'm not sure when this changed, but I'm using revision 31787. Also, there's a reference to some 'Template.html', which I assume would be the default style, but webkit.c seems to unconditionally use files from the user's directory. There's also a ton of leaks calling g_build_filename and not g_free-ing the result, but I assume you'll fix that when you finish that theme chooser thing (whenever it is you get around to that, Sean!)

comment:33 Changed 11 years ago by themadhatter

This was promising. Is there any efforts being put behind this feature?

comment:34 Changed 11 years ago by liviopl

try galaxium. it already does support this (both in gecko and webkit backends) :) .

comment:35 Changed 11 years ago by ssuuddoo

any news? it is already the version 2.4.3, but I do not see anything new.

can we help somehow?

ssuuddoo Slovakia

comment:36 Changed 11 years ago by ibrahima

I noticed the FunPidgin fork http://funpidgin.sourceforge.net/ claims to include this as a feature (so far, it seems like all they know how to do is copy/paste old code and include plugins made by others). I tried unzipping their installer using 7zip to get at a compiled DLL but I couldn't find one. I've never been able to compile it myself because the webkit source takes too long to download just to compile an experimental plugin that might not work. In any case, any progress on this being integrated into Pidgin proper yet? I'm just curious about what the fuss is all about, although I'm guessing I'd go back to the standard, space-saving style after a while.

comment:37 Changed 11 years ago by Simom

I didn't find any progress on this so I started playing with the plugin myself. It is here: https://launchpad.net/pidgin-webkit

comment:38 Changed 10 years ago by ferk

any news? Is still Webkit/Gtk?+ not stable enough? I think this would be a very neat feature

comment:39 Changed 10 years ago by liviopl

Try Pidgin-WebKit. Works like a charm but don't try to change contact of metacontact while already chatting.

For lazy people: https://launchpad.net/pidgin-webkit

comment:40 Changed 10 years ago by seeboo

Just wondering.. Is there still anybody working on this? sean's screenshots looked very nice, but it doesn't look like he's still developing this.. is he?

Anyway, i'd really like to see this in pidgin.

comment:41 Changed 10 years ago by deryni

I dont' believe anyone is actively working on it at the moment, though I believe someone imported it into a Google Code project a while back and I don't know what happened with that.

comment:42 Changed 10 years ago by Robby

Isn't this part of the "Webkit Message Views" GSoC?

comment:43 Changed 10 years ago by deryni

  • Keywords webkit adium message styles added

Yes, the Webkit SoC work includes some support for Adium Message Themes see here.

comment:44 Changed 9 years ago by QuLogic

Ticket #10977 has been marked as a duplicate of this ticket.

comment:45 Changed 9 years ago by znotdead

Is there any progress on this plugin ? (for example as it is in Empathy on lucid lynx )

comment:46 Changed 9 years ago by behzadsh

when using adium message styles, in yahoo protocol,message will not show if some smiley (like :-" and :">) were used!

e.g if you type "Thanks :">" nothing will be shown. this is happen when your smiley theme have a smiley icon for :-" or :">!

comment:47 Changed 9 years ago by darkrain42

Ticket #12295 has been marked as a duplicate of this ticket.

comment:48 Changed 8 years ago by Robby

  • Summary changed from Support for AdiumX "Message Styles" to Support for Adium "Message Styles"

That irked me, sorry for the spam. :P

comment:49 Changed 6 years ago by QuLogic

  • Milestone set to 3.0.0
  • Resolution set to fixed
  • Status changed from new to closed

The SoC work was merged ages ago. Why is this still open...

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!