Opened 8 years ago

Closed 7 years ago

#7500 closed enhancement (duplicate)

Preferences window too high for MSI Wind 100 netbook

Reported by: pbekesi Owned by:
Milestone: Component: unclassified
Version: 2.5.1 Keywords: netbook, display, interface
Cc:

Description

My MSI Wind Netbook's highest display resolution is 1024x600, but the Preferences window is higher than that and there is no way to resize it. Therefore the OK and Cancel buttons cannot be pushed, I have to use the keyboard to commit or cancel the changes.

Attachments (4)

screenshot.PNG (34.0 KB) - added by pbekesi 8 years ago.
Screenshot of the Preferences window on my full screen (taskbar is on autohide).
60_1024x600_gtkprefs.c.patch (1.1 KB) - added by paulliu 7 years ago.
Add scrollbars to Preference Window
60_1024x600_gtkaccount.c.patch (1.7 KB) - added by paulliu 7 years ago.
Add scrollbars to Account setting
60_1024x600_gtkpounce.c.patch (1.7 KB) - added by paulliu 7 years ago.
Add scrollbars to Pounce dialog

Download all attachments as: .zip

Change History (12)

Changed 8 years ago by pbekesi

Screenshot of the Preferences window on my full screen (taskbar is on autohide).

comment:1 Changed 8 years ago by deryni

You can move windows with the keyboard such that you could press the buttons but that doesn't solve the real problem.

comment:2 Changed 8 years ago by pbekesi

Yes, I tried. I was able to move the window with the keyboard, but to click on the buttons I had to press Enter first and that just put the window back to a lower position. :(

comment:3 Changed 8 years ago by deryni

Huh. I would have sworn that Windows used to let you position windows off the top of the screen, but it would appear that either I was wrong or they changed that since I last tried.

What Windows does and doesn't allow for window positioning has always mystified me.

comment:4 Changed 8 years ago by deryni

Ticket #7530 has been marked as a duplicate of this ticket.

comment:5 Changed 7 years ago by lschiere

  • Owner lschiere deleted

Changed 7 years ago by paulliu

Add scrollbars to Preference Window

Changed 7 years ago by paulliu

Add scrollbars to Account setting

Changed 7 years ago by paulliu

Add scrollbars to Pounce dialog

comment:6 Changed 7 years ago by paulliu

Dear all,

I have some downstream patch. It simply add some scrollbars when the screen height is not enough.

They comes from https://bugs.launchpad.net/ubuntu/+source/pidgin/+bug/305019

Ask me to refine the patches for any purpose.

Thanks.

comment:7 Changed 7 years ago by mterry

Also see http://developer.pidgin.im/ticket/7548 which is probably a dup of this bug, but it has more information, so I'd recommend dup'ing this one instead.

I've been putting reworked patches there that don't use scrollbars, based on on a conversation paulliu and I had.

comment:8 Changed 7 years ago by deryni

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #7548.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!