Opened 11 years ago

Closed 10 years ago

#7507 closed defect (invalid)

Segfault in Fedora 10 with GStreamer

Reported by: dmyersturnbull Owned by: rekkanoryo
Milestone: Component: unclassified
Version: 2.5.2 Keywords: gstreamer
Cc: Silivrenion

Description

Running Pidgin 2.5.2-1 under Fedora 10's Rawhide repository (Fedora 10) with Linux kernel revision 2.6.27.4-79. Have been experiencing frequent crashes.

(pidgin:8471): GStreamer-CRITICAL **: 
Trying to dispose element play, but it is not in the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.

(pidgin:8471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:8471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed

'''(last two lines are outputted multiple times)'''

E: shm.c: mmap() failed: Cannot allocate memory
'''(last one line is outputted multiple times)'''

pidgin: pulse.c:203: pulse_new: Assertion `p->context' failed.
Pidgin 2.5.2-1.fc10 has segfaulted and attempted to dump a core file.

Seems to happen randomly, averaging to about about once per 20 minutes. First noticed the problem yesterday (2008-11-09); enabled the History plugin (2.5.2-1) then or a few days before. Have been using same version under Fedora 10 for approx. two weeks. Have the following plugins (all 2.5.2-1) loaded:

Buddy Notes
Buddy State Notification
Conversation Colors
ExtPlacement
History
I'dle Mak'er
Iconify on Away
Message Notification
Message Timestamp Formats
Pidgin GTK+ Theme Control
Text replacement

Attachments (3)

Pidgin segfault log (5.5 KB) - added by dmyersturnbull 11 years ago.
message (and error) log
gdb_dump.txt (22.4 KB) - added by Silivrenion 10 years ago.
Silivrenion's GDB Dump file
pidgin-bugreport.txt (660.8 KB) - added by Silivrenion 10 years ago.
Pidgin's bug report as reported by Fedora 10

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by dmyersturnbull

message (and error) log

Changed 10 years ago by Silivrenion

Silivrenion's GDB Dump file

Changed 10 years ago by Silivrenion

Pidgin's bug report as reported by Fedora 10

comment:1 Changed 10 years ago by Silivrenion

I'd like to confirm also experiencing the same problem. I thought it was due to using the Facebook plugin, but even when I disabled that, it kept happening, and GStreamer errors are occuring in the console.

I am having it happen in the same frequency as the original poster.

Thanks for any help you can give!

comment:2 Changed 10 years ago by stefanharjes

I had this error in a totally different environment, but it is related to pulseaudio. PA tries to allocate 64MB at once. In my case it helped, if I restricted this to 16MB by adding

shm-size-bytes = 16777216

to /etc/pulse/client.conf

comment:3 Changed 10 years ago by QuLogic

  • Owner changed from lschiere to rekkanoryo

comment:4 Changed 10 years ago by bernmeister

Is this still occurring? Can you test/reproduce in 2.5.8? Can you try without any plugins enabled.

comment:5 Changed 10 years ago by darkrain42

  • Resolution set to invalid
  • Status changed from new to closed

This is crashing in PulseAudio?.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!