Opened 11 years ago

Closed 4 years ago

#7508 closed defect (out of date)

MSN crash sending offline message

Reported by: noccy Owned by: khc
Milestone: Component: MSN
Version: 2.5.2 Keywords: crash offline message
Cc: ari, pvuorela, salinasv, malcolm

Description

Pidgin seems to crash whenever messages are sent to an offline MSN user.

To reproduce: Talk to a user over MSN, have the user go offline, and then add another one or two lines to the conversation.

Attachments (8)

pidgin.RPT (2.2 KB) - added by thralas 11 years ago.
pidgin.2.RPT (2.1 KB) - added by Blue Ninja 10 years ago.
Latest crash report
pidgin.3.RPT (2.1 KB) - added by Blue Ninja 10 years ago.
My original report from 9 Feb - should have attached it instead of pasting into message.
Pidgin-debug.log (25.3 KB) - added by oji-sama 10 years ago.
Debug log with a few comments. Starts with me sending an offline message "pöö" to a user that had sent me a message several hours ago
pidgin_crash.txt (1.9 KB) - added by pvuorela 10 years ago.
backtrace for my crashes
pidgin-log (7.3 KB) - added by edman007 10 years ago.
Backtrace, log and comments
pidgin.4.RPT (2.2 KB) - added by lemonairepaides 10 years ago.
RPT of crash
pidgin-1.log (28.5 KB) - added by malcolm 9 years ago.
Debug output of the crash, when running Pidgin as pidgin -d.

Download all attachments as: .zip

Change History (63)

comment:1 Changed 11 years ago by rekkanoryo

  • Status changed from new to pending

Please follow the instructions to get a backtrace and attach it to this ticket.

comment:2 Changed 11 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:3 Changed 11 years ago by ranma42

I suffered a crash caused by the same problem. I tried to reproduce it, but it's not sufficient to send an OIM to a contact who has just had a conversation with you. I'll report here again as soon as I manage to get a backtrace.

Changed 11 years ago by thralas

comment:4 Changed 11 years ago by thralas

I'm not able to reproduce it either, but after being away for a while I found Pidgin had crashed again. Sadly I cannot remember whether I sent a message to an offline user before I left, however looking at the stack trace however indicates that I probably did.

comment:5 Changed 11 years ago by khc

do you also have the debug log?

comment:6 Changed 11 years ago by Blue Ninja

This has been happening to me for a few weeks also - just upgraded to 2.5.3, and it's still happening.

comment:7 Changed 11 years ago by ranma42

Backtrace obtained after sending an OIM to an offline buddy (Pidgin 2.5.3 on FreeBSD 7.1)

(gdb) bt
#0  0x2936310c in msn_soap_write_cb_internal (data=0x29c3ab00, fd=Variable "fd" is not available.
)
    at soap.c:544
#1  0x080a3103 in pidgin_eventloop_get_ui_ops ()
#2  0x28a48a29 in g_io_channel_unix_get_fd ()
   from /usr/local/lib/libglib-2.0.so.0
#3  0x28a171fe in g_main_context_dispatch ()
   from /usr/local/lib/libglib-2.0.so.0
#4  0x28a1a309 in g_main_context_check () from /usr/local/lib/libglib-2.0.so.0
#5  0x28a1a6d8 in g_main_loop_run () from /usr/local/lib/libglib-2.0.so.0
#6  0x28298363 in gtk_main () from /usr/local/lib/libgtk-x11-2.0.so.0
#7  0x080bb376 in main ()
(gdb) bt full
#0  0x2936310c in msn_soap_write_cb_internal (data=0x29c3ab00, fd=Variable "fd" is not available.
)
    at soap.c:544
        conn = Variable "conn" is not available.
(gdb) 

I don't know why gdb is unable to get a meaningful full backtrace. Should I compile with some debugging options? Apparently the symbols are available, since function and variable names get printed...

comment:8 Changed 11 years ago by khc

if you compiled with optimization, it's possible that the compiler optimized some variables away

comment:9 Changed 11 years ago by ranma42

I'll recompile pidgin and try to reproduce the problem again. Is the backtrace correct, except for the missing variables?

comment:10 Changed 11 years ago by ranma42

Here is the full backtrace after recompiling without optimizations. In the meantime I upgraded to version 2.5.4

(gdb) bt full
#0  0x294ffb5d in msn_soap_write_cb_internal (data=0x29f4ad30, fd=23, 
    cond=PURPLE_INPUT_WRITE, initial=0) at soap.c:544
        conn = (MsnSoapConnection *) 0x29f4ad30
        written = 1
#1  0x294ffce5 in msn_soap_write_cb (data=0x29f4ad30, fd=23, 
    cond=PURPLE_INPUT_WRITE) at soap.c:580
No locals.
#2  0x080abdfb in docklet_ui_init ()
No symbol table info available.
#3  0x28b15159 in g_io_channel_unix_get_fd ()
   from /usr/local/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x28ae339e in g_main_context_dispatch ()
   from /usr/local/lib/libglib-2.0.so.0
No symbol table info available.
#5  0x28ae64a9 in g_main_context_check () from /usr/local/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x28ae6878 in g_main_loop_run () from /usr/local/lib/libglib-2.0.so.0
No symbol table info available.
#7  0x2828f89d in gtk_main () from /usr/local/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#8  0x080c8cb8 in main ()
No symbol table info available.

comment:11 Changed 10 years ago by ari

Can this be reopened?

comment:12 Changed 10 years ago by ranma42

Maybe the content of conn might be of some interest. Here it is:

(gdb) bt full
#0  0x294ffb5d in msn_soap_write_cb_internal (data=0x2a4ccd30, fd=13, 
    cond=PURPLE_INPUT_WRITE, initial=0) at soap.c:544
        conn = (MsnSoapConnection *) 0x2a4ccd30
        written = 1
#1  0x294ffce5 in msn_soap_write_cb (data=0x2a4ccd30, fd=13, 
    cond=PURPLE_INPUT_WRITE) at soap.c:580
No locals.
#2  0x080abdfb in docklet_ui_init ()
No symbol table info available.
#3  0x28b15159 in g_io_channel_unix_get_fd ()
   from /usr/local/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x28ae339e in g_main_context_dispatch ()
   from /usr/local/lib/libglib-2.0.so.0
No symbol table info available.
#5  0x28ae64a9 in g_main_context_check () from /usr/local/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x28ae6878 in g_main_loop_run () from /usr/local/lib/libglib-2.0.so.0
No symbol table info available.
#7  0x2828f89d in gtk_main () from /usr/local/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#8  0x080c8cb8 in main ()
No symbol table info available.
(gdb) p *conn
$3 = {session = 0x29f01080, host = 0x2a7e91e0 "ows.messenger.msn.com", 
  last_used = 1232973743, ssl = 0x0, connected = 0, event_handle = 0, 
  run_timer = 1686932, buf = 0x0, handled_len = 0, body_len = 0, 
  response_code = 0, headers_done = 0, close_when_done = 0, message = 0x0, 
  queue = 0x2a8cdd70, current_request = 0x0, unsafe_debug = 0}
(gdb) 

comment:13 Changed 10 years ago by Blue Ninja

FYI, this still happens for me reliably - anytime I send an offline MSN message, Pidgin crashes. I'm using 2.5.4.

comment:14 Changed 10 years ago by darkrain42

  • Status changed from closed to new
  • Summary changed from MSN crash on offline message to MSN crash sending offline message

comment:15 Changed 10 years ago by QuLogic

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.
I don't know if this will be helpful, but anyway...

comment:16 Changed 10 years ago by Blue Ninja

I've installed the debug build. Sending a few offline MSN messages has NOT crashed Pidgin yet - perhaps the problem only shows up after some duration of time (it usually runs for weeks on end before being restarted), so I'll keep you posted.

comment:17 Changed 10 years ago by QuLogic

Ticket #8374 has been marked as a duplicate of this ticket.

comment:18 Changed 10 years ago by QuLogic

I have a feeling the 're-use SOAP connections' patch from #5381 doesn't work correctly. It's apparently fixing a bug, though, so we can't just revert it entirely.

comment:19 Changed 10 years ago by Blue Ninja

It finally happened again, after several days of running. If it helps, in this case (though not in all previous cases) the person signed off right about the time I was typing the message, just before I pressed Enter. So, this could be a race condition where the message was sent before Pidgin "realized" the person went offline.

Here's the crash report:


Error occured on Monday, February 9, 2009 at 23:01:20.

Windows Version 5.1 Build 2600 Service Pack 3

C:\Program Files\Pidgin\pidgin.exe caused an Access Violation at location 6b89bb5b in module C:\Program Files\Pidgin\plugins\libmsn.dll Reading from location 00000004.

Registers: eax=18153738 ebx=18153738 ecx=00000000 edx=00000020 esi=194c5ac8 edi=02c67310 eip=6b89bb5b esp=0022f100 ebp=0022f118 iopl=0 nv up ei pl zr na po nc cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00010246

Call stack: 6B89BB5B C:\Program Files\Pidgin\plugins\libmsn.dll msn_soap_write_cb_internal c:/devel/pidgin-devel/pidgin-2.5.4/libpurple/protocols/msn/soap.c:544

C:\Program Files\Pidgin\pidgin.dll [2.5.4.0]

64A77862 C:\Program Files\Pidgin\pidgin.dll pidgin_io_invoke c:/devel/pidgin-devel/pidgin-2.5.4/pidgin/gtkeventloop.c:82

C:\Program Files\Common Files\GTK\2.0\bin\libglib-2.0-0.dll [2.18.3.0]

685E73E7 C:\Program Files\Common Files\GTK\2.0\bin\libglib-2.0-0.dll g_main_context_dispatch 685E8AB3 C:\Program Files\Common Files\GTK\2.0\bin\libglib-2.0-0.dll g_main_context_acquire 685E8D5A C:\Program Files\Common Files\GTK\2.0\bin\libglib-2.0-0.dll g_main_loop_run

C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.14.6.0]

6185EAFE C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_main

C:\Program Files\Pidgin\pidgin.dll [2.5.4.0]

64A90971 C:\Program Files\Pidgin\pidgin.dll pidgin_main c:/devel/pidgin-devel/pidgin-2.5.4/pidgin/gtkmain.c:891

C:\Program Files\Pidgin\pidgin.exe [2.5.4.0]

004023EC C:\Program Files\Pidgin\pidgin.exe WinMain? c:/devel/pidgin-devel/pidgin-2.5.4/pidgin/win32/winpidgin.c:749 00402A4A C:\Program Files\Pidgin\pidgin.exe WinMain? c:/devel/pidgin-devel/pidgin-2.5.4/pidgin/win32/winpidgin.c:628 00401247 C:\Program Files\Pidgin\pidgin.exe 004012B8 C:\Program Files\Pidgin\pidgin.exe

C:\WINXP\system32\kernel32.dll [5.1.2600.5512]

7C817067 C:\WINXP\system32\kernel32.dll RegisterWaitForInputIdle?

Changed 10 years ago by Blue Ninja

Latest crash report

Changed 10 years ago by Blue Ninja

My original report from 9 Feb - should have attached it instead of pasting into message.

comment:20 Changed 10 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:21 Changed 10 years ago by ari

This shouldn't have been closed.

comment:22 Changed 10 years ago by QuLogic

  • Status changed from closed to new

comment:23 Changed 10 years ago by QuLogic

  • Status changed from new to pending

I asked for a debug log, not a crash report.

comment:24 Changed 10 years ago by Blue Ninja

Ahh, my apologies. I've modified the startup icon to create a debug log, so I should be able to re-create the crash in a day or two.

comment:25 Changed 10 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:26 Changed 10 years ago by ranma42

Here is a debug log of a fault.

(14:45:06) soap: POST //OimWS/oim.asmx HTTP/1.1
SOAPAction: http://messenger.live.com/ws/2006/09/oim/Store2
Content-Type:text/xml; charset=utf-8
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Accept: */*
Host: ows.messenger.msn.com
Content-Length: 1907
Connection: Keep-Alive
Cache-Control: no-cache

<soap:Envelope xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance' xmlns:soap=
'http://schemas.xmlsoap.org/soap/envelope/' xmlns:xsd='http://www.w3.org/2001/XM
LSchema'>...
<soap:Body><MessageType xmlns='http://messenger.msn.com
/ws/2004/09/oim/'>text</MessageType><Content xmlns='http://messenger.msn.com/ws/
2004/09/oim/'>MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: base64
X-OIM-Message-Type: OfflineMessage
X-OIM-Run-Id: {42A5ABD4-2366-A55C-9A1B-544D12223F0F}
X-OIM-Sequence-Num: 2

bWkgc2VtYnJhIGNoZSBlc2lzdGEgU3lzdGVtLmFycmF5Y29weQ==</Content></soap:Body></soap
:Envelope>
(14:45:06) soap: not connected, reconnecting

Program received signal SIGSEGV, Segmentation fault.

Please reopen the ticket.

comment:27 Changed 10 years ago by khc

hmm, did you send 2 messages quickly?

comment:28 Changed 10 years ago by khc

Ticket #8717 has been marked as a duplicate of this ticket.

comment:29 Changed 10 years ago by ranma42

No, I received a few messages, then the buddy I was talking to went offline. Sending a single (offline) message caused the crash (even if I were to send more than one message, pidgin crashed after the first one).

comment:30 Changed 10 years ago by oji-sama

I would like to see this opened as well. (using Pidgin 2.5.5)

Pidgin seems to crash for me every single time if the user who I have been conversing with has sent me a message and enough time (a few hours) has passed before I try to answer with an offline message.

I did create a debug log about this, there appears to be quite the loop of soap envelopes resulting to

(18:33:24) GLib: MsgWaitForMultipleObjectsEx? failed: The parameter is incorrect. (18:33:24) GLib: Too many handles to wait for!

but i'll try to get a new log, this one has some jabber + other lines messing the readability (at least for me...)

comment:31 Changed 10 years ago by khc

  • Status changed from closed to new

Changed 10 years ago by oji-sama

Debug log with a few comments. Starts with me sending an offline message "pöö" to a user that had sent me a message several hours ago

Changed 10 years ago by pvuorela

backtrace for my crashes

comment:32 Changed 10 years ago by pvuorela

I'm experiencing this also. The above backtrace is from 2.5.5, but I just tested that self-compiled 2.5.6 has identical backtrace.

comment:33 Changed 10 years ago by pvuorela

Oh, sorry, just noticed it was a SIGPIPE that was caught.

comment:34 Changed 10 years ago by Blue Ninja

This still happens in 2.5.6 also. This time, the Pidgin process memory on XP SP3 shot up to a bit over a gig before it crashed. As always, this only seems to happen when it's been running for a few days or so - once I restart it, I can send offline messages for a while.

comment:35 Changed 10 years ago by Blue Ninja

Meant to include this in the previous message, my apologies for making 2 back-to-back posts. I know the MSN/Yahoo file transfer problems are different, but I just thought that since both offline messages and file transfers seem to work fine until after Pidgin has been running for a few days, perhaps there's a common underlying cause? Not sure if anyone else had already noticed that particular similarity, but maybe it will be a clue...

Changed 10 years ago by edman007

Backtrace, log and comments

comment:36 follow-up: Changed 10 years ago by edman007

Here is my debug log with comments backtrace, and, using 2.5.8, (i censored some things, i don't think its important, but if it is i may be able to provide the uncensored version as i censored almost all binary info from the server that i don't understand), also i do have the core dump and i can look into it as needed.

comment:37 in reply to: ↑ 36 Changed 10 years ago by QuLogic

  • Status changed from new to pending

Replying to edman007:

Here is my debug log with comments backtrace, and, using 2.5.8, (i censored some things, i don't think its important, but if it is i may be able to provide the uncensored version as i censored almost all binary info from the server that i don't understand), also i do have the core dump and i can look into it as needed.

Please remove unnecessary censoring and send to <username>@pidgin.im.

comment:38 Changed 10 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Changed 10 years ago by lemonairepaides

RPT of crash

comment:39 follow-up: Changed 10 years ago by lemonairepaides

Can this be reopened? Above is my RPT file capturing the crash.

comment:40 in reply to: ↑ 39 Changed 10 years ago by darkrain42

Replying to lemonairepaides:

Can this be reopened? Above is my RPT file capturing the crash.

Your crash report is different enough from the others that I think it warrants its own ticket. Please file a new ticket (and attach the crash report) as well as a debug log

comment:41 Changed 10 years ago by Blue Ninja

Pidgin 2.6.3 still exhibits this same behavior. I'd ike to attach a crash report, but first I'd like to ask that the installer not overwrite the icon if it exists. This problem happens to me after Pidgin has been connected for awhile (days, weeks). Before that, sending offline messages works fine. After that, it hangs, the memory usage climbs up to 100% (it just exceeded 2.5 GB on this PC), and it then crashes. At this point I go to get the crash report, find there is none because the installer from the last update replaced the startup icon properties with the default, and I change it back. And, for the last several versions, this same process has repeated itself. It's very frustrating because I almost never send an offline message, so this problem only occurs once every few months - by which time there's been an update, which turned off the debug logging.

Perhaps the creation of a debug log could be an option in the GUI, such that new installs don't overwrite this setting? While this problem is extremely easily reproducible, due to the usage pattern on this PC, I can almost never reproduce it. This is a development PC that is often restarted for various updates, or Pidgin is disconnected and then reconnected due to changing network connections. It is extremely rare that this PC will allow Pidgin to be connected for several days or more continuously, which is required to reproduce the problem. However, EVERY time that condition is met and I send an offline message, the crash occurs.

comment:42 Changed 9 years ago by malcolm

I am also still experiencing this issue, so I doubt that it has been fixed. Would it help if I submit a backtrace for this issue? I am currently running Pidgin through gdb, waiting for it to crash when I send an offline message, so I should have a backtrace available soon. Is there anything else that I can do to help you figure out what is wrong? Thanks.

comment:43 follow-up: Changed 9 years ago by darkrain42

The request was not for a backtrace, but for a debug log (run "pidgin -d", or better yet "gdb --args pidgin -d" and get the output of that)

comment:44 in reply to: ↑ 43 Changed 9 years ago by malcolm

Replying to darkrain42:

The request was not for a backtrace, but for a debug log (run "pidgin -d", or better yet "gdb --args pidgin -d" and get the output of that)

Ok, I can provide that instead. Do I need to be running a special Pidgin debug version (i.e. from the pidgin-dbg package of my Ubuntu distribution)?

comment:45 Changed 9 years ago by darkrain42

  • Status changed from closed to new

Only for the backtrace part (which is mostly helpful to confirm it's the same crash). pidgin -d will provide useful debug output ("a debug log") even without pidgin-dbg installed.

comment:46 Changed 9 years ago by darkrain42

  • Status changed from new to pending

comment:47 Changed 9 years ago by malcolm

Ok, I've finally managed to reproduce this. For some reason, it seems like when running as pidgin -d, the bug seems to almost never occur. Also, when the bug did finally occur, it did not consume all my memory before finally crashing; it crashed within a couple of seconds, without consuming all memory. (However, as you will see in the debug output below, a Segmentation Fault still did occur.) I'm not certain that these differences are just because of the -d flag, but I thought I'd just mention it; it may be worth investigating.

I sent an MSN message to an off-line buddy that had sent me a message. The sequence of events that occurred were as follows:

  1. Buddy came on-line.
  2. Buddy sends me two messages.
  3. Buddy goes off-line.
  4. I send a message to Buddy. The message was, in this case, a 9-digit number.
  5. Pidgin crashes soon after.

I've tried to summarize the debug output below. Alternatively, I could send you the full raw debug output. (I don't have permission to attach files to this post, unfortunately).

(18:04:45) soap: POST //OimWS/oim.asmx HTTP/1.1
SOAPAction: http://messenger.live.com/ws/2006/09/oim/Store2
Content-Type:text/xml; charset=utf-8
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Accept: */*
Host: ows.messenger.msn.com
Content-Length: 1868
Connection: Keep-Alive
Cache-Control: no-cache

<soap:Envelope xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance' xmlns:xsd='http://www.w3.org/2001/XMLSchema' xmlns:soap='http://schemas.xmlsoap.org/soap/envelope/'><soap:Header><From xmlns='http://messenger.msn.com/ws/2004/09/oim/' memberName='me123456@gmail.com' friendlyName='=?utf-8?B?bWxhbGtha2FAZ21haWwuY29t?=' xml:lang='en-US' proxy='MSNMSGR' msnpVer='MSNP15' buildVer='8.5.1288'/><To xmlns='http://messenger.msn.com/ws/2004/09/oim/' memberName='buddy123@hotmail.com'/><Ticket xmlns='http://messenger.msn.com/ws/2004/09/oim/' appid='PROD0119GSJUC$18' lockkey='3837e834607c5dc116d6981d685db469' passport='t=EwDQATIiAQAUno9QpucDnNi8T5syqJTstzjjm3WAALbD0kRZ5i7LdB5myOSM5xfqLg7HEuDBmmWnx3OhO40/50ocLvJ9Ac4eGgRrSYNTOxlzsocZkdeaga5pmJLhEbg8im/dkJzTdhaha6CJENIT5+0RA5Dblfr1yBfJzLffJcPO+3yoTLapVewoibUOuuKfVDXYgQvVnUIQxyAQ/OIwA2YAAAjhtp2zZ0suzCABa96teDZjA5v9XHBPob/kMABmawHfx4ku2wKVPrg0vxcUnm2QTbA+2HkNLWSykDVZq1nZnwJVxf+6gGldTWwc84gtJP/EIBa8AlbgTFuT4DMnX/6WXoJVSmFiK1tg6C8PeUEZ9zmxHb0BQsKEt0q8LrR7K4GBT36AvUabeQg/OUPnpvwkzhJA/jeria8ljy0zHJILhzQcwaRDmAJIaSHlKbhZ3Zv84muOpeUS1oe1IkDeBpmbQDLjtAT5LQTsFf/cFZ4TlddYGa3KGfZ+2MrVCX9z5GONOLODCTb2ujbfjRhMz3BNP5NR/Wa2yqOzTuaWAbPflM4kn2qwYlhpnXQRm1wADiCQ1TXDj04zKtIaZ9nPLHKIq0nUqidLTCGBzGv0TAE=&amp;p='/><Sequence xmlns='http://schemas.xmlsoap.org/ws/2003/03/rm'><Identifier xmlns='http://schemas.xmlsoap.org/ws/2002/07/utility'>http://messenger.msn.com</Identifier><MessageNumber>6</MessageNumber></Sequence></soap:Header><soap:Body><MessageType xmlns='http://messenger.msn.com/ws/2004/09/oim/'>text</MessageType><Content xmlns='http://messenger.msn.com/ws/2004/09/oim/'>MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: base64
X-OIM-Message-Type: OfflineMessage
X-OIM-Run-Id: {7386A3D9-B338-7267-30C8-9B4529C35FA6}
X-OIM-Sequence-Num: 6

MzAxMDIzNDky</Content></soap:Body></soap:Envelope>

...(The above output repeats itself multiple times.)...

(18:04:45) soap: read 830 bytes
(18:04:45) soap: current HTTP/1.1 500 Internal Server Error
Cache-Control: private
Content-Length: 614
Content-Type: text/xml; charset=utf-8
X-MSNSERVER: BY2MSG3020817
X-AspNet-Version: 2.0.50727
Date: Fri, 12 Mar 2010 02:04:44 GMT

<?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Header><Machine name="BY2MSG3020817" ver="9.31.3909.0" xmlns="http://messenger.msn.com/ws/2004/09/oim/" /></soap:Header><soap:Body><soap:Fault><faultcode xmlns:q0="http://messenger.msn.com/ws/2004/09/oim/">q0:SenderThrottleLimitExceeded</faultcode><faultstring>Exception of type 'System.Web.Services.Protocols.SoapException' was thrown.</faultstring><detail /></soap:Fault></soap:Body></soap:Envelope>
Segmentation fault
dns[10484]: Oops, father has gone, wait for me, wait...!

In the output above, I've changed the email addresses, so that bots don't get at them, etc. My email address has been changed to me123456@gmail.com and my friend's email address has been changed to buddy123@hotmail.com.

So judging from the debug output, it seems that Pidgin attempted to send my message multiple times to Buddy. Indeed, when I started Pidgin again, I opened the message log between me and Buddy, and here is what it said:

...
(06:04:31 PM) Me: 301023492
(06:04:45 PM) Message was not sent because messages are being sent too quickly.
(06:04:45 PM) 301023492

I hope this has been useful. If you need more information, please do not hesitate to ask, as I am eager for this issue to finally get resolved :).

comment:48 Changed 9 years ago by QuLogic

Please attach the full log. There should be no reason why you can't do so. Note, the attachment button is near the top of the page, not down in the entry here. If you can't get that to work, you can send the log to <username>@pidgin.im.

Changed 9 years ago by malcolm

Debug output of the crash, when running Pidgin as pidgin -d.

comment:49 Changed 9 years ago by malcolm

Oops, I didn't realize the button was at the top. It's now there, as pidgin-1.log.

comment:50 Changed 9 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:51 Changed 9 years ago by QuLogic

  • Status changed from closed to new

comment:52 follow-up: Changed 9 years ago by malcolm

By the way, if someone is looking into this defect, I would be happy to log on to MSN and try to reproduce the problem with you. If you would like to do that, just ask.

comment:53 in reply to: ↑ 52 Changed 9 years ago by salinasv

Replying to malcolm:

By the way, if someone is looking into this defect, I would be happy to log on to MSN and try to reproduce the problem with you. If you would like to do that, just ask.

That would be great. Sorry if it looks like nobody is taking care of this ticket. I have been working on other stuff and school is getting crazy.

Qulogic: What is your guess about this one?

comment:54 Changed 8 years ago by ari

This is reportedly fixed in newer versions.

comment:55 Changed 4 years ago by dx

  • Resolution set to out of date
  • Status changed from new to closed

Not sure what happened with this one but SOAP based offline messaging doesn't exist anymore. Closing.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!